summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-14 06:41:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-14 06:41:08 +0000
commit2e368569fc6180a07bc8c3904b8a58c09875b4f2 (patch)
tree950f1f35d3ba170393efc87be71417534f043ebe /net-misc
parentdon't assign default to S (diff)
downloadhistorical-2e368569fc6180a07bc8c3904b8a58c09875b4f2.tar.gz
historical-2e368569fc6180a07bc8c3904b8a58c09875b4f2.tar.bz2
historical-2e368569fc6180a07bc8c3904b8a58c09875b4f2.zip
don't assign default to S; IUSE
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/urlview/urlview-0.9.ebuild13
-rw-r--r--net-misc/whoischk/whoischk-0.2.3.ebuild7
-rw-r--r--net-misc/whoischk/whoischk-0.2.4.ebuild7
3 files changed, 13 insertions, 14 deletions
diff --git a/net-misc/urlview/urlview-0.9.ebuild b/net-misc/urlview/urlview-0.9.ebuild
index 060f3d5abe34..18b18124f2f1 100644
--- a/net-misc/urlview/urlview-0.9.ebuild
+++ b/net-misc/urlview/urlview-0.9.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.16 2004/06/25 00:17:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/urlview/urlview-0.9.ebuild,v 1.17 2004/07/14 06:41:08 mr_bones_ Exp $
inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="extracts urls from text and will send them to another app"
-SRC_URI="ftp://gd.tuwien.ac.at/infosys/mail/mutt/contrib/${P}.tar.gz"
HOMEPAGE="http://www.mutt.org"
-DEPEND=">=sys-libs/ncurses-5.2"
-RDEPEND=">=sys-libs/ncurses-5.2"
-KEYWORDS="x86 ppc sparc alpha s390"
+SRC_URI="ftp://gd.tuwien.ac.at/infosys/mail/mutt/contrib/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc sparc alpha s390"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2"
src_compile() {
epatch ${FILESDIR}/no-trailing-newline.patch
diff --git a/net-misc/whoischk/whoischk-0.2.3.ebuild b/net-misc/whoischk/whoischk-0.2.3.ebuild
index 97f23d405936..05cc756071d8 100644
--- a/net-misc/whoischk/whoischk-0.2.3.ebuild
+++ b/net-misc/whoischk/whoischk-0.2.3.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whoischk/whoischk-0.2.3.ebuild,v 1.2 2004/06/25 00:20:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whoischk/whoischk-0.2.3.ebuild,v 1.3 2004/07/14 06:38:23 mr_bones_ Exp $
DESCRIPTION="monitor a list of domains and report when there has been any change"
HOMEPAGE="http://downloads.afterdark.org.uk/whoischk/"
SRC_URI="http://downloads.afterdark.org.uk/whoischk/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-
-S="${WORKDIR}/${P}"
+IUSE=""
RDEPEND="app-shells/bash
net-misc/jwhois"
-
src_compile() {
for i in core/header.sh core/config.sh \
functions/rcfile.sh functions/display.sh functions/whois.sh \
diff --git a/net-misc/whoischk/whoischk-0.2.4.ebuild b/net-misc/whoischk/whoischk-0.2.4.ebuild
index 85a653e7e8bd..efb5636ffef1 100644
--- a/net-misc/whoischk/whoischk-0.2.4.ebuild
+++ b/net-misc/whoischk/whoischk-0.2.4.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whoischk/whoischk-0.2.4.ebuild,v 1.2 2004/06/25 00:20:20 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whoischk/whoischk-0.2.4.ebuild,v 1.3 2004/07/14 06:38:23 mr_bones_ Exp $
DESCRIPTION="monitor a list of domains and report when there has been any change"
HOMEPAGE="http://downloads.afterdark.org.uk/whoischk/"
SRC_URI="http://downloads.afterdark.org.uk/whoischk/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
-S="${WORKDIR}/${P}"
+IUSE=""
RDEPEND="app-shells/bash
net-misc/jwhois"
-
src_compile() {
sed -i -e 's|WHOIS=whois|WHOIS=jwhois|' whoischk || die
}