summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-03 16:31:50 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-03 16:31:50 +0000
commitfa881da131319e03e47ddb562e71bb498babf09e (patch)
tree4c6ee1e1da5a9d9436e48aac67d309d7c4878d33 /net-misc
parentNew versions to fix recent exploits. (diff)
downloadhistorical-fa881da131319e03e47ddb562e71bb498babf09e.tar.gz
historical-fa881da131319e03e47ddb562e71bb498babf09e.tar.bz2
historical-fa881da131319e03e47ddb562e71bb498babf09e.zip
old, sploity versions launched
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/files/digest-openssh-2.9_p21
-rw-r--r--net-misc/openssh/files/digest-openssh-2.9_p2-r61
-rwxr-xr-xnet-misc/openssh/files/sshd-run7
-rwxr-xr-xnet-misc/openssh/files/svc-sshd47
-rw-r--r--net-misc/openssh/openssh-2.9_p2-r6.ebuild48
-rw-r--r--net-misc/openssh/openssh-2.9_p2.ebuild48
6 files changed, 0 insertions, 152 deletions
diff --git a/net-misc/openssh/files/digest-openssh-2.9_p2 b/net-misc/openssh/files/digest-openssh-2.9_p2
deleted file mode 100644
index 9c8a76bd9f29..000000000000
--- a/net-misc/openssh/files/digest-openssh-2.9_p2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fb5ea44cb5a894bed7b610c5a517542d openssh-2.9p2.tar.gz
diff --git a/net-misc/openssh/files/digest-openssh-2.9_p2-r6 b/net-misc/openssh/files/digest-openssh-2.9_p2-r6
deleted file mode 100644
index 9c8a76bd9f29..000000000000
--- a/net-misc/openssh/files/digest-openssh-2.9_p2-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fb5ea44cb5a894bed7b610c5a517542d openssh-2.9p2.tar.gz
diff --git a/net-misc/openssh/files/sshd-run b/net-misc/openssh/files/sshd-run
deleted file mode 100755
index 7ca410ed8150..000000000000
--- a/net-misc/openssh/files/sshd-run
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-if [ ! -e /var/run/sshd.pid ]
-then
- /usr/sbin/sshd
- sleep 2
-fi
-exec envuidgid daemon /usr/bin/watchpid `cat /var/run/sshd.pid`
diff --git a/net-misc/openssh/files/svc-sshd b/net-misc/openssh/files/svc-sshd
deleted file mode 100755
index daa0324a67d3..000000000000
--- a/net-misc/openssh/files/svc-sshd
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/sh
-#RCUPDATE:2 3 4:75:This line is required for script management
-
-. /etc/rc.d/config/functions
-
-SERVICE="svc-openssh"
-opts="start stop"
-
-gen_keys() {
- if [ ! -e /etc/ssh/ssh_host_key ] ; then
- einfo "Generating Hostkey..."
- /usr/bin/ssh-keygen -b 1024 -f /etc/ssh/ssh_host_key -N ''
- fi
- if [ ! -e /etc/ssh/ssh_host_dsa_key ] ; then
- einfo "Generating DSA-Hostkey..."
- /usr/bin/ssh-keygen -d -f /etc/ssh/ssh_host_dsa_key -N ''
- fi
- if [ ! -e /etc/ssh/ssh_host_rsa_key ]
- then
- einfo "Generating RSA-Hostkey..."
- /usr/bin/ssh-keygen -t rsa -f /etc/ssh/ssh_host_rsa_key -N ''
- fi
-}
-
-start() {
- gen_keys
- ebegin "Starting $SERVICE"
- ln -sf ../services/${SERVICE} ${SVCDIR}/control/${SERVICE}
- eend $?
-}
-
-stop() {
- ebegin "Stopping $SERVICE"
- if [ -e ${SVCDIR}/control/${SERVICE} ]
- then
- /usr/bin/svc -dx ${SVCDIR}/control/${SERVICE}
- rm ${SVCDIR}/control/${SERVICE}
- fi
- eend $?
-}
-
-doservice ${@}
-
-
-
-
-
diff --git a/net-misc/openssh/openssh-2.9_p2-r6.ebuild b/net-misc/openssh/openssh-2.9_p2-r6.ebuild
deleted file mode 100644
index 60df7aad28fb..000000000000
--- a/net-misc/openssh/openssh-2.9_p2-r6.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: System Team <system@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2-r6.ebuild,v 1.1 2001/09/07 09:07:37 woodchip Exp $
-
-P=openssh-2.9p2
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Port of OpenBSD's free SSH release"
-SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${A}"
-HOMEPAGE="http://www.openssh.com/"
-
-DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-RDEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-src_compile() {
-
- local myconf
- use tcpd && myconf="${myconf} --with-tcp-wrappers"
- use tcpd || myconf="${myconf} --without-tcp-wrappers"
- use pam && myconf="${myconf} --with-pam"
- use pam || myconf="${myconf} --without-pam"
-
- ./configure --prefix=/usr --sysconfdir=/etc/ssh --host=${CHOST} \
- --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
- --with-ipv4-default --disable-suid-ssh ${myconf}
- assert
- make || die
-}
-
-src_install() {
-
- make install-files DESTDIR=${D} || die
- dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
-
- insinto /etc/pam.d
- newins ${FILESDIR}/sshd.pam.rc6 sshd
- exeinto /etc/init.d
- newexe ${FILESDIR}/sshd.rc6 sshd
-}
diff --git a/net-misc/openssh/openssh-2.9_p2.ebuild b/net-misc/openssh/openssh-2.9_p2.ebuild
deleted file mode 100644
index bb607886d881..000000000000
--- a/net-misc/openssh/openssh-2.9_p2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: System Team <system@gentoo.org>
-# /home/cvsroot/gentoo-x86/net-misc/openssh/openssh-2.9_p2.ebuild,v 1.3 2001/09/07 09:07:37 woodchip Exp
-
-P=openssh-2.9p2
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Port of OpenBSD's free SSH release"
-SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${A}"
-HOMEPAGE="http://www.openssh.com/"
-
-DEPEND="virtual/glibc sys-devel/perl sys-apps/groff
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-RDEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.73 )
- >=dev-libs/openssl-0.9.6
- sys-libs/zlib"
-
-src_compile() {
-
- local myconf
- use tcpd && myconf="${myconf} --with-tcp-wrappers"
- use tcpd || myconf="${myconf} --without-tcp-wrappers"
- use pam && myconf="${myconf} --with-pam"
- use pam || myconf="${myconf} --without-pam"
-
- ./configure --prefix=/usr --sysconfdir=/etc/ssh --host=${CHOST} \
- --libexecdir=/usr/lib/misc --mandir=/usr/share/man \
- --with-ipv4-default --disable-suid-ssh ${myconf}
- assert
- make || die
-}
-
-src_install() {
-
- make install-files DESTDIR=${D} || die
- dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
-
- insinto /etc/pam.d
- newins ${FILESDIR}/sshd.pam.rc5 sshd
- exeinto /etc/rc.d/init.d
- newexe ${FILESDIR}/sshd.rc5 sshd
-}