summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-23 12:37:03 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-23 12:37:03 +0000
commitc94c9dc00e3313a56bdbd03418deb0da7c193c36 (patch)
tree32e6737ae1c638df1e54b73e374cc8796ff37ffa /net-news/pan
parentThe rest of the files from phoen][x's new revision. (diff)
downloadhistorical-c94c9dc00e3313a56bdbd03418deb0da7c193c36.tar.gz
historical-c94c9dc00e3313a56bdbd03418deb0da7c193c36.tar.bz2
historical-c94c9dc00e3313a56bdbd03418deb0da7c193c36.zip
Removed the libgnome dependence. Closes bug #4003
Diffstat (limited to 'net-news/pan')
-rw-r--r--net-news/pan/ChangeLog9
-rw-r--r--net-news/pan/files/digest-pan-0.12.0-r11
-rw-r--r--net-news/pan/pan-0.12.0-r1.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index c433166b2899..8a3c10ee63a8 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.9 2002/06/19 16:49:48 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.10 2002/06/23 12:37:03 stroke Exp $
+
+*pan-0.12.0-r1 (23 Jun 2002)
+
+ 23 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> pan-0.12.0-r1.ebuild:
+
+ Removed libgnome depencence. Closes bug #4003
+
*pan-0.12.0 (19 Jun 2002)
diff --git a/net-news/pan/files/digest-pan-0.12.0-r1 b/net-news/pan/files/digest-pan-0.12.0-r1
new file mode 100644
index 000000000000..501c9aa95353
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.12.0-r1
@@ -0,0 +1 @@
+MD5 2a3c82d8521b91f90b9a069b0e6b0946 pan-0.12.0.tar.bz2 1642788
diff --git a/net-news/pan/pan-0.12.0-r1.ebuild b/net-news/pan/pan-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..4ac613dbdb6d
--- /dev/null
+++ b/net-news/pan/pan-0.12.0-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.12.0-r1.ebuild,v 1.1 2002/06/23 12:37:03 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/0.12.0/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+LICENSE="GPL-2"
+SLOT="0"
+
+#libglade
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ dev-libs/libxml2"
+
+DEPEND="$RDEPEND"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ libtoolize --copy --force
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}
+
+