summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-30 23:55:35 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-30 23:55:35 +0000
commit1960f3faabe722430250d9401ac18df1e081207a (patch)
treeb3b3287326240bcf9180196d5324b585ce02ef35 /net-news
parentNew ebuild for CCMSN (diff)
downloadhistorical-1960f3faabe722430250d9401ac18df1e081207a.tar.gz
historical-1960f3faabe722430250d9401ac18df1e081207a.tar.bz2
historical-1960f3faabe722430250d9401ac18df1e081207a.zip
Fixed a problem with the libxml-2 dependence. Closes bug #4368
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/ChangeLog9
-rw-r--r--net-news/pan/files/digest-pan-0.12.0-r21
-rw-r--r--net-news/pan/pan-0.12.0-r2.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index 8a3c10ee63a8..dbbfe3f57e52 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.10 2002/06/23 12:37:03 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.11 2002/06/30 23:55:35 stroke Exp $
+
+*pan-0.12.0-r2 (01 Jul 2002)
+
+ 01 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> pan-0.12.0-r2.ebuild:
+
+ Fixed a problem with the libxml-2 dependence. Closes bug #4368
+
*pan-0.12.0-r1 (23 Jun 2002)
diff --git a/net-news/pan/files/digest-pan-0.12.0-r2 b/net-news/pan/files/digest-pan-0.12.0-r2
new file mode 100644
index 000000000000..501c9aa95353
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.12.0-r2
@@ -0,0 +1 @@
+MD5 2a3c82d8521b91f90b9a069b0e6b0946 pan-0.12.0.tar.bz2 1642788
diff --git a/net-news/pan/pan-0.12.0-r2.ebuild b/net-news/pan/pan-0.12.0-r2.ebuild
new file mode 100644
index 000000000000..29719dfcf3d3
--- /dev/null
+++ b/net-news/pan/pan-0.12.0-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.12.0-r2.ebuild,v 1.1 2002/06/30 23:55:35 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/0.12.0/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+LICENSE="GPL-2"
+SLOT="0"
+
+#libglade
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22"
+
+DEPEND="$RDEPEND"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ libtoolize --copy --force
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --enable-debug=yes \
+ ${myconf} || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/lib \
+ install || die "installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}
+
+