summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-04-29 16:15:18 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-04-29 16:15:18 +0000
commit7f127ba2a7a73b2c6e80be5c88f4146bb580004f (patch)
tree9583df688aae610542d5f9fb0a64ddb71eaa1efb /net-news
parentAdding ~ia64 on Ned's request. (diff)
downloadhistorical-7f127ba2a7a73b2c6e80be5c88f4146bb580004f.tar.gz
historical-7f127ba2a7a73b2c6e80be5c88f4146bb580004f.tar.bz2
historical-7f127ba2a7a73b2c6e80be5c88f4146bb580004f.zip
Bump to 1.2.13
* Fixes a significant memory leak when dropping items from cache reported by several users. * Changes the new item counting to a simpler counting statistic so that on subsequent updates of the same feed might present a lower new item number, but which is a bit faster. * Added new Catalan default feed list (Gil Forcada) Package-Manager: portage-2.1.2.5
Diffstat (limited to 'net-news')
-rw-r--r--net-news/liferea/ChangeLog14
-rw-r--r--net-news/liferea/files/digest-liferea-1.2.133
-rw-r--r--net-news/liferea/liferea-1.2.13.ebuild88
3 files changed, 104 insertions, 1 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index 435f529741da..84774de5424a 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-news/liferea
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.96 2007/04/28 01:20:53 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.97 2007/04/29 16:15:18 dang Exp $
+
+*liferea-1.2.13 (29 Apr 2007)
+
+ 29 Apr 2007; Daniel Gryniewicz <dang@gentoo.org> +liferea-1.2.13.ebuild:
+ Bump to 1.2.13
+ * Fixes a significant memory leak when dropping items
+ from cache reported by several users.
+ * Changes the new item counting to a simpler counting
+ statistic so that on subsequent updates of the same
+ feed might present a lower new item number, but which
+ is a bit faster.
+ * Added new Catalan default feed list (Gil Forcada)
*liferea-1.2.12b (28 Apr 2007)
diff --git a/net-news/liferea/files/digest-liferea-1.2.13 b/net-news/liferea/files/digest-liferea-1.2.13
new file mode 100644
index 000000000000..b4d57c1cfa84
--- /dev/null
+++ b/net-news/liferea/files/digest-liferea-1.2.13
@@ -0,0 +1,3 @@
+MD5 cbb1bf128494b560f808a0dabdace9aa liferea-1.2.13.tar.gz 1426401
+RMD160 851667673afa00d9b9b89abe0ade124db1641948 liferea-1.2.13.tar.gz 1426401
+SHA256 c5b136b314337792d57a31dcbf53d74c4d06bf52e73a5c3e359c91e8c1dc3a49 liferea-1.2.13.tar.gz 1426401
diff --git a/net-news/liferea/liferea-1.2.13.ebuild b/net-news/liferea/liferea-1.2.13.ebuild
new file mode 100644
index 000000000000..e6648dea0b80
--- /dev/null
+++ b/net-news/liferea/liferea-1.2.13.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.2.13.ebuild,v 1.1 2007/04/29 16:15:18 dang Exp $
+
+WANT_AUTOMAKE=1.7
+WANT_AUTOCONF=latest
+inherit gnome2 flag-o-matic eutils autotools
+
+DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo/etc feeds"
+HOMEPAGE="http://liferea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus firefox gtkhtml gnutls libnotify networkmanager seamonkey xulrunner"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ x11-libs/pango
+ >=gnome-base/gconf-2
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.19
+ >=dev-libs/glib-2
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( firefox? ( www-client/mozilla-firefox ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( www-client/seamonkey ) ) )
+ !amd64? ( !xulrunner? ( !firefox? ( !seamonkey? ( =gnome-extra/gtkhtml-2* ) ) ) )
+ !amd64? ( gtkhtml? ( =gnome-extra/gtkhtml-2* ) )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ networkmanager? ( net-misc/networkmanager )
+ gnutls? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${PN}-1.1.0-libnotify.patch"
+
+ eautoreconf || die "Autoreconf failed"
+}
+
+pkg_setup() {
+ # On amd64, gtkhtml isn't supported. You need one of the gecko use flags
+ if use amd64 && ! use firefox && ! use seamonkey && ! use xulrunner; then
+ elog "gtkhtml is no longer supported on amd64; you will need to select"
+ elog "one of the gecko backends to use liferea"
+ die "You must enable on of the gecko backends on amd64"
+ fi
+
+ # if you don't choose a gecko to use, we will automatically
+ # use gtkhtml2 as the backend except on amd64 (where we failed above)
+ if ! use seamonkey && ! use firefox && ! use xulrunner && ! use amd64 ; then
+ G2CONF="${G2CONF} --enable-gtkhtml2"
+ elif ! use amd64 && use gtkhtml ; then
+ G2CONF="${G2CONF} --enable-gtkhtml2"
+ else
+ G2CONF="${G2CONF} --disable-gtkhtml2"
+ fi
+
+ # we prefer xulrunner over firefox over seamonkey
+ if use xulrunner ; then
+ G2CONF="${G2CONF} --enable-xulrunner"
+ elif use firefox ; then
+ G2CONF="${G2CONF} --enable-gecko=firefox"
+ elif use seamonkey ; then
+ G2CONF="${G2CONF} --enable-gecko=seamonkey"
+ else
+ G2CONF="${G2CONF} --disable-gecko"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_enable dbus) \
+ $(use_enable gnutls) \
+ $(use_enable libnotify) \
+ $(use_enable networkmanager nm)"
+}
+
+src_install() {
+ gnome2_src_install
+ rm -f ${D}/usr/bin/${PN}
+ mv ${D}/usr/bin/${PN}-bin ${D}/usr/bin/${PN}
+}