summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-28 14:31:15 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-28 14:31:15 +0000
commit5bc8cf6a23f5651a9208f31673fa1987c5163144 (patch)
tree12f8cee808a5a0665b9cb1d4a4ba165badeddfe1 /net-p2p
parentFix slot-dep on gtk+ (diff)
downloadhistorical-5bc8cf6a23f5651a9208f31673fa1987c5163144.tar.gz
historical-5bc8cf6a23f5651a9208f31673fa1987c5163144.tar.bz2
historical-5bc8cf6a23f5651a9208f31673fa1987c5163144.zip
Fix slot-dep on gtk+
Package-Manager: portage-2.1.9.44/cvs/Linux x86_64
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog8
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild8
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild10
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-9999.ebuild10
-rw-r--r--net-p2p/sancho-bin/ChangeLog8
-rw-r--r--net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild8
-rw-r--r--net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild8
-rw-r--r--net-p2p/tvrss/ChangeLog7
-rw-r--r--net-p2p/tvrss/tvrss-1.8_beta.ebuild8
9 files changed, 48 insertions, 27 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index cdbdaf8f780d..98ca63c56450 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/linuxdcpp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.42 2010/07/18 18:04:52 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.43 2011/03/28 14:30:10 nirbheek Exp $
+
+ 28 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ linuxdcpp-1.0.3.ebuild, linuxdcpp-1.0.3-r1.ebuild, linuxdcpp-9999.ebuild:
+ Fix slot-dep on gtk+
18 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
linuxdcpp-1.0.3-r1.ebuild, linuxdcpp-9999.ebuild:
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
index dd39c9ae9d39..5cc631eeebe2 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild,v 1.3 2010/07/18 18:04:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild,v 1.4 2011/03/28 14:30:10 nirbheek Exp $
EAPI=2
@@ -14,8 +14,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="debug"
-RDEPEND=">=gnome-base/libglade-2.4
- >=x11-libs/gtk+-2.6
+RDEPEND=">=gnome-base/libglade-2.4:2.0
+ >=x11-libs/gtk+-2.6:2
app-arch/bzip2
dev-libs/openssl"
DEPEND="${RDEPEND}
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
index f55c0e5bd01e..c35d28591d6f 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.4 2010/06/18 22:09:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.5 2011/03/28 14:30:10 nirbheek Exp $
+
+EAPI="1"
inherit eutils
@@ -12,8 +14,8 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
IUSE="debug"
-RDEPEND=">=gnome-base/libglade-2.4
- >=x11-libs/gtk+-2.6
+RDEPEND=">=gnome-base/libglade-2.4:2.0
+ >=x11-libs/gtk+-2.6:2
app-arch/bzip2
dev-libs/openssl"
DEPEND="${RDEPEND}
diff --git a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
index 9b88ff8f7111..e46acd62301d 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.14 2010/07/18 18:04:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.15 2011/03/28 14:30:10 nirbheek Exp $
+
+EAPI="1"
inherit bzr eutils
@@ -16,8 +18,8 @@ EBZR_REPO_URI="lp:linuxdcpp"
S=${WORKDIR}/${P}
-RDEPEND=">=gnome-base/libglade-2.4
- >=x11-libs/gtk+-2.6
+RDEPEND=">=gnome-base/libglade-2.4:2.0
+ >=x11-libs/gtk+-2.6:2
app-arch/bzip2
dev-libs/openssl"
DEPEND="${RDEPEND}
diff --git a/net-p2p/sancho-bin/ChangeLog b/net-p2p/sancho-bin/ChangeLog
index 6f7e81d8bd77..3d08b4efce8a 100644
--- a/net-p2p/sancho-bin/ChangeLog
+++ b/net-p2p/sancho-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/sancho-bin
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.46 2008/01/29 16:26:44 rich0 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/ChangeLog,v 1.47 2011/03/28 14:30:52 nirbheek Exp $
+
+ 28 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ sancho-bin-0.9.4.58.ebuild, sancho-bin-0.9.4.58-r1.ebuild:
+ Fix slot-dep on gtk+
29 Jan 2008; Richard Freeman <rich0@gentoo.org>
sancho-bin-0.9.4.58-r1.ebuild:
diff --git a/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild b/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild
index 795f484c681b..8f2a7cc0f225 100644
--- a/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild
+++ b/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild,v 1.5 2008/01/29 16:26:44 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.58-r1.ebuild,v 1.6 2011/03/28 14:30:52 nirbheek Exp $
+
+EAPI="1"
inherit eutils
@@ -28,7 +30,7 @@ IUSE="java"
DEPEND="x11-libs/libXxf86vm
x11-libs/libXext
x11-libs/libX11
- >=x11-libs/gtk+-2
+ x11-libs/gtk+:2
amd64? ( !java? ( >=app-emulation/emul-linux-x86-baselibs-1.0
>=app-emulation/emul-linux-x86-gtklibs-1.0 ) )
java? ( >=virtual/jre-1.5 )"
diff --git a/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild b/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild
index 8c69a9e9cc4f..a23db734c89b 100644
--- a/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild
+++ b/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild,v 1.7 2007/10/31 19:46:39 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/sancho-bin/sancho-bin-0.9.4.58.ebuild,v 1.8 2011/03/28 14:30:52 nirbheek Exp $
+
+EAPI="1"
inherit eutils
@@ -20,7 +22,7 @@ IUSE=""
DEPEND="x11-libs/libXxf86vm
x11-libs/libXext
x11-libs/libX11
- >=x11-libs/gtk+-2
+ x11-libs/gtk+:2
amd64? ( >=app-emulation/emul-linux-x86-baselibs-1.0
>=app-emulation/emul-linux-x86-gtklibs-1.0 )"
diff --git a/net-p2p/tvrss/ChangeLog b/net-p2p/tvrss/ChangeLog
index a30651363ff0..ba7d1c918193 100644
--- a/net-p2p/tvrss/ChangeLog
+++ b/net-p2p/tvrss/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/tvrss
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tvrss/ChangeLog,v 1.2 2007/03/19 17:39:25 kloeri Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tvrss/ChangeLog,v 1.3 2011/03/28 14:31:15 nirbheek Exp $
+
+ 28 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> tvrss-1.8_beta.ebuild:
+ Fix slot-dep on gtk+
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove squinky86 from metadata.xml due to retirement.
diff --git a/net-p2p/tvrss/tvrss-1.8_beta.ebuild b/net-p2p/tvrss/tvrss-1.8_beta.ebuild
index 5543dc144864..f4c1347019a8 100644
--- a/net-p2p/tvrss/tvrss-1.8_beta.ebuild
+++ b/net-p2p/tvrss/tvrss-1.8_beta.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tvrss/tvrss-1.8_beta.ebuild,v 1.1 2006/06/14 00:02:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/tvrss/tvrss-1.8_beta.ebuild,v 1.2 2011/03/28 14:31:15 nirbheek Exp $
+
+EAPI="2"
inherit versionator
@@ -14,7 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-DEPEND="x11-libs/gtk+
+DEPEND="x11-libs/gtk+:2
>=dev-lang/perl-5.8.6
dev-perl/XML-RAI
dev-perl/glib-perl