summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-16 19:14:02 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-16 19:14:02 +0000
commit60c5a6bf8eca6e88c042f13c6783de924461ae6f (patch)
treef4111f4b544e083c259b2801f5d20ac8d6bcd32e /net-p2p
parentInitial work on bug 43851 (diff)
downloadhistorical-60c5a6bf8eca6e88c042f13c6783de924461ae6f.tar.gz
historical-60c5a6bf8eca6e88c042f13c6783de924461ae6f.tar.bz2
historical-60c5a6bf8eca6e88c042f13c6783de924461ae6f.zip
Made the systray4j DEPEND require the kde use flag.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus-bin/ChangeLog6
-rw-r--r--net-p2p/azureus-bin/Manifest4
-rw-r--r--net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild14
3 files changed, 17 insertions, 7 deletions
diff --git a/net-p2p/azureus-bin/ChangeLog b/net-p2p/azureus-bin/ChangeLog
index 16f4c74affab..7c897672823e 100644
--- a/net-p2p/azureus-bin/ChangeLog
+++ b/net-p2p/azureus-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/azureus-bin
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/ChangeLog,v 1.5 2004/03/14 01:32:19 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/ChangeLog,v 1.6 2004/03/16 19:14:02 eradicator Exp $
+
+ 16 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ azureus-bin-2.0.8.0a.ebuild:
+ Made the systray4j DEPEND require the kde use flag.
*azureus-bin-2.0.8.0a (13 Mar 2004)
diff --git a/net-p2p/azureus-bin/Manifest b/net-p2p/azureus-bin/Manifest
index 44cadea547a5..2557abbf3169 100644
--- a/net-p2p/azureus-bin/Manifest
+++ b/net-p2p/azureus-bin/Manifest
@@ -1,6 +1,6 @@
MD5 3d5dc27f2b59c9471eaf7d6a8a83ac7a azureus-bin-2.0.7.1_pre20040224.ebuild 3519
-MD5 e2e676b9eea8572375c9405e1d6b0232 azureus-bin-2.0.8.0a.ebuild 3258
-MD5 5066de8fec62942f5ab5f9ed5e71134a ChangeLog 979
+MD5 b4c0a83cdb02ca2b9e6196fce003adb2 azureus-bin-2.0.8.0a.ebuild 3426
+MD5 3fb044c1ec08f11f60b9ed22e51f8f9e ChangeLog 1122
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 492b5db31f8be8a352cc1eb3adb23ba1 files/digest-azureus-bin-2.0.7.1_pre20040224 299
MD5 0b7b4678fdb7cc0211a089ce94dfc87f files/azureus-bin-2.0.8.0a-gentoo.sh 1768
diff --git a/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild b/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild
index 4fddfd389ca3..740da50cecb0 100644
--- a/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild
+++ b/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild,v 1.1 2004/03/14 01:32:19 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/azureus-bin-2.0.8.0a.ebuild,v 1.2 2004/03/16 19:14:02 eradicator Exp $
inherit eutils
@@ -22,14 +22,14 @@ SLOT="0"
# Still in progress... trying to get most external classes in through DEPENDs rather than
KEYWORDS="~x86"
-IUSE="gtk"
+IUSE="gtk kde"
DEPEND="virtual/glibc"
RDEPEND="${DEPEND}
dev-java/commons-cli
dev-java/log4j
- dev-java/systray4j
+ kde? ( dev-java/systray4j )
dev-java/junit
gtk? ( =x11-libs/gtk+-2* )
!gtk? ( =x11-libs/openmotif-2.1* )
@@ -39,7 +39,12 @@ RDEPEND="${DEPEND}
PROGRAM_DIR="/usr/lib/${MY_PN}"
src_unpack() {
- if [ `use gtk` ] ; then
+ if ! use kde; then
+ einfo "The kde use flag is off, so the systray support will be disabled."
+ einfo "kde is required to build dev-java/systray4j."
+ fi
+
+ if use gtk; then
unpack Azureus_${PV}_linux.GTK.tar.bz2
echo
einfo "Using the GTK Azureus package, to use the Motif package"
@@ -111,4 +116,5 @@ pkg_postinst() {
einfo "the setting in ~/.azureus/gentoo.config will be properly used, but"
einfo "you should report all bugs pertaining to the CVS release to the"
einfo "azureus developers and not Gentoo."
+ echo
}