summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-08-30 01:33:02 +0000
committerJon Hood <squinky86@gentoo.org>2006-08-30 01:33:02 +0000
commit6e4eede659c5a3108ea116da2741857ff7a60b74 (patch)
treebdf280c23e501a0915e2b4fb40353ae7c14df97a /net-p2p
parentUpdated atlas-3.7.15-shared-libs.patch in order for it to also work with the ... (diff)
downloadhistorical-6e4eede659c5a3108ea116da2741857ff7a60b74.tar.gz
historical-6e4eede659c5a3108ea116da2741857ff7a60b74.tar.bz2
historical-6e4eede659c5a3108ea116da2741857ff7a60b74.zip
Version bump, amd64 fix for sha1, bug #139915.
Package-Manager: portage-2.1.1_rc1-r1
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gift-gnutella/ChangeLog10
-rw-r--r--net-p2p/gift-gnutella/files/digest-gift-gnutella-0.0.113
-rw-r--r--net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild48
3 files changed, 60 insertions, 1 deletions
diff --git a/net-p2p/gift-gnutella/ChangeLog b/net-p2p/gift-gnutella/ChangeLog
index 6c8d939b1e5a..4036155f17b6 100644
--- a/net-p2p/gift-gnutella/ChangeLog
+++ b/net-p2p/gift-gnutella/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/gift-gnutella
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/ChangeLog,v 1.27 2006/05/05 21:51:13 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/ChangeLog,v 1.28 2006/08/30 01:33:02 squinky86 Exp $
+
+*gift-gnutella-0.0.11 (30 Aug 2006)
+
+ 30 Aug 2006; Jon Hood <squinky86@gentoo.org>
+ -files/gift-gnutella-gcc35.patch, -gift-gnutella-0.0.9.2-r1.ebuild,
+ -gift-gnutella-0.0.10.ebuild, +gift-gnutella-0.0.11.ebuild:
+ Version bump, amd64 fix for sha1, bug #139915. Thanks Brad DeMorrow
+ <syllogism711@gmail.com>.
05 May 2006; <tcort@gentoo.org> gift-gnutella-0.0.10.1.ebuild:
Added ~alpha keyword wrt Bug #132197.
diff --git a/net-p2p/gift-gnutella/files/digest-gift-gnutella-0.0.11 b/net-p2p/gift-gnutella/files/digest-gift-gnutella-0.0.11
new file mode 100644
index 000000000000..1dc1d4959edb
--- /dev/null
+++ b/net-p2p/gift-gnutella/files/digest-gift-gnutella-0.0.11
@@ -0,0 +1,3 @@
+MD5 279c7dc0121b3b7e209b09c98d10f17f gift-gnutella-0.0.11.tar.bz2 405742
+RMD160 f9c39fc8c1e056483b3cc82c5e801efeee1cdf2a gift-gnutella-0.0.11.tar.bz2 405742
+SHA256 5a28fd53ad617a6acdc3042144829e74822510d80963a6ca35e7d256d5a06f86 gift-gnutella-0.0.11.tar.bz2 405742
diff --git a/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
new file mode 100644
index 000000000000..48b5cf46f252
--- /dev/null
+++ b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild,v 1.1 2006/08/30 01:33:02 squinky86 Exp $
+
+inherit eutils
+
+IUSE="xml"
+
+DESCRIPTION="The giFT Gnutella plugin"
+HOMEPAGE="http://gift.sf.net/"
+SRC_URI="mirror://sourceforge/gift/${P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2"
+
+RDEPEND=">=net-p2p/gift-0.11.6"
+
+src_compile() {
+ econf $(use_with xml libxml) || die "failed to configure"
+ emake || die "failed to build"
+}
+
+src_install() {
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/$(get_libdir)/giFT \
+ datadir=${D}/usr/share \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+}
+
+pkg_postinst() {
+ einfo "It is recommended that you re-run gift-setup as"
+ einfo "the user you will run the giFT daemon as:"
+ einfo "\tgift-setup"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/giftd.conf configuration file:"
+ einfo "plugins = Gnutella"
+ echo
+ einfo "To update your caches, run:"
+ einfo "\tsh /usr/portage/net-p2p/${PN}/files/cacheupdate.sh"
+}