summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-01 14:46:53 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-01 14:46:53 +0000
commitd350bd5d2c4b4c85e2b706a702e34df10b1f68ca (patch)
treeb2ae2d9e0bf648a92f238bbb1d96f84127b698f5 /net-p2p
parentfixed bug #18457 (diff)
downloadhistorical-d350bd5d2c4b4c85e2b706a702e34df10b1f68ca.tar.gz
historical-d350bd5d2c4b4c85e2b706a702e34df10b1f68ca.tar.bz2
historical-d350bd5d2c4b4c85e2b706a702e34df10b1f68ca.zip
mailcap fixes
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog5
-rw-r--r--net-p2p/bittorrent/bittorrent-3.2.1.ebuild21
2 files changed, 18 insertions, 8 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index d1b0045f94c0..c6e9ddd2639a 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.4 2003/03/31 20:09:19 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.5 2003/04/01 14:46:53 liquidx Exp $
*bittorrent-3.2.1 (31 Mar 2003)
+ 01 Apr 2003; Alastair Tse <liquidx@gentoo.org> bittorrent-3.2.1.ebuild:
+ fixed mailcap entry to something more robust. also fixes #18569.
+
31 Mar 2003; Alastair Tse <liquidx@gentoo.org> bittorrent-3.2.1.ebuild:
version bump
diff --git a/net-p2p/bittorrent/bittorrent-3.2.1.ebuild b/net-p2p/bittorrent/bittorrent-3.2.1.ebuild
index edbdb76db3ba..ab74b704af25 100644
--- a/net-p2p/bittorrent/bittorrent-3.2.1.ebuild
+++ b/net-p2p/bittorrent/bittorrent-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.2.1.ebuild,v 1.1 2003/03/31 20:09:19 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.2.1.ebuild,v 1.2 2003/04/01 14:46:53 liquidx Exp $
inherit distutils
@@ -15,18 +15,25 @@ KEYWORDS="~x86"
IUSE=""
-DEPEND=">=dev-python/wxPython-2.2
+RDEPEND=">=dev-python/wxPython-2.2
>=dev-lang/python-2.1"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
mydoc="FAQ.txt README.txt LICENSE.txt"
pkg_postinst() {
- # add entry to mailcap if it doesn't already exist
- if ! grep "application/x-bittorrent" /etc/mailcap;
- then
- einfo "adding application/x-bittorrent to /etc/mailcap..."
- echo 'application/x-bittorrent; /usr/bin/btdownloadprefetched.py %s; test=test -n "$DISPLAY"' >> /etc/mailcap
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if [ -n "`grep 'application/x-bittorrent' /etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," /etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> /etc/mailcap
fi
}