summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-16 18:07:57 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-16 18:07:57 +0000
commit580faf122f7e524be66b525fd48609fdd8c5e535 (patch)
tree43eda2ba83202f86abbb48ca41151164b252964b /net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild
parentAllow to build without dvbpsi (diff)
downloadhistorical-580faf122f7e524be66b525fd48609fdd8c5e535.tar.gz
historical-580faf122f7e524be66b525fd48609fdd8c5e535.tar.bz2
historical-580faf122f7e524be66b525fd48609fdd8c5e535.zip
Bump fixing a crash and a security issue, remove old.
Package-Manager: portage-2.1.9.40/cvs/Linux x86_64
Diffstat (limited to 'net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild')
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild
new file mode 100644
index 000000000000..5b6e633c0f97
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.10.5.ebuild,v 1.1 2011/02/16 18:07:57 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils python
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.11.16
+ net-libs/libsoup:2.4[ssl]
+ >=net-libs/libnice-0.0.11
+ >=net-libs/gnutls-2.10.2
+ dev-db/sqlite:3
+ dev-libs/libxml2
+ !<net-im/telepathy-mission-control-5.5.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-lang/python-2.5
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ # Twisted tests fail, upstream bug #30565
+ emake -C tests check-TESTS || die "tests failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog README || die "dodoc failed"
+}