summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-18 12:27:00 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-18 12:27:00 +0000
commit55586dc69378226b8361757a79e4fbdfb44ff8fd (patch)
tree2fcc59dc917eda04de5627c3266dee8aa6cf2689 /net-wireless
parentVersion bump wrt #305109 by "hitachi". (diff)
downloadhistorical-55586dc69378226b8361757a79e4fbdfb44ff8fd.tar.gz
historical-55586dc69378226b8361757a79e4fbdfb44ff8fd.tar.bz2
historical-55586dc69378226b8361757a79e4fbdfb44ff8fd.zip
Version bump
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/ChangeLog7
-rw-r--r--net-wireless/bluez/bluez-4.66.ebuild169
-rw-r--r--net-wireless/gnome-bluetooth/ChangeLog10
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch23
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch34
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild60
-rw-r--r--net-wireless/gnome-bluetooth/metadata.xml3
7 files changed, 304 insertions, 2 deletions
diff --git a/net-wireless/bluez/ChangeLog b/net-wireless/bluez/ChangeLog
index 6933e242e76f..8e6218943aba 100644
--- a/net-wireless/bluez/ChangeLog
+++ b/net-wireless/bluez/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/bluez
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.39 2010/06/11 22:25:13 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/ChangeLog,v 1.40 2010/06/18 12:27:00 pacho Exp $
+
+*bluez-4.66 (18 Jun 2010)
+
+ 18 Jun 2010; Pacho Ramos <pacho@gentoo.org> +bluez-4.66.ebuild:
+ Version bump fixing some bugs and regressions.
11 Jun 2010; Joseph Jezak <josejx@gentoo.org> bluez-4.63.ebuild,
bluez-4.64.ebuild, bluez-4.65.ebuild:
diff --git a/net-wireless/bluez/bluez-4.66.ebuild b/net-wireless/bluez/bluez-4.66.ebuild
new file mode 100644
index 000000000000..a786c144d70b
--- /dev/null
+++ b/net-wireless/bluez/bluez-4.66.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/bluez-4.66.ebuild,v 1.1 2010/06/18 12:27:00 pacho Exp $
+
+EAPI="2"
+
+inherit autotools multilib eutils
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+IUSE="alsa caps +consolekit cups debug gstreamer old-daemons pcmcia test-programs usb"
+
+CDEPEND="alsa? (
+ media-libs/alsa-lib[alsa_pcm_plugins_extplug,alsa_pcm_plugins_ioplug]
+ )
+ caps? ( >=sys-libs/libcap-ng-0.6.2 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10 )
+ usb? ( dev-libs/libusb )
+ cups? ( net-print/cups )
+ sys-fs/udev
+ >=dev-libs/glib-2.14
+ sys-apps/dbus
+ media-libs/libsndfile
+ >=dev-libs/libnl-1.1
+ !net-wireless/bluez-libs
+ !net-wireless/bluez-utils"
+DEPEND="sys-devel/flex
+ >=dev-util/pkgconfig-0.20
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ consolekit? ( sys-auth/pambase[consolekit] )
+ test-programs? (
+ dev-python/dbus-python
+ dev-python/pygobject )"
+
+pkg_setup() {
+ if ! use consolekit; then
+ enewgroup plugdev
+ fi
+}
+
+src_prepare() {
+ if ! use consolekit; then
+ # No consolekit for at_console etc, so we grant plugdev the rights
+ epatch "${FILESDIR}/bluez-plugdev.patch"
+ fi
+
+ if use cups; then
+ epatch "${FILESDIR}/4.60/cups-location.patch"
+ fi
+
+ # Fix alsa files location
+ epatch "${FILESDIR}/${PN}-alsa_location.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable caps capng) \
+ --enable-network \
+ --enable-serial \
+ --enable-input \
+ --enable-audio \
+ --enable-service \
+ $(use_enable gstreamer) \
+ $(use_enable alsa) \
+ $(use_enable usb) \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ $(use_enable old-daemons hidd) \
+ $(use_enable old-daemons pand) \
+ $(use_enable old-daemons dund) \
+ $(use_enable cups) \
+ $(use_enable test-programs test) \
+ --enable-udevrules \
+ --enable-configfiles \
+ $(use_enable pcmcia) \
+ $(use_enable debug) \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog README || die
+
+ if use test-programs ; then
+ cd "${S}/test"
+ dobin simple-agent simple-service monitor-bluetooth
+ newbin list-devices list-bluetooth-devices
+ for b in apitest hsmicro hsplay test-* ; do
+ newbin "${b}" "bluez-${b}"
+ done
+ insinto /usr/share/doc/${PF}/test-services
+ doins service-*
+
+ cd "${S}"
+ fi
+
+ if use old-daemons; then
+ newconfd "${FILESDIR}/4.18/conf.d-hidd" hidd || die
+ newinitd "${FILESDIR}/4.18/init.d-hidd" hidd || die
+ fi
+
+ insinto /etc/bluetooth
+ doins \
+ input/input.conf \
+ audio/audio.conf \
+ network/network.conf \
+ serial/serial.conf \
+ || die
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}/${PN}-4.18-udev.rules" 70-bluetooth.rules || die
+ exeinto /$(get_libdir)/udev/
+ newexe "${FILESDIR}/${PN}-4.18-udev.script" bluetooth.sh || die
+
+ newinitd "${FILESDIR}/4.60/bluetooth-init.d" bluetooth || die
+ newconfd "${FILESDIR}/4.60/bluetooth-conf.d" bluetooth || die
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules && udevadm trigger --subsystem-match=bluetooth
+
+ elog
+ elog "To use dial up networking you must install net-dialup/ppp."
+ elog
+ elog "For a password agent, there is for example net-wireless/bluez-gnome"
+ elog "for gnome and net-wireless/kdebluetooth for kde. You can also give a"
+ elog "try to net-wireless/blueman"
+ elog
+ elog "Use the old-daemons use flag to get the old daemons like hidd"
+ elog "installed. Please note that the init script doesn't stop the old"
+ elog "daemons after you update it so it's recommended to run:"
+ elog " /etc/init.d/bluetooth stop"
+ elog "before updating your configuration files or you can manually kill"
+ elog "the extra daemons you previously enabled in /etc/conf.d/bluetooth."
+
+ if use consolekit; then
+ elog ""
+ elog "If you want to use rfcomm as a normal user, you need to add the user"
+ elog "to the uucp group."
+ else
+ elog ""
+ elog "Since you have the consolekit use flag disabled, you will only be able to run"
+ elog "bluetooth clients as root. If you want to be able to run bluetooth clientes as "
+ elog "a regular user, you need to enable the consolekit use flag for this package."
+ fi
+
+ if use old-daemons; then
+ elog ""
+ elog "The hidd init script was installed because you have the old-daemons"
+ elog "use flag on. It is not started by default via udev so please add it"
+ elog "to the required runlevels using rc-update <runlevel> add hidd. If"
+ elog "you need init scripts for the other daemons, please file requests"
+ elog "to https://bugs.gentoo.org."
+ fi
+}
diff --git a/net-wireless/gnome-bluetooth/ChangeLog b/net-wireless/gnome-bluetooth/ChangeLog
index b2bee591e510..003d17413086 100644
--- a/net-wireless/gnome-bluetooth/ChangeLog
+++ b/net-wireless/gnome-bluetooth/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-wireless/gnome-bluetooth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.74 2010/06/11 11:54:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.75 2010/06/18 12:22:46 pacho Exp $
+
+*gnome-bluetooth-2.30.0 (18 Jun 2010)
+
+ 18 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-bluetooth-2.30.0.ebuild,
+ +files/gnome-bluetooth-2.30.0-add-pin.patch,
+ +files/gnome-bluetooth-2.30.0-mounted-failure.patch:
+ Version bump for Gnome 2.30
11 Jun 2010; Pacho Ramos <pacho@gentoo.org> -gnome-bluetooth-0.9.1.ebuild,
-gnome-bluetooth-0.11.0.ebuild, gnome-bluetooth-0.12.0.ebuild,
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch
new file mode 100644
index 000000000000..dc55eb65fe2d
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch
@@ -0,0 +1,23 @@
+From fff176c2b14516bc572576199490a0f526999b24 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Sun, 02 May 2010 17:45:21 +0000
+Subject: Add pin code for BT-GPS8 JENTRO
+
+https://bugzilla.gnome.org/show_bug.cgi?id=617371
+---
+diff --git a/wizard/pin-code-database.xml b/wizard/pin-code-database.xml
+index 8f9e9a3..8a73d65 100644
+--- a/wizard/pin-code-database.xml
++++ b/wizard/pin-code-database.xml
+@@ -65,6 +65,9 @@
+ <device oui="00:19:1D:" name="Nintendo RVL-CNT-01" pin="NULL"/>
+ <device oui="00:1F:C5:" name="Nintendo RVL-CNT-01" pin="NULL"/>
+
++ <!-- BT-GPS8 JENTRO, GPS mouse -->
++ <device oui="00:0D:B5:" name="BT-GPS8 JENTRO" pin="0000"/>
++
+ <!-- GPS devices -->
+ <device oui="00:0D:B5:" name="TomTom Wireless GPS MkII" pin="0000"/>
+ <device oui="00:0D:B5:" name="GPS-GW-005" pin="0000"/>
+--
+cgit v0.8.3.1
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch
new file mode 100644
index 000000000000..90e5da5dff76
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch
@@ -0,0 +1,34 @@
+From 49c9ab7ddd8c20ad1722d20185a0fc3e71ce2d20 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 26 May 2010 14:24:15 +0000
+Subject: Don't fail to browse the device if already mounted
+
+We don't need to have an error if the device is already mounted,
+just show it already!
+---
+diff --git a/applet/main.c b/applet/main.c
+index 5655a75..dd517c8 100644
+--- a/applet/main.c
++++ b/applet/main.c
+@@ -114,9 +114,16 @@ mount_finish_cb (GObject *source_object,
+
+ if (g_file_mount_enclosing_volume_finish (G_FILE (source_object),
+ res, &error) == FALSE) {
+- g_printerr ("Failed to mount OBEX volume: %s", error->message);
+- g_error_free (error);
+- return;
++ /* Ignore "already mounted" error */
++ if (error->domain == G_IO_ERROR &&
++ error->code == G_IO_ERROR_ALREADY_MOUNTED) {
++ g_error_free (error);
++ error = NULL;
++ } else {
++ g_printerr ("Failed to mount OBEX volume: %s", error->message);
++ g_error_free (error);
++ return;
++ }
+ }
+
+ uri = g_file_get_uri (G_FILE (source_object));
+--
+cgit v0.8.3.1
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild
new file mode 100644
index 000000000000..1d1f0d8fcf6c
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild,v 1.1 2010/06/18 12:22:46 pacho Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+IUSE="doc nautilus"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEPEND=">=dev-libs/glib-2.19.1
+ >=x11-libs/gtk+-2.19.1
+ >=x11-libs/libnotify-0.4.3
+ >=gnome-base/gconf-2.6
+ >=dev-libs/dbus-glib-0.74
+ dev-libs/libunique
+ nautilus? ( >=gnome-extra/nautilus-sendto-2.28.0.1[-bluetooth] )"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd"
+DEPEND="${COMMON_DEPEND}
+ !!net-wireless/bluez-gnome
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS README NEWS ChangeLog"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable nautilus nautilus-sendto)
+ --disable-moblin
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-introspection"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Add pin code for BT-GPS8 JENTRO
+ epatch "${FILESDIR}/${P}-add-pin.patch"
+
+ # Don't fail to browse the device if already mounted
+ epatch "${FILESDIR}/${P}-mounted-failure.patch"
+}
diff --git a/net-wireless/gnome-bluetooth/metadata.xml b/net-wireless/gnome-bluetooth/metadata.xml
index 005e4261aa01..2e75dd9e50f5 100644
--- a/net-wireless/gnome-bluetooth/metadata.xml
+++ b/net-wireless/gnome-bluetooth/metadata.xml
@@ -4,4 +4,7 @@
<herd>mobile</herd>
<herd>pda</herd>
<herd>gnome</herd>
+<use>
+ <flag name='nautilus'>Build nautilus-sendto plugin</flag>
+</use>
</pkgmetadata>