summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-30 11:43:08 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-30 11:43:08 +0000
commit3c680d295d2d0484cd36ca6b230ebb5d9d5ceb95 (patch)
tree5e0dcb049ff257fcd6580ca20fd4bc203371712f /net-www/htdig
parentCleanup (diff)
downloadhistorical-3c680d295d2d0484cd36ca6b230ebb5d9d5ceb95.tar.gz
historical-3c680d295d2d0484cd36ca6b230ebb5d9d5ceb95.tar.bz2
historical-3c680d295d2d0484cd36ca6b230ebb5d9d5ceb95.zip
*** empty log message ***
Diffstat (limited to 'net-www/htdig')
-rw-r--r--net-www/htdig/htdig-3.1.5-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-www/htdig/htdig-3.1.5-r1.ebuild b/net-www/htdig/htdig-3.1.5-r1.ebuild
new file mode 100644
index 000000000000..75a6d1a64ae2
--- /dev/null
+++ b/net-www/htdig/htdig-3.1.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/htdig/htdig-3.1.5-r1.ebuild,v 1.1 2001/04/30 11:43:08 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="WWW index and searching system"
+SRC_URI="http://www.htdig.org/files/${A}"
+HOMEPAGE="http://www.htdig.org"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-devel/gcc-2.95.2
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/CONFIG.in ${S}
+}
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --with-cgi-bin-dir=/usr/bin \
+ --with-image-dir=/usr/local/httpd/images/htdig \
+ --with-search-dir=/usr/local/httpd/htdocs/htdig
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} CGIBIN_DIR=${D}/usr/bin \
+ SEARCH_DIR=${D}/usr/local/httpd/htdocs/htdig \
+ IMAGE_DIR=${D}/usr/local/httpd/htdocs/images/htdig \
+ exec_prefix=${D}/usr install
+ dosed /etc/httpd/htdig.conf /usr/bin/rundig
+ dodoc ChangeLog COPYING README
+
+}
+