summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 07:47:07 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2002-04-28 07:47:07 +0000
commit3efd8c7ec09210dfb1b4dbba945ab7855ea7a624 (patch)
tree7e42085b5da4edd61d8e489792db5233907eb244 /net-www
parentsecond try at an ebuild (diff)
downloadhistorical-3efd8c7ec09210dfb1b4dbba945ab7855ea7a624.tar.gz
historical-3efd8c7ec09210dfb1b4dbba945ab7855ea7a624.tar.bz2
historical-3efd8c7ec09210dfb1b4dbba945ab7855ea7a624.zip
(all-arch) GPL flash plugin
Diffstat (limited to 'net-www')
-rw-r--r--net-www/gplflash/files/digest-gplflash-0.4.101
-rw-r--r--net-www/gplflash/files/gentoo.diff8
-rw-r--r--net-www/gplflash/gplflash-0.4.10.ebuild39
3 files changed, 48 insertions, 0 deletions
diff --git a/net-www/gplflash/files/digest-gplflash-0.4.10 b/net-www/gplflash/files/digest-gplflash-0.4.10
new file mode 100644
index 000000000000..559fd82f09cb
--- /dev/null
+++ b/net-www/gplflash/files/digest-gplflash-0.4.10
@@ -0,0 +1 @@
+MD5 1473f085c599d8076fa866cd91e11598 flash-0.4.10.tgz 358995
diff --git a/net-www/gplflash/files/gentoo.diff b/net-www/gplflash/files/gentoo.diff
new file mode 100644
index 000000000000..ad184a999479
--- /dev/null
+++ b/net-www/gplflash/files/gentoo.diff
@@ -0,0 +1,8 @@
+--- Makefile Mon Jun 12 10:19:14 2000
++++ Makefile.new Thu Apr 25 10:51:27 2002
+@@ -1,4 +1,4 @@
+-SUBDIRS= Jpeg Zlib Lib Player Plugin Kflash
++SUBDIRS= Jpeg Zlib Lib Player Plugin
+
+ all:
+ for subdir in $(SUBDIRS); do (cd $$subdir; $(MAKE)); done
diff --git a/net-www/gplflash/gplflash-0.4.10.ebuild b/net-www/gplflash/gplflash-0.4.10.ebuild
new file mode 100644
index 000000000000..bea7f80cb933
--- /dev/null
+++ b/net-www/gplflash/gplflash-0.4.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Pieter Van den Abeele <pvdabeel@gentoo.org>
+# $Id: gplflash-0.4.10.ebuild,v 1.1 2002/04/28 07:47:07 pvdabeel Exp $
+
+S=${WORKDIR}/flash-0.4.10
+DESCRIPTION="GPL Shockwave Flash Player/Plugin"
+SRC_URI="http://www.swift-tools.com/Flash/flash-0.4.10.tgz"
+HOMEPAGE="http://www.swift-tools.com/Flash"
+
+DEPEND="media-libs/libflash"
+
+PATCH=${FILESDIR}/gentoo.diff
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack flash-0.4.10.tgz
+ cd ${S}
+ cat ${PATCH} | patch -p0 || die
+}
+
+src_compile() {
+ cd ${S}
+ emake
+}
+
+src_install() {
+ cd ${S}/Plugin
+ insinto /opt/netscape/plugins
+ doins npflash.so
+ cd ${S}
+ dodoc README ReadMe.htm
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npflash.so \
+ /usr/lib/mozilla/plugins/npflash.so
+ fi
+}