summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-06-15 03:18:09 +0000
committerChuck Short <zul@gentoo.org>2004-06-15 03:18:09 +0000
commit7f9f87ccb392b58d4b12075ded2ac166d053154c (patch)
treecc201c4fd9ccc7010736ab3feea57692e7132ea9 /net-www
parentFix use invocation (diff)
downloadhistorical-7f9f87ccb392b58d4b12075ded2ac166d053154c.tar.gz
historical-7f9f87ccb392b58d4b12075ded2ac166d053154c.tar.bz2
historical-7f9f87ccb392b58d4b12075ded2ac166d053154c.zip
Initial version.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_pam/ChangeLog10
-rw-r--r--net-www/mod_auth_pam/files/10_mod_auth_pam.conf14
-rw-r--r--net-www/mod_auth_pam/files/digest-mod_auth_pam-1.1.11
-rw-r--r--net-www/mod_auth_pam/metadata.xml8
-rw-r--r--net-www/mod_auth_pam/mod_auth_pam-1.1.1.ebuild54
5 files changed, 87 insertions, 0 deletions
diff --git a/net-www/mod_auth_pam/ChangeLog b/net-www/mod_auth_pam/ChangeLog
new file mode 100644
index 000000000000..328fa4f0c1f1
--- /dev/null
+++ b/net-www/mod_auth_pam/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/mod_auth_pam
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/ChangeLog,v 1.1 2004/06/15 03:18:09 zul Exp $
+
+*mod_auth_pam-1.1.1 (14 Jun 2004)
+
+ 14 Jun 2004; Chuck Short <zul@gentoo.org> mod_auth_pam-1.1.1.ebuild,
+ files/10_mod_auth_pam.conf:
+ Initial ebuild, closes #28114.
+
diff --git a/net-www/mod_auth_pam/files/10_mod_auth_pam.conf b/net-www/mod_auth_pam/files/10_mod_auth_pam.conf
new file mode 100644
index 000000000000..04fc2bb4ab98
--- /dev/null
+++ b/net-www/mod_auth_pam/files/10_mod_auth_pam.conf
@@ -0,0 +1,14 @@
+#<IfDefine AUTH_PAM>
+ <IfModule !mod_auth_pam.c>
+ LoadModule auth_pam_module extramodules/mod_auth_pam.so
+ </IfModule>
+#</IfDefine>
+
+#<IfModule mod_auth_pam.c>
+# AuthPAM_Enabled on
+#
+# AuthType Basic
+# AuthName "secure area"
+# require group staff
+# require user webmaster
+#</IfModule>
diff --git a/net-www/mod_auth_pam/files/digest-mod_auth_pam-1.1.1 b/net-www/mod_auth_pam/files/digest-mod_auth_pam-1.1.1
new file mode 100644
index 000000000000..d6c1f8c5cbb8
--- /dev/null
+++ b/net-www/mod_auth_pam/files/digest-mod_auth_pam-1.1.1
@@ -0,0 +1 @@
+MD5 ab873520ddd2fee7d480dfd53e464e0a mod_auth_pam-2.0-1.1.1.tar.gz 11456
diff --git a/net-www/mod_auth_pam/metadata.xml b/net-www/mod_auth_pam/metadata.xml
new file mode 100644
index 000000000000..bcaabdbbd0d3
--- /dev/null
+++ b/net-www/mod_auth_pam/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+<longdescription>
+The Apache HTTP Server Project is an effort to develop and maintain an open-source HTTP server for modern operating systems including UNIX and Windows NT. The goal of this project is to provide a secure, efficient and extensible server that provides HTTP services in sync with the current HTTP standards.
+</longdescription>
+</pkgmetadata>
diff --git a/net-www/mod_auth_pam/mod_auth_pam-1.1.1.ebuild b/net-www/mod_auth_pam/mod_auth_pam-1.1.1.ebuild
new file mode 100644
index 000000000000..af4d3229f388
--- /dev/null
+++ b/net-www/mod_auth_pam/mod_auth_pam-1.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1.ebuild,v 1.1 2004/06/15 03:18:09 zul Exp $
+
+DESCRIPTION="PAM authentication module for Apache2"
+HOMEPAGE="http://pam.sourceforge.net/mod_auth_pam/"
+
+S="${WORKDIR}/${PN}"
+SRC_URI="http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-1.1.1.tar.gz"
+LICENSE="Apache-1.1"
+
+KEYWORDS="x86 ~ppc ~sparc"
+
+DEPEND="sys-libs/pam
+ =net-www/apache-2*"
+RDEPEND="${DEPEND}"
+IUSE=""
+SLOT="0"
+#
+src_unpack() {
+ unpack "${PN}-2.0-1.1.1.tar.gz"
+ cd "${S}"
+ epatch ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ emake APXS=apxs2 || die
+}
+
+src_install () {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/mod_auth_pam.so
+
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/10_mod_auth_pam.conf
+ insinto /etc/pam.d
+ newins ${FILESDIR}/apache2.pam apache2
+
+ dodoc INSTALL README
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ local gid=`grep ^apache: /etc/group |cut -d: -f3`
+ [ -z "${gid}" ] && gid=81
+ einfo
+ einfo "If the system is configured with the shadow authentication method"
+ einfo "the following commands must be executed by root to make /etc/shadow"
+ einfo "accessible by the apache server:"
+ einfo
+ einfo " # chgrp ${gid} /etc/shadow"
+ einfo " # chmod 640 /etc/shadow"
+ einfo
+}