summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-01-23 13:27:04 +0000
committerChristian Parpart <trapni@gentoo.org>2005-01-23 13:27:04 +0000
commit7fa46f4a7e371e6b7e912893423c13e78f61300e (patch)
tree693cae902050fb2b52842f788b6e5f217e74c0c0 /net-www
parentadding ~amd64 to keywords (diff)
downloadhistorical-7fa46f4a7e371e6b7e912893423c13e78f61300e.tar.gz
historical-7fa46f4a7e371e6b7e912893423c13e78f61300e.tar.bz2
historical-7fa46f4a7e371e6b7e912893423c13e78f61300e.zip
code cleanup; added missing need_apache2
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_pam/ChangeLog6
-rw-r--r--net-www/mod_auth_pam/Manifest4
-rw-r--r--net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild12
3 files changed, 13 insertions, 9 deletions
diff --git a/net-www/mod_auth_pam/ChangeLog b/net-www/mod_auth_pam/ChangeLog
index 7fceabcff945..68d9f3ecbf3a 100644
--- a/net-www/mod_auth_pam/ChangeLog
+++ b/net-www/mod_auth_pam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mod_auth_pam
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/ChangeLog,v 1.6 2005/01/23 13:06:47 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/ChangeLog,v 1.7 2005/01/23 13:27:04 trapni Exp $
+
+ 23 Jan 2005; Christian Parpart <trapni@gentoo.org>
+ mod_auth_pam-1.1.1-r1.ebuild:
+ code cleanup; added missing need_apache2
23 Jan 2005; Christian Parpart <trapni@gentoo.org>
mod_auth_pam-1.1.1-r1.ebuild:
diff --git a/net-www/mod_auth_pam/Manifest b/net-www/mod_auth_pam/Manifest
index bc40e8092a57..9ffcb71c49a9 100644
--- a/net-www/mod_auth_pam/Manifest
+++ b/net-www/mod_auth_pam/Manifest
@@ -1,7 +1,7 @@
-MD5 7deab193d567af5da14c5642e9d64604 ChangeLog 942
+MD5 2d0fadbbcb6bfcbe844f95949c487e30 ChangeLog 1071
MD5 0d18f0fe5d603b41b988373892caf195 metadata.xml 226
MD5 0975dfb93f3fb015c383d0c8c89450fd mod_auth_pam-1.1.1.ebuild 1361
-MD5 7a1c8f9f084f00b900d601206cbd0ec0 mod_auth_pam-1.1.1-r1.ebuild 1538
+MD5 9020eea1f379eb9cd3d08de90646a5dc mod_auth_pam-1.1.1-r1.ebuild 1541
MD5 1c6bc704c0a9ba60cde371d219c6a595 files/10_mod_auth_pam.conf 310
MD5 d0cb338160e3be8790524af8071cc4df files/apache2.pam 380
MD5 6cbbe41e49ddf63a8c680ce625084853 files/digest-mod_auth_pam-1.1.1 73
diff --git a/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
index cc5d57ed1ac7..67e4c61c486e 100644
--- a/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
+++ b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.2 2005/01/23 13:06:47 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.3 2005/01/23 13:27:04 trapni Exp $
inherit eutils apache-module
DESCRIPTION="PAM authentication module for Apache2"
HOMEPAGE="http://pam.sourceforge.net/mod_auth_pam/"
-SRC_URI="http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-1.1.1.tar.gz"
+SRC_URI="http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-${PV}.tar.gz"
LICENSE="Apache-1.1"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
@@ -18,13 +18,13 @@ IUSE=""
S="${WORKDIR}/${PN}"
-APXS2_S="${S}/.libs"
APACHE2_MOD_CONF="${PVR}/10_mod_auth_pam"
DOCFILES="INSTALL README"
+need_apache
src_unpack() {
- unpack "${PN}-2.0-1.1.1.tar.gz"
+ unpack "${PN}-2.0-${PV}.tar.gz"
cd "${S}"
epatch ${FILESDIR}/${PF}-gentoo.diff || die
}
@@ -34,9 +34,9 @@ src_compile() {
}
src_install () {
- APACHE2_MOD_FILE='mod_auth_sys_group.so' apache2_src_install
+ APACHE2_MOD_FILE='.libs/mod_auth_sys_group.so' apache2_src_install
unset DOCFILES APACHE2_MOD_CONF
- APACHE2_MOD_FILE='mod_auth_pam.so' apache2_src_install
+ APACHE2_MOD_FILE='.libs/mod_auth_pam.so' apache2_src_install
insinto /etc/pam.d
newins ${FILESDIR}/apache2.pam apache2