summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-02-07 22:30:26 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-02-07 22:30:26 +0000
commitf3a6b8fb03f4c2c300125c4dd68562b7aaf36208 (patch)
tree20642ec615dd550dee2a8ba7549ea3635f22c553 /net-www
parentadd ~alpha (diff)
downloadhistorical-f3a6b8fb03f4c2c300125c4dd68562b7aaf36208.tar.gz
historical-f3a6b8fb03f4c2c300125c4dd68562b7aaf36208.tar.bz2
historical-f3a6b8fb03f4c2c300125c4dd68562b7aaf36208.zip
new package. ARCH masked
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phpBB/ChangeLog8
-rw-r--r--net-www/phpBB/files/digest-phpBB-2.0.41
-rw-r--r--net-www/phpBB/phpBB-2.0.4.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/net-www/phpBB/ChangeLog b/net-www/phpBB/ChangeLog
new file mode 100644
index 000000000000..1340a6fb1a02
--- /dev/null
+++ b/net-www/phpBB/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/phpBB
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.1 2003/02/07 22:30:26 rphillips Exp $
+
+*phpBB-2.0.4 (07 Feb 2003)
+
+ 07 Feb 2003; Ryan Phillips <rphillips@gentoo.org> :
+ New package. Submitted by Tim Radisch. Fixes #14912
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.4 b/net-www/phpBB/files/digest-phpBB-2.0.4
new file mode 100644
index 000000000000..193373c22337
--- /dev/null
+++ b/net-www/phpBB/files/digest-phpBB-2.0.4
@@ -0,0 +1 @@
+MD5 1f3312f7c6b35995ffcbc689e2f55be0 phpBB-2.0.4.tar.gz 497330
diff --git a/net-www/phpBB/phpBB-2.0.4.ebuild b/net-www/phpBB/phpBB-2.0.4.ebuild
new file mode 100644
index 000000000000..9a3c4d8bee1b
--- /dev/null
+++ b/net-www/phpBB/phpBB-2.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tim Raedisch <tim.raedisch@udo.edu>
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.4.ebuild,v 1.1 2003/02/07 22:30:26 rphillips Exp $
+
+S="${WORKDIR}/${PN}2"
+DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
+SRC_URI="http://belnet.dl.sourceforge.net/sourceforge/phpbb/${P}.tar.gz"
+HOMEPAGE="http://www.phpbb.com/"
+LICENSE="GPL-2"
+DEPEND="virtual/php"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep '^DocumentRoot' /etc/apache2/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/phpbb ] ; then
+ ewarn "You need to unmerge your old phpBB version first."
+ ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #we need to have this empty function ... default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir ${HTTPD_ROOT}/phpbb
+ cp -r * ${D}/${HTTPD_ROOT}/phpbb
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${D}/${HTTPD_ROOT}/phpbb
+ dodoc ${S}/docs/*
+}
+
+