summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-10-24 11:40:04 +0000
committerBen de Groot <yngwin@gentoo.org>2012-10-24 11:40:04 +0000
commit86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38 (patch)
treed95657be6ecd3644a62f909a646dd62fbc78e0be /razorqt-base/razorqt-kbshortcuts
parentNew revision, eapi4 bump, respect CC, LDFLAGS, add ~amd64 (diff)
downloadhistorical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.tar.gz
historical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.tar.bz2
historical-86aa3d6c6e769a8f362fdcd0cef90034e7b8fd38.zip
Version bump
Package-Manager: portage-2.2.0_alpha123/cvs/Linux x86_64
Diffstat (limited to 'razorqt-base/razorqt-kbshortcuts')
-rw-r--r--razorqt-base/razorqt-kbshortcuts/ChangeLog8
-rw-r--r--razorqt-base/razorqt-kbshortcuts/razorqt-kbshortcuts-0.5.1.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/razorqt-base/razorqt-kbshortcuts/ChangeLog b/razorqt-base/razorqt-kbshortcuts/ChangeLog
index c3158ef24241..baa7c50b2e6d 100644
--- a/razorqt-base/razorqt-kbshortcuts/ChangeLog
+++ b/razorqt-base/razorqt-kbshortcuts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for razorqt-base/razorqt-kbshortcuts
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-kbshortcuts/ChangeLog,v 1.1 2012/10/15 09:48:44 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-kbshortcuts/ChangeLog,v 1.2 2012/10/24 11:35:13 yngwin Exp $
+
+*razorqt-kbshortcuts-0.5.1 (24 Oct 2012)
+
+ 24 Oct 2012; Ben de Groot <yngwin@gentoo.org>
+ +razorqt-kbshortcuts-0.5.1.ebuild:
+ Version bump
*razorqt-kbshortcuts-0.5.0 (15 Oct 2012)
diff --git a/razorqt-base/razorqt-kbshortcuts/razorqt-kbshortcuts-0.5.1.ebuild b/razorqt-base/razorqt-kbshortcuts/razorqt-kbshortcuts-0.5.1.ebuild
new file mode 100644
index 000000000000..e9d5d5586536
--- /dev/null
+++ b/razorqt-base/razorqt-kbshortcuts/razorqt-kbshortcuts-0.5.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/razorqt-base/razorqt-kbshortcuts/razorqt-kbshortcuts-0.5.1.ebuild,v 1.1 2012/10/24 11:35:12 yngwin Exp $
+
+EAPI=4
+inherit cmake-utils
+
+DESCRIPTION="Razor-qt global keyboard shortcuts manager"
+HOMEPAGE="http://razor-qt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Razor-qt/razor-qt.git"
+ EGIT_BRANCH="master"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/downloads/Razor-qt/razor-qt/razorqt-${PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/razorqt-${PV}"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+DEPEND="razorqt-base/razorqt-libs"
+RDEPEND="${DEPEND}
+ razorqt-base/razorqt-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPLIT_BUILD=On
+ -DMODULE_GLOBALKEYSHORTCUTS=On
+ )
+ cmake-utils_src_configure
+}