summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-02-07 01:59:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-02-07 01:59:49 +0000
commitdf9f96995bbc4cf52981ccd6bf4f651b85bddf6e (patch)
tree13362e147ce966b9e316381564e446f59e4e7d22 /sci-astronomy/stellarium
parentAdded ~sparc keyword wrt bug #121880. (diff)
downloadhistorical-df9f96995bbc4cf52981ccd6bf4f651b85bddf6e.tar.gz
historical-df9f96995bbc4cf52981ccd6bf4f651b85bddf6e.tar.bz2
historical-df9f96995bbc4cf52981ccd6bf4f651b85bddf6e.zip
gcc41 patch + dep fixup
Package-Manager: portage-2.0.54
Diffstat (limited to 'sci-astronomy/stellarium')
-rw-r--r--sci-astronomy/stellarium/ChangeLog6
-rw-r--r--sci-astronomy/stellarium/Manifest5
-rw-r--r--sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch58
-rw-r--r--sci-astronomy/stellarium/stellarium-0.7.1.ebuild15
4 files changed, 78 insertions, 6 deletions
diff --git a/sci-astronomy/stellarium/ChangeLog b/sci-astronomy/stellarium/ChangeLog
index f67bd65071ee..5b5184d0774c 100644
--- a/sci-astronomy/stellarium/ChangeLog
+++ b/sci-astronomy/stellarium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/stellarium
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.11 2006/02/01 07:28:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/ChangeLog,v 1.12 2006/02/07 01:59:49 mr_bones_ Exp $
+
+ 07 Feb 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/stellarium-0.7.1-gcc41.patch, stellarium-0.7.1.ebuild:
+ gcc41 patch + dep fixup from Diego Pettenò via bug #121746
01 Feb 2006; Michael Sterrett <mr_bones_@gentoo.org>
stellarium-0.7.1.ebuild:
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index b392ff4dde81..68ac641d4818 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -1,4 +1,5 @@
-MD5 1d3c8c72e1a885e7d87d46d2e3bdbb4b ChangeLog 3295
+MD5 40759424a61b9d07457bdd22284c25c4 ChangeLog 3477
MD5 d29c89b04a7be61c3500c69982369f3b files/digest-stellarium-0.7.1 70
+MD5 41515c4b741475273695fa912b8b4a86 files/stellarium-0.7.1-gcc41.patch 2683
MD5 e4bdac528fd001633aa222d2b42fe048 metadata.xml 219
-MD5 1a62c61b1cc1726181833527609bfc64 stellarium-0.7.1.ebuild 924
+MD5 8c6845997decf60af384d8947fd3ac11 stellarium-0.7.1.ebuild 1093
diff --git a/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch b/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch
new file mode 100644
index 000000000000..348a32b26a8c
--- /dev/null
+++ b/sci-astronomy/stellarium/files/stellarium-0.7.1-gcc41.patch
@@ -0,0 +1,58 @@
+Index: stellarium-0.7.1/src/observator.h
+===================================================================
+--- stellarium-0.7.1.orig/src/observator.h
++++ stellarium-0.7.1/src/observator.h
+@@ -112,8 +112,8 @@ private:
+ string s_time_format_to_string(S_TIME_FORMAT) const;
+
+ // Convert the date format enum to its associated string and reverse
+- S_DATE_FORMAT Observator::string_to_s_date_format(const string& df) const;
+- string Observator::s_date_format_to_string(S_DATE_FORMAT df) const;
++ S_DATE_FORMAT string_to_s_date_format(const string& df) const;
++ string s_date_format_to_string(S_DATE_FORMAT df) const;
+
+ // for changing position
+ bool flag_move_to;
+Index: stellarium-0.7.1/src/projector.h
+===================================================================
+--- stellarium-0.7.1.orig/src/projector.h
++++ stellarium-0.7.1/src/projector.h
+@@ -75,7 +75,7 @@ public:
+ virtual void set_viewport(int x, int y, int w, int h);
+
+ // Fill with black around the circle
+- void Projector::draw_viewport_shape(void);
++ void draw_viewport_shape(void);
+
+ int viewW(void) const {return vec_viewport[2];}
+ int viewH(void) const {return vec_viewport[3];}
+Index: stellarium-0.7.1/src/stel_command_interface.h
+===================================================================
+--- stellarium-0.7.1.orig/src/stel_command_interface.h
++++ stellarium-0.7.1/src/stel_command_interface.h
+@@ -43,9 +43,9 @@ class StelCommandInterface : CommandInte
+ public:
+ StelCommandInterface(stel_core * core);
+ virtual ~StelCommandInterface();
+- virtual int StelCommandInterface::execute_command(string commandline);
+- virtual int StelCommandInterface::execute_command(string command, double arg);
+- virtual int StelCommandInterface::execute_command(string command, int arg);
++ virtual int execute_command(string commandline);
++ virtual int execute_command(string command, double arg);
++ virtual int execute_command(string command, int arg);
+ virtual int execute_command(string command, unsigned long int &wait, bool trusted);
+ virtual int set_flag(string name, string value, bool &newval, bool trusted);
+ void update(int delta_time);
+Index: stellarium-0.7.1/src/stel_ui.h
+===================================================================
+--- stellarium-0.7.1.orig/src/stel_ui.h
++++ stellarium-0.7.1/src/stel_ui.h
+@@ -316,7 +316,7 @@ private:
+ void tui_cb_sky_time(); // change effect parameters
+
+ // Parse a file of type /usr/share/zoneinfo/zone.tab
+- s_tui::MultiSet_item<string>* stel_ui::create_tree_from_time_zone_file(const string& zonetab);
++ s_tui::MultiSet_item<string>* create_tree_from_time_zone_file(const string& zonetab);
+
+ bool ScriptDirectoryRead;
+ };
diff --git a/sci-astronomy/stellarium/stellarium-0.7.1.ebuild b/sci-astronomy/stellarium/stellarium-0.7.1.ebuild
index 1ecbc2f4cbb6..166d320259fa 100644
--- a/sci-astronomy/stellarium/stellarium-0.7.1.ebuild
+++ b/sci-astronomy/stellarium/stellarium-0.7.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.7.1.ebuild,v 1.7 2006/02/01 07:28:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/stellarium/stellarium-0.7.1.ebuild,v 1.8 2006/02/07 01:59:49 mr_bones_ Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Stellarium renders 3D photo-realistic skies in real time."
HOMEPAGE="http://stellarium.free.fr/"
@@ -17,11 +17,20 @@ RDEPEND="virtual/opengl
media-libs/libsdl
media-libs/libpng
media-libs/sdl-mixer
- nls? ( sys-devel/gettext )"
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
|| ( x11-libs/libXt virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gcc41.patch #bug #121746
+}
+
src_compile() {
+ append-flags -fno-strict-aliasing
econf \
--disable-dependency-tracking \
$(use_enable nls) \