summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-12-07 21:03:03 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-12-07 21:03:03 +0000
commit5df8fbfce7c8b62a323bff2ea2a0c6008313927c (patch)
tree097d76a688ae016606ee5ad8360d6f2d10b6438b /sci-biology
parentInitial commit. Many thanks go to Jean-Michel Petit the upstream author for p... (diff)
downloadhistorical-5df8fbfce7c8b62a323bff2ea2a0c6008313927c.tar.gz
historical-5df8fbfce7c8b62a323bff2ea2a0c6008313927c.tar.bz2
historical-5df8fbfce7c8b62a323bff2ea2a0c6008313927c.zip
Fix x86 compile issue. Thanks to Fabian Groffen.
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tophat/ChangeLog5
-rw-r--r--sci-biology/tophat/Manifest4
-rw-r--r--sci-biology/tophat/tophat-1.0.12.ebuild10
3 files changed, 12 insertions, 7 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
index 22bb55cca671..de94fe14956a 100644
--- a/sci-biology/tophat/ChangeLog
+++ b/sci-biology/tophat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/tophat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.1 2009/12/07 15:50:08 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.2 2009/12/07 21:03:03 weaver Exp $
+
+ 07 Dec 2009; Andrey Kislyuk <weaver@gentoo.org> tophat-1.0.12.ebuild:
+ Fix x86 compile issue. Thanks to Fabian Groffen.
*tophat-1.0.12 (07 Dec 2009)
diff --git a/sci-biology/tophat/Manifest b/sci-biology/tophat/Manifest
index 820c764ca16d..4a431aa3f379 100644
--- a/sci-biology/tophat/Manifest
+++ b/sci-biology/tophat/Manifest
@@ -1,4 +1,4 @@
DIST tophat-1.0.12.tar.gz 468781 RMD160 b705ca7bde20bd143ba1cfd084b3a3e2815a7a4d SHA1 8a39af78dc9ec797f9f30853fb24b6b0e42d0ef6 SHA256 f67b3f89aa79c7e14b40bcdba87f5aba6d322f869ca4260503e64ffcd2b621b2
-EBUILD tophat-1.0.12.ebuild 822 RMD160 5ceb851fcadba7ac329dc62893a35b93adf0ff36 SHA1 300a2e03d1bcaa44f0b118bdae0d5b911cd24d1f SHA256 38af1af5c13548f9da93bbd5f4dedfd02ea7a030e5817d09fc7cca1c9b6eb06c
-MISC ChangeLog 404 RMD160 6263aa3eb1fd473e1507ee72001da769996e0643 SHA1 783ef262c017d3557144b17264f83cf6990c4578 SHA256 20c33409393d614252db3ac11f742a6435265045db03f4ede71c18d30362bf3a
+EBUILD tophat-1.0.12.ebuild 959 RMD160 aa48d11e8ac87ceafff1a67caf40dee3de2220ea SHA1 c4172e1758d82ab37589648879162837193281c7 SHA256 2f54d5c08b2ed9db3c96df25214cd9214ca74a9de37f73c117332d1c28f619b0
+MISC ChangeLog 528 RMD160 ab03d628c82b2378ab76dc64b3d0b60bda364b23 SHA1 01b9b75550275dad3071b9a95b7925685444b28c SHA256 2cd3dc265871d9f41a33408b4f4776f21b8046590dd4b78c1264f1a4877258ba
MISC metadata.xml 259 RMD160 d9d81b67d635fabd81aef8ae0edf971211ae9072 SHA1 8e32f751c67ff891fa35405a2cf6fb33752d6eb1 SHA256 541c3fbcf299d9a8ccf4132ee61f9e53a5d737cefdaa6fdc77764d8d4c7f3110
diff --git a/sci-biology/tophat/tophat-1.0.12.ebuild b/sci-biology/tophat/tophat-1.0.12.ebuild
index e691698188d7..0082942fbc0a 100644
--- a/sci-biology/tophat/tophat-1.0.12.ebuild
+++ b/sci-biology/tophat/tophat-1.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.1 2009/12/07 15:50:08 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.2 2009/12/07 21:03:03 weaver Exp $
EAPI="2"
@@ -13,16 +13,18 @@ SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
IUSE=""
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
-DEPEND="sci-biology/bowtie"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND="sci-biology/bowtie"
src_prepare() {
# fix gcc-4.4 missing include
sed -i '/#include <string>/ a #include <stdio.h>' "${S}/src/gff_juncs.cpp" || die
# fix parallel make race
sed -i -e 's/\$(top_builddir)\/src\///g' src/Makefile.am || die
+ # remove broken arch-dependent CFLAGS setting
+ perl -i -ne 'print unless /case "\${host_cpu}-\${host_os}" in/../^esac/' configure.ac || die
eautoreconf || die
}