summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-11 20:54:00 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-11 20:54:00 +0000
commit23be6d58cef02b92d9f1a617ea07ad61ef4bef89 (patch)
tree9279a1ab34c1ba180f96bba4f9652ad66330fc46 /sci-libs/blas-atlas
parentAdded source USE flag. (diff)
downloadhistorical-23be6d58cef02b92d9f1a617ea07ad61ef4bef89.tar.gz
historical-23be6d58cef02b92d9f1a617ea07ad61ef4bef89.tar.bz2
historical-23be6d58cef02b92d9f1a617ea07ad61ef4bef89.zip
Bumped to new development snapshot and removed old version (see bug #144314).
Package-Manager: portage-2.1.1
Diffstat (limited to 'sci-libs/blas-atlas')
-rw-r--r--sci-libs/blas-atlas/ChangeLog9
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.17.ebuild148
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.176
3 files changed, 162 insertions, 1 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index eebd8cf3d130..454b20b91962 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.43 2006/09/08 04:07:07 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.44 2006/09/11 20:54:00 markusle Exp $
+
+*blas-atlas-3.7.17 (10 Sep 2006)
+
+ 10 Sep 2006; Markus Dittrich <markusle@gentoo.org>
+ -blas-atlas-3.7.15.ebuild, +blas-atlas-3.7.17.ebuild:
+ Bumped to new development snapshot and removed old version
+ (see bug #144314).
08 Sep 2006; Joshua Jackson <tsunam@gentoo.org> blas-atlas-3.7.11.ebuild:
stable x86; bug #141432
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.17.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.17.ebuild
new file mode 100644
index 000000000000..245b16ca7b77
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.17.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.17.ebuild,v 1.1 2006/09/11 20:54:00 markusle Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/${MY_PN}-3.7.15-shared-libs.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5"
+PROVIDE="virtual/blas"
+
+
+S="${WORKDIR}/ATLAS"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/blas"
+FORTRAN="g77 gfortran"
+
+pkg_setup() {
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of blas-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+ epause 8
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${DISTDIR}"/${MY_PN}-3.7.15-shared-libs.patch.bz2
+
+ # make sure shared libs link against proper libraries
+ if [[ ${FORTRANC} == "gfortran" ]]; then
+ libs="${LDFLAGS} -lpthread -lgfortran"
+ else
+ libs="${LDFLAGS} -lpthread -lg2c"
+ fi
+ sed -e "s/SHRD_LNK/${libs}/g" -i Make.top || \
+ die "Failed to add addtional libs to shared object build"
+
+ mkdir ${BLD_DIR} || die "failed to generate build directory"
+ cp "${FILESDIR}"/war ${BLD_DIR} && chmod a+x ${BLD_DIR}/war || \
+ die "failed to install war"
+
+ cd ${BLD_DIR} && ../configure -Si cputhrchk 0 \
+ || die "configure failed"
+
+ sed -e "s:GENTOO_GCC:$(tc-getCC):" \
+ -e "s:GENTOO_FORTRAN:${FORTRANC}:" \
+ -e "s:GENTOO_CFLAGS:${CFLAGS}:" \
+ -e "s:GENTOO_FFLAGS:${FFLAGS}:" \
+ -i Make.inc || die "Failed to fix Make.inc"
+}
+
+src_compile() {
+ cd ${BLD_DIR}
+ make || die "make failed"
+
+ make shared-strip RPATH=${RPATH}/atlas || \
+ die "failed to build shared libraries"
+
+ # build shared libraries of threaded libraries if applicable
+ if [ -d gentoo/libptf77blas.a ]; then
+ make ptshared-strip RPATH=${RPATH}/threaded-atlas || \
+ die "failed to build threaded shared libraries"
+ fi
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd ${BLD_DIR}/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
+ die "Failed to install libatlas"
+ cp -P *blas* "${D}/${RPATH}"/atlas || \
+ die "Failed to install blas/cblas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas atlas
+
+ if [ -d ${BLD_DIR}/gentoo/threaded-libs ]
+ then
+ dodir "${RPATH}"/threaded-atlas
+ cd ${BLD_DIR}/gentoo/threaded-libs
+ cp -P * "${D}/${RPATH}"/threaded-atlas || \
+ die "Failed to install threaded atlas"
+
+ eselect blas add $(get_libdir) ${FILESDIR}/eselect.blas-threaded threaded-atlas
+ eselect cblas add $(get_libdir) ${FILESDIR}/eselect.cblas-threaded threaded-atlas
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h \
+ "${S}"/include/atlas_enum.h || \
+ die "failed to install headers"
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins ${BLD_DIR}/include/*.h || \
+ die "failed to install timing headers"
+
+ #some docs
+ cd "${S}"
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ local THREADED
+
+ if [ -d "${RPATH}"/threaded-atlas ]
+ then
+ THREADED="threaded-"
+ fi
+ if [[ -z "$(eselect blas show)" ]]; then
+ eselect blas set ${THREADED}atlas
+ fi
+ if [[ -z "$(eselect cblas show)" ]]; then
+ eselect cblas set ${THREADED}atlas
+ fi
+
+ elog
+ elog "Fortran users link using -lblas"
+ elog
+ elog "C users compile against the header ${ROOT}usr/include/atlas/cblas.h and"
+ elog "link using -lcblas"
+ elog
+ elog "If using threaded ATLAS, you may also need to link with -lpthread."
+ elog
+ elog "Configuration now uses eselect rather than blas-config."
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.17 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.17
new file mode 100644
index 000000000000..cdff5f8d0a76
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.17
@@ -0,0 +1,6 @@
+MD5 4d85e976f592f02afa54a82d3890ff22 atlas-3.7.15-shared-libs.patch.bz2 6769
+RMD160 6c9922e4c6236a1c6bb07af3862d023678d86a31 atlas-3.7.15-shared-libs.patch.bz2 6769
+SHA256 6539ea2ecff0e7d84d1968fb9cf9a60e1300e505dd1882f74c386e3dd63baa6d atlas-3.7.15-shared-libs.patch.bz2 6769
+MD5 00f68b5ccdc4bbbaeefa086e6d8e38ff atlas3.7.17.tar.bz2 1746646
+RMD160 6545fa2ae68667d12ec36e01adccc85607de7b5d atlas3.7.17.tar.bz2 1746646
+SHA256 35a20f7a97bf1da14030aebfed39b14cc88d241fa0da4993bb995c112fb2232c atlas3.7.17.tar.bz2 1746646