summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:15:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:15:19 +0000
commit8a11b274b33ab4c8afe272f5935f83e511c3c39a (patch)
treeffcd9fc471ab4bcf28d3440f70776d451fdb3ce3 /sci-libs/netcdf-cxx
parentVersion bump. Remove old. (diff)
downloadhistorical-8a11b274b33ab4c8afe272f5935f83e511c3c39a.tar.gz
historical-8a11b274b33ab4c8afe272f5935f83e511c3c39a.tar.bz2
historical-8a11b274b33ab4c8afe272f5935f83e511c3c39a.zip
Initial import
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/netcdf-cxx')
-rw-r--r--sci-libs/netcdf-cxx/ChangeLog10
-rw-r--r--sci-libs/netcdf-cxx/Manifest4
-rw-r--r--sci-libs/netcdf-cxx/metadata.xml14
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild31
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-libs/netcdf-cxx/ChangeLog b/sci-libs/netcdf-cxx/ChangeLog
new file mode 100644
index 000000000000..ddc8f9233f28
--- /dev/null
+++ b/sci-libs/netcdf-cxx/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/netcdf-cxx
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/ChangeLog,v 1.1 2012/04/18 19:11:48 bicatali Exp $
+
+*netcdf-cxx-4.2 (18 Apr 2012)
+
+ 18 Apr 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> +netcdf-cxx-4.2.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/netcdf-cxx/Manifest b/sci-libs/netcdf-cxx/Manifest
new file mode 100644
index 000000000000..00ce4215c841
--- /dev/null
+++ b/sci-libs/netcdf-cxx/Manifest
@@ -0,0 +1,4 @@
+DIST netcdf-cxx4-4.2.tar.gz 395117 RMD160 776927fe4869b5c4b9b4ee8f8b2a6e5643f002fd SHA1 59628c9f06c211a47517fc00d8b068da159ffa9d SHA256 310b56ca9220ec709d2ebe6fcf46567fda5b26a20b7afa9744acbbc5a59b2226
+EBUILD netcdf-cxx-4.2.ebuild 637 RMD160 233e680e15d4fa1dfe8d0aa7d7b90efc229db999 SHA1 a2cf06bdf9b59580e00eadd65c6ac51bd5dcc7d3 SHA256 0423daad5a9f881ec6c6542d3818a14d2369cdcb696c5cb7bb95e4e4039953cd
+MISC ChangeLog 265 RMD160 72a0f65d3b33b22ab725194c22348fed9806eedb SHA1 23c09495fbe9f0d18022dbbea48d3be6196bd0d7 SHA256 a5c63eee464a64c7b30ca1db5c79e49a13e0a6278b1c8624a4b3bd8141556ca0
+MISC metadata.xml 644 RMD160 7722c69d84ba6f82ac2ad3f26120594ecbe0192f SHA1 8db9add766d0325df74ec43c509d766ae6eeeeb7 SHA256 67e053721f2f8fe57ed6d53b5b4584cffcd2a43d502bb9abb5af43028824e98f
diff --git a/sci-libs/netcdf-cxx/metadata.xml b/sci-libs/netcdf-cxx/metadata.xml
new file mode 100644
index 000000000000..0c3cb8546cdc
--- /dev/null
+++ b/sci-libs/netcdf-cxx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+<longdescription lang="en">
+ NetCDF (network Common Data Form) is an interface for scientific
+ data access and a freely-distributed software library that provides an
+ implementation of the interface. The netCDF library also defines a
+ machine-independent format for representing scientific data.
+ Together, the interface, library, and format support the creation,
+ access, and sharing of scientific data.
+ This is the C++ library which links to the C library.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild
new file mode 100644
index 000000000000..516f8e44bda1
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/netcdf-cxx-4.2.ebuild,v 1.1 2012/04/18 19:11:48 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils versionator
+
+MYP=${PN}4-${PV}
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://www.unidata.ucar.edu/downloads/netcdf/ftp/${MYP}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples static-libs"
+
+RDEPEND=">=sci-libs/netcdf-4.2"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}