summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-22 23:39:18 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-22 23:39:18 +0000
commit5ceb904addea43cb15c42024852c0dd4ca312e30 (patch)
treefaa1d5b4df1b7afbccc759fffa3a81c3d8145d65 /sci-mathematics/octave
parentopenexr gcc4 fix (diff)
downloadhistorical-5ceb904addea43cb15c42024852c0dd4ca312e30.tar.gz
historical-5ceb904addea43cb15c42024852c0dd4ca312e30.tar.bz2
historical-5ceb904addea43cb15c42024852c0dd4ca312e30.zip
Allow the use of gfortran too for gcc4, closes bug 108781.
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/Manifest22
-rw-r--r--sci-mathematics/octave/octave-2.1.71.ebuild4
3 files changed, 22 insertions, 9 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index eb1901fbb4d7..9d30e0c53908 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.14 2005/09/17 01:00:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.15 2005/10/22 23:39:18 cryos Exp $
+
+ 22 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> octave-2.1.71.ebuild:
+ Allow the use of gfortran too for gcc4, closes bug 108781.
17 Sep 2005; Aron Griffis <agriffis@gentoo.org> octave-2.1.69.ebuild:
Mark 2.1.69 stable on alpha
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
index 00d2c7afd7ae..33b5634ff19e 100644
--- a/sci-mathematics/octave/Manifest
+++ b/sci-mathematics/octave/Manifest
@@ -1,8 +1,18 @@
-MD5 bd2ed4dec06725b62ae2a8d1f97c196e octave-2.1.69.ebuild 3633
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 e79f2cfa6ff83971adefbfd6ba27d58f ChangeLog 8725
-MD5 4842851327d8ccfb46012e109ff57f9f octave-2.1.71.ebuild 3522
-MD5 62c4dfb1220dccc6624875121b80bbeb octave-2.1.57-r1.ebuild 3668
-MD5 67d13a7bca35d1d0210394b7735fd073 files/digest-octave-2.1.69 67
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 2232e441020ce9244f94361292546063 ChangeLog 8858
MD5 32c6cee1f5b42b8b20369c3722fb4db2 files/digest-octave-2.1.57-r1 67
+MD5 67d13a7bca35d1d0210394b7735fd073 files/digest-octave-2.1.69 67
MD5 6582a298022b4c4301eca44791cb6da2 files/digest-octave-2.1.71 67
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 62c4dfb1220dccc6624875121b80bbeb octave-2.1.57-r1.ebuild 3668
+MD5 bd2ed4dec06725b62ae2a8d1f97c196e octave-2.1.69.ebuild 3633
+MD5 e7a66fad5a451fe4a902ee91bc6cd6a2 octave-2.1.71.ebuild 3546
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDWs2zntT9W3vfTuoRAkYLAJ0aeLBu1GIIgbOhY9h599U9qAdPUwCfReNY
+D+uAUjecAU5t9ftz8RRH3sc=
+=moQ0
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/octave/octave-2.1.71.ebuild b/sci-mathematics/octave/octave-2.1.71.ebuild
index 96cda01c8ca8..f2403e475d95 100644
--- a/sci-mathematics/octave/octave-2.1.71.ebuild
+++ b/sci-mathematics/octave/octave-2.1.71.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.71.ebuild,v 1.1 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.71.ebuild,v 1.2 2005/10/22 23:39:18 cryos Exp $
inherit flag-o-matic
@@ -32,7 +32,7 @@ DEPEND="virtual/libc
# more information
pkg_setup() {
- use ifc || if [ -z `which g77` ]; then
+ use ifc || if [ -z `which g77` ] && [ -z `which gfortran` ]; then
#if ifc is defined then the dep was already checked
eerror "No fortran compiler found on the system!"
eerror "Please add fortran to your USE flags and reemerge gcc!"