summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-08-04 20:03:19 +0000
committerThomas Kahle <tomka@gentoo.org>2013-08-04 20:03:19 +0000
commit22f61a73afbd554acd3894eb1ecae30a44ddbc1e (patch)
treef95d8fa568fe43e398011443b47089b96eeda16d /sci-mathematics
parentVersion bump. (diff)
downloadhistorical-22f61a73afbd554acd3894eb1ecae30a44ddbc1e.tar.gz
historical-22f61a73afbd554acd3894eb1ecae30a44ddbc1e.tar.bz2
historical-22f61a73afbd554acd3894eb1ecae30a44ddbc1e.zip
Initial ebuild for sci-mathematics/bertini
Package-Manager: portage-2.1.13.1/cvs/Linux x86_64 Manifest-Sign-Key: 0x89DEB219565C32BC!
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/bertini/ChangeLog10
-rw-r--r--sci-mathematics/bertini/Manifest14
-rw-r--r--sci-mathematics/bertini/bertini-1.4.ebuild58
-rw-r--r--sci-mathematics/bertini/metadata.xml25
4 files changed, 107 insertions, 0 deletions
diff --git a/sci-mathematics/bertini/ChangeLog b/sci-mathematics/bertini/ChangeLog
new file mode 100644
index 000000000000..e77c8ed02a35
--- /dev/null
+++ b/sci-mathematics/bertini/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/bertini
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/bertini/ChangeLog,v 1.1 2013/08/04 20:03:02 tomka Exp $
+
+*bertini-1.4 (04 Aug 2013)
+
+ 04 Aug 2013; Thomas Kahle <tomka@gentoo.org> +bertini-1.4.ebuild,
+ +metadata.xml:
+ First ebuild written by myself.
+
diff --git a/sci-mathematics/bertini/Manifest b/sci-mathematics/bertini/Manifest
new file mode 100644
index 000000000000..10dd27dc947f
--- /dev/null
+++ b/sci-mathematics/bertini/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST BertiniSource_v1.4.tar.gz 1827401 SHA256 61ce11b2714d1540311c1a8e3192ff92bfbd8fd85c357b554d22ab6cbe67f6a1 SHA512 bb53f8ed24a0f21e95b4e373be36039b69ea0ddb11ad8240bcf52ce64436a56c1f2057a5d733d017fdf68cfb3598a473e1f12b4659308890e2e2575b7d8143f6 WHIRLPOOL f832076f0c2277c35df28d7ed94476e1ec086c5fcb4a80e52fd3cd2d5fce79ecbc66606ba1cb0f71ca0fa6180c0e82e79b5cc85eb5949de64b6c9d8e2e8b7e6a
+EBUILD bertini-1.4.ebuild 1157 SHA256 7c444cc0bfe21354748c3e54e5a80f3ecaddc76f4403ed6b630e375ec32aba91 SHA512 59b8b7538c59da05d3784c8c7892387fa74b633cd5f9d530986c980f37b6b491a045a7606119bece1bd3fa82772516f2c8f815d9279b864f60c5757d1381193d WHIRLPOOL 56d09d92503fb58cf80523ff04c9e6ad9a202c515eda4b927a84ac8e882586c53b3aa8acaedad99d228f541404dc187a46c5dd6bfeea1c3786a920fe3af6cb77
+MISC ChangeLog 366 SHA256 d9ecd4284c2045754e9d954c05761c581cb77b865f3cfbbf0bc689c6ebe57185 SHA512 2cf11ebe1a982e85a6bc89cc7f45046bd15a69dd41f2881a3289b33bff5ac6c717a9e053059cc9c48406beaad6fc78ba4bcd973566a131ef654100f68fafad2e WHIRLPOOL 9d3f2247dcc8875876eb0583aab29e1b78b12826598fa6564602971110397241025db0318c3ee54b2c3de2a661c006bcf67b68b48102f0abc55d596dd0fcd559
+MISC metadata.xml 777 SHA256 be4033132d81992deea0f3cb9993dd0792413f35e433354b9a3e6f9c152de88f SHA512 84f9008227b46bb5ed2dc996bf89ebe00ecabd33ff6b8f65607c6cbcfc8dfef5f10011a5df19617bcc5bd500bb1f1d9769f984410d6736f1a2fe05cba9a75dcf WHIRLPOOL 89a73af15a8c326e2d6171c2117a880b2d4af7cc76a5d63f0fdde52ca985f462dbb9f17133b4669d225a1682cef567bd9bbd7561950db6fa5b2ed1a589e94b56
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.20 (GNU/Linux)
+
+iF4EAREIAAYFAlH+s38ACgkQid6yGVZcMrwzKQEAxEuJlseMtUumxNw2X7i87tcq
+S1sChYh34RP9WtYMWQ8BAJmK5j4HCoUfYjYn/lbgGRqmkVbyVvja5SztANHf8PRe
+=8lmz
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/bertini/bertini-1.4.ebuild b/sci-mathematics/bertini/bertini-1.4.ebuild
new file mode 100644
index 000000000000..ef8cac249ef2
--- /dev/null
+++ b/sci-mathematics/bertini/bertini-1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/bertini/bertini-1.4.ebuild,v 1.1 2013/08/04 20:03:02 tomka Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MYP="BertiniSource_v${PV}"
+
+DESCRIPTION="Software for Numerical Algebraic Geometry"
+HOMEPAGE="http://bertini.nd.edu"
+
+SRC_URI="http://www3.nd.edu/~sommese/bertini/${MYP}.tar.gz"
+
+LICENSE="bertini"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +optimization"
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="
+ dev-libs/gmp
+ dev-libs/mpfr
+"
+
+S="${WORKDIR}/${MYP}/src"
+
+src_prepare() {
+ if ! use optimization; then
+ sed -i -e "s/\$(OPT)/ ${CXXFLAGS} ${LDFLAGS}/" Makefile
+ else
+ sed -i -e "s/\$(OPT)/ \$(OPT) ${LDFLAGS}/" Makefile
+ fi
+ sed -i -e "s/gcc/$(tc-getCC)/" Makefile
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dobin bertini
+ if use doc; then
+ dodoc "${WORKDIR}/${MYP}/BertiniUsersManual.pdf"
+ fi
+ if use examples; then
+ insinto "/usr/share/${PN}"
+ doins -r "${WORKDIR}/${MYP}/examples"
+ elog "Examples have been installed into /usr/share/${MYP}"
+ fi
+}
diff --git a/sci-mathematics/bertini/metadata.xml b/sci-mathematics/bertini/metadata.xml
new file mode 100644
index 000000000000..e79bcd17ddc7
--- /dev/null
+++ b/sci-mathematics/bertini/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Bertini: Software for Numerical Algebraic Geometry
+
+Facts in brief:
+
+ Purpose: The numerical solution of systems of polynomial equations
+
+ Approach: Homotopy continuation.
+
+ Authors: Daniel J. Bates, Jonathan D. Hauenstein, Andrew J. Sommese, Charles W. Wampler
+
+ Background: Bertini is a general-purpose solver, written in C, that was
+ created for research about polynomial continuation.
+</longdescription>
+<use>
+ <flag name="optimization">Accept upstream's choices for -O option.</flag>
+</use>
+</pkgmetadata>