summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-09-06 00:12:26 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-09-06 00:12:26 +0000
commit2f6996cf69bf7d0e67c695ddc1c8b599a9221b47 (patch)
treea8d7b86bee1da0f55cf3da2f1d0c3838a72adb7f /sci-mathematics
parent(#104660) Get rid of obsolete license. (diff)
downloadhistorical-2f6996cf69bf7d0e67c695ddc1c8b599a9221b47.tar.gz
historical-2f6996cf69bf7d0e67c695ddc1c8b599a9221b47.tar.bz2
historical-2f6996cf69bf7d0e67c695ddc1c8b599a9221b47.zip
Fixed USE=mpi handling.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog5
-rw-r--r--sci-mathematics/octave/Manifest8
-rw-r--r--sci-mathematics/octave/octave-2.1.69.ebuild10
3 files changed, 16 insertions, 7 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index bc3108367b9f..77dd7128ddd6 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.12 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.13 2005/09/06 00:12:26 kugelfang Exp $
+
+ 06 Sep 2005; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.69.ebuild:
+ Fixed USE=mpi handling.
*octave-2.1.71 (21 Aug 2005)
diff --git a/sci-mathematics/octave/Manifest b/sci-mathematics/octave/Manifest
index 0d7104c74908..10526f8ec2ce 100644
--- a/sci-mathematics/octave/Manifest
+++ b/sci-mathematics/octave/Manifest
@@ -1,8 +1,8 @@
+MD5 ef7ea2b376c5ebccde58ab393d005495 ChangeLog 8623
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 4842851327d8ccfb46012e109ff57f9f octave-2.1.71.ebuild 3522
-MD5 4dc8df17b0394c84aa07993c2c54e5bd octave-2.1.69.ebuild 3519
MD5 62c4dfb1220dccc6624875121b80bbeb octave-2.1.57-r1.ebuild 3668
-MD5 4ac4d6f9bab2cc109ffb4b22391f2e10 ChangeLog 8521
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 b2d461730ff166dfb8f752a8aea22d80 octave-2.1.69.ebuild 3635
+MD5 6582a298022b4c4301eca44791cb6da2 files/digest-octave-2.1.71 67
MD5 32c6cee1f5b42b8b20369c3722fb4db2 files/digest-octave-2.1.57-r1 67
MD5 67d13a7bca35d1d0210394b7735fd073 files/digest-octave-2.1.69 67
-MD5 6582a298022b4c4301eca44791cb6da2 files/digest-octave-2.1.71 67
diff --git a/sci-mathematics/octave/octave-2.1.69.ebuild b/sci-mathematics/octave/octave-2.1.69.ebuild
index fd7cb6ee7eb1..7b4eff009dbe 100644
--- a/sci-mathematics/octave/octave-2.1.69.ebuild
+++ b/sci-mathematics/octave/octave-2.1.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.6 2005/08/21 04:15:27 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.69.ebuild,v 1.7 2005/09/06 00:12:26 kugelfang Exp $
inherit flag-o-matic
@@ -24,6 +24,7 @@ DEPEND="virtual/libc
tetex? ( virtual/tetex )
x86? ( ifc? ( dev-lang/ifc ) )
blas? ( virtual/blas )
+ mpi? ( sys-cluster/lam-mpi )
!=app-text/texi2html-1.70"
# NOTE: octave supports blas/lapack from intel but this is not open
@@ -51,9 +52,14 @@ src_compile() {
# Danny van Dyk 2004/08/26
use zlib && LDFLAGS="${LDFLAGS} -lz"
+ if use mpi; then
+ myconf="${myconf} --with-mpi=lammpi++"
+ else
+ myconf="${myconf} --without-mpi"
+ fi
+
econf \
$(use_with hdf5) \
- $(use_with mpi) \
$(use_enable readline) \
${myconf} \
LDFLAGS="${LDFLAGS}" || die "econf failed"