summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-04-03 12:40:00 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-04-03 12:40:00 +0000
commitb69a4071a41a5d327d2a48fcbb957c8964d20d04 (patch)
tree2b3865cc38debcb8c6a12ec9a05486215a5e7738 /sci-mathematics
parentJust in case - this is final cleanup for Locale-Maktext-Lexicon snafu (diff)
downloadhistorical-b69a4071a41a5d327d2a48fcbb957c8964d20d04.tar.gz
historical-b69a4071a41a5d327d2a48fcbb957c8964d20d04.tar.bz2
historical-b69a4071a41a5d327d2a48fcbb957c8964d20d04.zip
Fixed -fPIC handling. Fixed BUG #87283. Marked stable on amd64.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/Manifest12
-rw-r--r--sci-mathematics/pari/pari-2.1.6.ebuild26
2 files changed, 24 insertions, 14 deletions
diff --git a/sci-mathematics/pari/Manifest b/sci-mathematics/pari/Manifest
index c12c013ca7df..de1168ff59fa 100644
--- a/sci-mathematics/pari/Manifest
+++ b/sci-mathematics/pari/Manifest
@@ -1,11 +1,21 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 bcb807d16b683aaa33ee7661306f6c50 ChangeLog 3572
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 d33b0309bbbaa8e508e35af360efb31b pari-2.1.5-r1.ebuild 953
MD5 4818ef4876441247184df2b11538de44 pari-2.1.5-r4.ebuild 1882
-MD5 fe209288831d560efb220c57e0f91661 pari-2.1.6.ebuild 1629
+MD5 3f0a4b74c862c38b7048281e78d7ebc4 pari-2.1.6.ebuild 1683
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r1 63
MD5 ee951aeeb2122fab2aaf9803097fad76 files/digest-pari-2.1.5-r4 63
MD5 2fd9906f2bf293fdad42d572846508de files/digest-pari-2.1.6 60
MD5 c3f89da5ddbdb73646e3d64ee31ea887 files/docs.patch 915
MD5 dccf7ef464f99fa750a5c7fc3ec67e8f files/wrong_functype-r1.patch 1498
MD5 cbd309a01e2fee1a5ba6cb3a93ba5708 files/wrong_functype.patch 1946
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFCT+Sg5mJXAu5GbtIRAtLGAJ0a9sqcYySSWNU3NPCXhag1T3a4iACeKOnC
+IJLgVuTC9RRLVFNrDYCMRDM=
+=+TlM
+-----END PGP SIGNATURE-----
diff --git a/sci-mathematics/pari/pari-2.1.6.ebuild b/sci-mathematics/pari/pari-2.1.6.ebuild
index 857380f0eedc..01b6ff2d296b 100644
--- a/sci-mathematics/pari/pari-2.1.6.ebuild
+++ b/sci-mathematics/pari/pari-2.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.3 2005/03/29 03:07:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pari/pari-2.1.6.ebuild,v 1.4 2005/04/03 12:40:00 kugelfang Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/unix/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~hppa ~mips ~ppc ~sparc ~x86"
IUSE="doc emacs"
DEPEND="doc? ( virtual/tetex )"
@@ -32,22 +32,22 @@ src_compile() {
addwrite "/var/lib/texmf"
addwrite "/usr/share/texmf"
addwrite "/var/cache/fonts"
- if use amd64 || use alpha || use hppa ; then
- # Fixes BUG #49583
- einfo "Building shared library..."
- cd Olinux-${CHOST%%-*}
- emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
- einfo "Building executables..."
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building exectuables failed!"
- else
- emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp || die
- fi
+
+ # Shared libraries should be PIC on ALL architectures.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/31
+ # Fixes BUG #49583
+ einfo "Building shared library..."
+ cd Olinux-* || die "Bad directory. File a BUG!"
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE -fPIC" lib-dyn || die "Building shared library failed!"
+ einfo "Building executables..."
+ emake CFLAGS="${CFLAGS} -DGCC_INLINE" gp ../gp || die "Building executables failed!"
+
use doc || rm -rf doc/*.tex
use doc && emake doc
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} LIBDIR=${D}/usr/$(get_libdir) install || die
if use emacs; then
insinto /usr/share/emacs/site-lisp
doins emacs/pari.el