summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 19:10:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 19:10:20 +0000
commit1a83eb54a6071c0d696de7c46d38d4ca906f591a (patch)
treeff9a60ea9faa8a1b7dc2a299953dd830cde6cac0 /sci-physics/bullet
parentRemoving gkrellm-bfm after p.mask period is up. Bug #207720 (diff)
downloadhistorical-1a83eb54a6071c0d696de7c46d38d4ca906f591a.tar.gz
historical-1a83eb54a6071c0d696de7c46d38d4ca906f591a.tar.bz2
historical-1a83eb54a6071c0d696de7c46d38d4ca906f591a.zip
Initial import. Thanks Renato Caldas <seventhguardian@gmail.com> for his initial work. Closing bug #166192
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-physics/bullet')
-rw-r--r--sci-physics/bullet/ChangeLog11
-rw-r--r--sci-physics/bullet/Manifest14
-rw-r--r--sci-physics/bullet/bullet-2.67.ebuild47
-rw-r--r--sci-physics/bullet/metadata.xml10
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
new file mode 100644
index 000000000000..82b1ca90d5f5
--- /dev/null
+++ b/sci-physics/bullet/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-physics/bullet
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+
+*bullet-2.67 (11 Mar 2008)
+
+ 11 Mar 2008; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +bullet-2.67.ebuild:
+ Initial import. Thanks Renato Caldas <seventhguardian@gmail.com> for his
+ initial work. Closing bug #166192
+
diff --git a/sci-physics/bullet/Manifest b/sci-physics/bullet/Manifest
new file mode 100644
index 000000000000..f96939024a38
--- /dev/null
+++ b/sci-physics/bullet/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST bullet-2.67.tgz 5918156 RMD160 7d56de4dfee6269686628c1394e0bc297bf693a0 SHA1 7a091558263c056f70fa308b11c05c3926e9e505 SHA256 217a90389f70a651c48eaa5c0c3b1d08086448772438fed44612d847b13a6d03
+EBUILD bullet-2.67.ebuild 1121 RMD160 f43a71f5734ddbe035efc49978ca814241fa5636 SHA1 305bde17697c772cf9d08b3aeb796facfc1caa13 SHA256 3f5b8d0a7a0bd906ff49cd4e970d5d6e1e5209ce1fb856b57b2664e8d83f45c4
+MISC ChangeLog 444 RMD160 617c4c41ad5a7f8e8e2d5055213028744b30a075 SHA1 96a3d00bc01d4043f418a96959702d544420b6aa SHA256 9c67f6235cd0dc84344f1e8b4164b92fdba8bc25ba2d12480203bb50c672ccab
+MISC metadata.xml 350 RMD160 58e5a06b4029ee0ee2f2de5b1008fbb233beae23 SHA1 7a5d337c1364ca38a28378b7df86ac801b354ca7 SHA256 c2651cf06a3d9498dfb05e05b7899292a7a7fd0a45fd28e4f8eaa7bd2b88b726
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFH1tkn1ycZbhPLE2ARAvDnAJ4yQ0D+QMOhAkFsb6ltoscfkoRMuQCdEq/8
++VJJAUju0HIZjQvNg0B3L1E=
+=O9Ng
+-----END PGP SIGNATURE-----
diff --git a/sci-physics/bullet/bullet-2.67.ebuild b/sci-physics/bullet/bullet-2.67.ebuild
new file mode 100644
index 000000000000..a197496dccbb
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.67.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.67.ebuild,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.continuousphysics.com/Bullet/"
+SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples"
+
+RDEPEND="examples? ( virtual/opengl virtual/glut )"
+DEPEND="${DEPEND}
+ || ( dev-util/jam dev-util/ftjam )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:-O3 -fomit-frame-pointer -ffast-math::' \
+ Jamrules || die "sed Jamrules failed"
+}
+
+src_compile() {
+ econf \
+ $(use_with examples x) \
+ $(use_with examples mesa) \
+ || die "econf failed"
+ jam -qa || die "jam failed"
+}
+
+src_test() {
+ jam check || die "jam check failed"
+}
+
+src_install() {
+ jam -sDESTDIR="${D}" install || die "jam install failed"
+ dodoc README ChangeLog.txt AUTHORS || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ fi
+}
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
new file mode 100644
index 000000000000..fff1dddb8ce3
--- /dev/null
+++ b/sci-physics/bullet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ Bullet is a professional open source multi-threaded
+ 3D Collision Detection and Rigid Body Dynamics Library
+ for games and animation.
+</longdescription>
+</pkgmetadata>