summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-06 18:18:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-06 18:18:37 +0000
commitd47014847eb10895411380e016985fd3b2c43a2d (patch)
tree8ec576e1f98d642a488a429f7d7fb6b2e1f0c745 /sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
parentmasked lightspeed for broken launch of application (diff)
downloadhistorical-d47014847eb10895411380e016985fd3b2c43a2d.tar.gz
historical-d47014847eb10895411380e016985fd3b2c43a2d.tar.bz2
historical-d47014847eb10895411380e016985fd3b2c43a2d.zip
Updated with gtk-2 dependency, see bug #204621. Warning: still buggy.
Package-Manager: portage-2.1.4_rc14
Diffstat (limited to 'sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild')
-rw-r--r--sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
new file mode 100644
index 000000000000..21597ce80fea
--- /dev/null
+++ b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild,v 1.1 2008/01/06 18:18:36 bicatali Exp $
+
+inherit eutils
+
+DEB_PATCH="${PN}_${PV}-7"
+DESCRIPTION="OpenGL interactive relativistic simulator"
+HOMEPAGE="http://lightspeed.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/objects-1.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_PATCH}.diff.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE="nls"
+LANGS="es"
+for i in ${LANGS}; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+
+DEPEND="virtual/opengl
+ x11-libs/gtkglext
+ x11-libs/gtkglarea
+ >=x11-libs/gtk+-2
+ media-libs/libpng
+ media-libs/tiff
+ truetype? ( media-libs/ftgl )"
+
+S2="${WORKDIR}/objects"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${DEB_PATCH}.diff
+}
+
+src_compile() {
+ econf \
+ --with-gtk=2 \
+ $(use_enable nls) \
+ $(use_with truetype ftgl) \
+ || die "econf failed"
+ emake || die "emake failed"
+ for i in ${LANGS}; do
+ use linguas_${i} && emake ${i}.gmo
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/icon.xpm
+ make_desktop_entry lightspeed lightspeed \
+ lightspeed.xpm "Science;Physics;Education"
+ dodoc AUTHORS ChangeLog MATH NEWS README TODO || die
+ newdoc debian/changelog ChangeLog.Debian || die
+ cd ${S2}
+ newdoc README objects-README || die
+ insinto /usr/share/${PN}
+ doins *.3ds *.lwo || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Some 3d models have been placed in /usr/share/${PN}"
+ elog "You can load them in Light Speed! from the File menu."
+ elog
+}