summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-11 12:14:47 +0000
commit996e32e20b69d597aa01f1e5a7eb7b4b0773cee8 (patch)
tree6e7ad6eec22c7553b29f324146f9c376e3a7263b /sci-physics
parentadded missing pkgconfig dep wrt bug #205494 (diff)
downloadhistorical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.tar.gz
historical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.tar.bz2
historical-996e32e20b69d597aa01f1e5a7eb7b4b0773cee8.zip
New series of patches from Debian, more compatible with gfortran and better tests. Much ebuild cleaning.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/cernlib-montecarlo/ChangeLog11
-rw-r--r--sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r1.ebuild70
-rw-r--r--sci-physics/cernlib-montecarlo/metadata.xml10
-rw-r--r--sci-physics/cernlib/ChangeLog11
-rw-r--r--sci-physics/cernlib/cernlib-2006-r1.ebuild110
-rw-r--r--sci-physics/cernlib/cernlib-2006.ebuild5
-rw-r--r--sci-physics/geant/ChangeLog11
-rw-r--r--sci-physics/geant/geant-3.21.14-r1.ebuild74
-rw-r--r--sci-physics/geant/metadata.xml12
-rw-r--r--sci-physics/paw/ChangeLog11
-rw-r--r--sci-physics/paw/metadata.xml16
-rw-r--r--sci-physics/paw/paw-2.14.04-r1.ebuild85
12 files changed, 396 insertions, 30 deletions
diff --git a/sci-physics/cernlib-montecarlo/ChangeLog b/sci-physics/cernlib-montecarlo/ChangeLog
index 246664bce9ca..164c8142d41e 100644
--- a/sci-physics/cernlib-montecarlo/ChangeLog
+++ b/sci-physics/cernlib-montecarlo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/cernlib-montecarlo
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/ChangeLog,v 1.1 2007/08/24 21:36:03 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/ChangeLog,v 1.2 2008/03/11 12:11:03 bicatali Exp $
+
+*cernlib-montecarlo-2006-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +cernlib-montecarlo-2006-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
*cernlib-montecarlo-2006 (24 Aug 2007)
diff --git a/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r1.ebuild b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r1.ebuild
new file mode 100644
index 000000000000..afe8afeaa2a8
--- /dev/null
+++ b/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib-montecarlo/cernlib-montecarlo-2006-r1.ebuild,v 1.1 2008/03/11 12:11:03 bicatali Exp $
+
+inherit eutils multilib fortran
+
+DEB_PN=mclibs
+DEB_PV=${PV}.dfsg.2
+DEB_PR=5
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="Monte-carlo library and tools for the cernlib"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/cernlib"
+LICENSE="GPL-2 LGPL-2 BSD"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran
+ sci-physics/cernlib"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+
+ cd "${S}"
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ Makefile || "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "debian patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test_() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
diff --git a/sci-physics/cernlib-montecarlo/metadata.xml b/sci-physics/cernlib-montecarlo/metadata.xml
index 1ce24154637e..44b82fa188e8 100644
--- a/sci-physics/cernlib-montecarlo/metadata.xml
+++ b/sci-physics/cernlib-montecarlo/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
-This metapackage provides various Monte Carlo libraries included in
-Cernlib (both shared and static). Likely only physicists will be
-interested in these packages.
-The libraries of Ariadne, Fritiof, Jetset, Lepto, and Pythia are not
-available for Gentoo: see cernlib Debian packaging for explanation.
+ This metapackage provides various Monte Carlo libraries included in
+ Cernlib (both shared and static). Likely only physicists will be
+ interested in these packages.
+ The libraries of Ariadne, Fritiof, Jetset, Lepto, and Pythia are not
+ available for Gentoo: see cernlib Debian packaging for explanation.
</longdescription>
</pkgmetadata>
diff --git a/sci-physics/cernlib/ChangeLog b/sci-physics/cernlib/ChangeLog
index 7f4823a36574..92db5bca5907 100644
--- a/sci-physics/cernlib/ChangeLog
+++ b/sci-physics/cernlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/cernlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/ChangeLog,v 1.6 2007/11/23 14:59:40 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/ChangeLog,v 1.7 2008/03/11 12:09:06 bicatali Exp $
+
+*cernlib-2006-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +cernlib-2006-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
23 Nov 2007; Samuli Suominen <drac@gentoo.org> cernlib-2006.ebuild:
amd64 stable wrt #196304
diff --git a/sci-physics/cernlib/cernlib-2006-r1.ebuild b/sci-physics/cernlib/cernlib-2006-r1.ebuild
new file mode 100644
index 000000000000..346203b40f85
--- /dev/null
+++ b/sci-physics/cernlib/cernlib-2006-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006-r1.ebuild,v 1.1 2008/03/11 12:09:06 bicatali Exp $
+
+inherit eutils multilib fortran
+
+DEB_PN=cernlib
+DEB_PV=${PV}.dfsg.2
+DEB_PR=11
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN program library for High Energy Physics"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/cernlib"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~sparc ~x86"
+LICENSE="GPL-2 LGPL-2 BSD"
+
+SLOT="0"
+
+DEPEND="virtual/motif
+ virtual/lapack
+ virtual/latex-base
+ dev-lang/cfortran
+ x11-misc/imake
+ x11-misc/makedepend
+ dev-util/pkgconfig"
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran"
+
+IUSE=""
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+ cd "${S}"
+
+ # set some default paths
+ sed -i \
+ -e "s:/usr/local:/usr:g" \
+ -e "s:prefix)/lib:prefix)/$(get_libdir):" \
+ -e 's:$(prefix)/etc:/etc:' \
+ -e 's:$(prefix)/man:$(prefix)/share/man:' \
+ debian/add-ons/cernlib.mk || die "sed failed"
+
+ # use system blas and lapack set by gentoo framework
+ sed -i \
+ -e "s:\$DEPS -lm:$(pkg-config --libs blas):" \
+ -e "s:\$DEPS -llapack -lm:$(pkg-config --libs lapack):" \
+ -e 's:`depend $d $a blas`::' \
+ -e "s:X11R6:X11:g" \
+ debian/add-ons/bin/cernlib.in || die "sed failed"
+
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "debian patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h \
+
+ # fix an ifort problem
+ sed -i \
+ -e 's/= $(CLIBS) -nofor_main/:= $(CLIBS) -nofor_main/' \
+ src/packlib/kuip/programs/kxterm/Imakefile || die "sed ifc failed"
+
+ # respect users flags
+ sed -i \
+ -e 's/-O3/-O2/g' \
+ -e "s/-O2/${CFLAGS}/g" \
+ src/config/linux.cf || die "sed linux.cf failed"
+}
+
+src_compile() {
+ # create local LaTeX cache dir
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake libs failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt NEWS copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
+
+pkg_postinst() {
+ elog "Gentoo ${PN} is based on Debian similar package."
+ elog "Serious cernlib users might want to check:"
+ elog "http://people.debian.org/~kmccarty/cernlib/"
+ elog "for the changes and licensing from the original package"
+ if use amd64; then
+ elog "Please see the possible warnings for ${PN} on 64 bits:"
+ elog "${ROOT}/usr/share/doc/${PF}/README.*64*"
+ fi
+}
diff --git a/sci-physics/cernlib/cernlib-2006.ebuild b/sci-physics/cernlib/cernlib-2006.ebuild
index 5dc03bb4463f..419beaa35852 100644
--- a/sci-physics/cernlib/cernlib-2006.ebuild
+++ b/sci-physics/cernlib/cernlib-2006.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006.ebuild,v 1.8 2007/11/23 14:59:40 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/cernlib/cernlib-2006.ebuild,v 1.9 2008/03/11 12:09:06 bicatali Exp $
inherit eutils multilib fortran
@@ -112,7 +112,6 @@ src_compile() {
}
src_test() {
- cd "${S}"
LD_LIBRARY_PATH="${S}"/shlib make \
TEST_PACKAGES="kernlib packlib mathlib graflib" \
DEB_BUILD_OPTIONS="${FORTRANC} nostrip" \
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 2cf149244d09..40db7ac0fe68 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/geant
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.1 2007/08/24 21:43:26 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.2 2008/03/11 12:14:47 bicatali Exp $
+
+*geant-3.21.14-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +geant-3.21.14-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
*geant-3.21.14 (24 Aug 2007)
diff --git a/sci-physics/geant/geant-3.21.14-r1.ebuild b/sci-physics/geant/geant-3.21.14-r1.ebuild
new file mode 100644
index 000000000000..edb772c3eeae
--- /dev/null
+++ b/sci-physics/geant/geant-3.21.14-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r1.ebuild,v 1.1 2008/03/11 12:14:47 bicatali Exp $
+
+DEB_PN=geant321
+DEB_PV=${PV}.dfsg
+DEB_PR=8
+DEB_P=${DEB_PN}_${DEB_PV}
+
+inherit eutils multilib fortran
+
+DESCRIPTION="CERN's detector description and simulation Tool"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/geant/index.html"
+
+LICENSE="GPL-2 LGPL-2 BSD"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran
+ sci-physics/cernlib
+ sci-physics/paw"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+KEYWORDS="~amd64 ~x86"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+ rm -f ${DEB_P}-${DEB_PR}.diff
+ cd "${S}"
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ Makefile || "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "debian patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test_() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt NEWS copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
index 54e13262758b..513adf0f9ef8 100644
--- a/sci-physics/geant/metadata.xml
+++ b/sci-physics/geant/metadata.xml
@@ -3,11 +3,11 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
-Geant simulates the passage of subatomic particles through matter, for
-instance, particle detectors. For maximum flexibility, Geant
-simulations are performed by linking Fortran code supplied by the user
-with the Geant libraries, then running the resulting executable.
-
-This package includes gxint, the script used to perform this linking step.
+ Geant simulates the passage of subatomic particles through matter, for
+ instance, particle detectors. For maximum flexibility, Geant
+ simulations are performed by linking Fortran code supplied by the user
+ with the Geant libraries, then running the resulting executable.
+
+ This package includes gxint, the script used to perform this linking step.
</longdescription>
</pkgmetadata>
diff --git a/sci-physics/paw/ChangeLog b/sci-physics/paw/ChangeLog
index 24a438d7867f..2b8ca00744bb 100644
--- a/sci-physics/paw/ChangeLog
+++ b/sci-physics/paw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/paw
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.1 2007/08/24 21:38:52 bicatali Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/ChangeLog,v 1.2 2008/03/11 12:12:41 bicatali Exp $
+
+*paw-2.14.04-r1 (11 Mar 2008)
+
+ 11 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +paw-2.14.04-r1.ebuild:
+ New series of patches from Debian, more compatible with gfortran and better
+ tests. Much ebuild cleaning.
*paw-2.14.04 (24 Aug 2007)
diff --git a/sci-physics/paw/metadata.xml b/sci-physics/paw/metadata.xml
index c3dd8b627dc4..9450758ff229 100644
--- a/sci-physics/paw/metadata.xml
+++ b/sci-physics/paw/metadata.xml
@@ -3,13 +3,13 @@
<pkgmetadata>
<herd>sci-physics</herd>
<longdescription lang="en">
-PAW is an interactive program providing interactive graphical
-presentation and statistical and mathematical analysis tools. It is
-designed to work on objects familiar to physicists such as histograms,
-event files (Ntuples), vectors, etc.
-The program is linked statically against the CERN libraries on 64-bit
-architectures in order to function properly, as its design is not very
-64-bit clean. Even so, AMD64 is the only 64-bit platform where it
-functions well.
+ PAW is an interactive program providing interactive graphical
+ presentation and statistical and mathematical analysis tools. It is
+ designed to work on objects familiar to physicists such as histograms,
+ event files (Ntuples), vectors, etc.
+ The program is linked statically against the CERN libraries on 64-bit
+ architectures in order to function properly, as its design is not very
+ 64-bit clean. Even so, AMD64 is the only 64-bit platform where it
+ functions well.
</longdescription>
</pkgmetadata>
diff --git a/sci-physics/paw/paw-2.14.04-r1.ebuild b/sci-physics/paw/paw-2.14.04-r1.ebuild
new file mode 100644
index 000000000000..0d386c65371d
--- /dev/null
+++ b/sci-physics/paw/paw-2.14.04-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/paw/paw-2.14.04-r1.ebuild,v 1.1 2008/03/11 12:12:41 bicatali Exp $
+
+inherit eutils multilib fortran
+
+DEB_PN=paw
+DEB_PV=${PV}.dfsg.2
+DEB_PR=3
+DEB_P=${DEB_PN}_${DEB_PV}
+
+DESCRIPTION="CERN's Physics Analysis Workstation data analysis program"
+HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/paw/index.html"
+LICENSE="GPL-2 LGPL-2 BSD"
+SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/motif
+ virtual/lapack
+ dev-lang/cfortran
+ sci-physics/cernlib
+ x11-libs/xbae"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ x11-misc/imake
+ x11-misc/makedepend"
+
+S="${WORKDIR}/${DEB_PN}-${DEB_PV}.orig"
+
+KEYWORDS="~amd64 ~x86"
+
+FORTRAN="gfortran g77 ifc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${DEB_P}-${DEB_PR}".diff
+
+ cd "${S}"
+ cp debian/add-ons/Makefile .
+ export DEB_BUILD_OPTIONS="${FORTRANC} nostrip nocheck"
+
+ # fix some path stuff and collision for comis.h,
+ # already installed by cernlib and replace hardcoded fortran compiler
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ -e '/comis.h/d' \
+ -e "s/gfortran/${FORTRANC}/g" \
+ Makefile || "sed'ing the Makefile failed"
+
+ einfo "Applying Debian patches"
+ emake -j1 patch || die "make patch failed"
+
+ # since we depend on cfortran, do not use the one from cernlib
+ rm -f src/include/cfortran/cfortran.h
+}
+
+src_compile() {
+ # create local LaTeX cache directory
+ mkdir -p .texmf-var
+ emake -j1 cernlib-indep cernlib-arch || die "emake failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}"/shlib \
+ emake -j1 cernlib-test || die "emake test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"/debian
+ dodoc changelog README.* deadpool.txt copyright || die "dodoc failed"
+ newdoc add-ons/README README.add-ons || die "newdoc failed"
+}
+
+pkg_postinst() {
+ if use amd64; then
+ elog "Please see the possible warnings in using ${PN} on 64 bits:"
+ elog "${ROOT}/usr/share/doc/${PF}/README.*64*"
+ fi
+}