summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-04-13 20:17:49 +0000
committerMichał Górny <mgorny@gentoo.org>2011-04-13 20:17:49 +0000
commita29689a62a23b40dd1dae5df60b3ec30a0aa6b5c (patch)
tree93cfada260645c10f689f70f4849e3ae4fbe7f60 /skel.ebuild
parentx86 stable, bug #358573 (diff)
downloadhistorical-a29689a62a23b40dd1dae5df60b3ec30a0aa6b5c.tar.gz
historical-a29689a62a23b40dd1dae5df60b3ec30a0aa6b5c.tar.bz2
historical-a29689a62a23b40dd1dae5df60b3ec30a0aa6b5c.zip
Update for PMS-4 on behalf of QA.
Diffstat (limited to 'skel.ebuild')
-rw-r--r--skel.ebuild35
1 files changed, 25 insertions, 10 deletions
diff --git a/skel.ebuild b/skel.ebuild
index ec7f224b053a..d6518c00b828 100644
--- a/skel.ebuild
+++ b/skel.ebuild
@@ -12,10 +12,11 @@
# generated to contain the correct data.
# The EAPI variable tells the ebuild format in use.
-# Defaults to 0 if not specified. The current PMS draft contains details on
-# a proposed EAPI=0 definition but is not finalized yet.
-# Eclasses will test for this variable if they need to use EAPI > 0 features.
-#EAPI=0
+# Defaults to 0 if not specified.
+# It is suggested that you the latest EAPI approved by the Council.
+# The PMS contains specifications for all EAPIs. Eclasses will test for this
+# variable if they need to use EAPI > 0 features.
+EAPI=4
# inherit lists eclasses to inherit functions from. Almost all ebuilds should
# inherit eutils, as a large amount of important functionality has been
@@ -41,6 +42,7 @@ HOMEPAGE="http://foo.bar.com/"
# Portage.
SRC_URI="ftp://foo.bar.com/${P}.tar.gz"
+
# License of the package. This must match the name of file(s) in
# /usr/portage/licenses/. For complex license combination see the developer
# docs on gentoo.org for details.
@@ -87,6 +89,7 @@ IUSE="gnome X"
# for details. Usually not needed.
#RESTRICT="strip"
+
# Build-time dependencies, such as
# ssl? ( >=dev-libs/openssl-0.9.6b )
# >=dev-lang/perl-5.6.1-r1
@@ -107,9 +110,10 @@ RDEPEND="${DEPEND}"
#S="${WORKDIR}/${P}"
-# The following src_compile function is implemented as default by portage, so
-# you only need to call it, if you need a different behaviour.
-#src_compile() {
+# The following src_configure function is implemented as default by portage, so
+# you only need to call it if you need a different behaviour.
+# This function is available only in EAPI 2 and later.
+#src_configure() {
# Most open-source packages use GNU autoconf for configuration.
# The default, quickest (and preferred) way of running configure is:
#econf
@@ -128,7 +132,14 @@ RDEPEND="${DEPEND}"
# Note the use of --infodir and --mandir, above. This is to make
# this package FHS 2.2-compliant. For more information, see
# http://www.pathname.com/fhs/
+#}
+# The following src_compile function is implemented as default by portage, so
+# you only need to call it, if you need different behaviour.
+# For EAPI < 2 src_compile runs also commands currently present in
+# src_configure. Thus, if you're using an older EAPI, you need to copy them
+# to your src_compile and drop the src_configure function.
+#src_compile() {
# emake (previously known as pmake) is a script that calls the
# standard GNU make with parallel building options for speedier
# builds (especially on SMP systems). Try emake first. It might
@@ -140,12 +151,16 @@ RDEPEND="${DEPEND}"
#emake || die "emake failed"
#}
-src_install() {
+# The following src_install function is implemented as default by portage, so
+# you only need to call it, if you need different behaviour.
+# For EAPI < 4 src_install is just returing true, so you need to always specify
+# this function in older EAPIs.
+#src_install() {
# You must *personally verify* that this trick doesn't install
# anything outside of DESTDIR; do this by reading and
# understanding the install part of the Makefiles.
# This is the preferred way to install.
- emake DESTDIR="${D}" install || die "emake install failed"
+ #emake DESTDIR="${D}" install || die "emake install failed"
# When you hit a failure with emake, do not just use make. It is
# better to fix the Makefiles to allow proper parallelization.
@@ -168,4 +183,4 @@ src_install() {
# The portage shortcut to the above command is simply:
#
#einstall || die "einstall failed"
-}
+#}