summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-12-19 00:00:33 +0000
committerNed Ludd <solar@gentoo.org>2003-12-19 00:00:33 +0000
commitd49387fc65fe4cfe9e85d532944e7eb728a6fd54 (patch)
treeefd00a80ada1ba6ae6a1eb526d2f33a541685f29 /sys-apps/busybox
parentversion bump of the _pre series.. (diff)
downloadhistorical-d49387fc65fe4cfe9e85d532944e7eb728a6fd54.tar.gz
historical-d49387fc65fe4cfe9e85d532944e7eb728a6fd54.tar.bz2
historical-d49387fc65fe4cfe9e85d532944e7eb728a6fd54.zip
version bump of the _pre series..
This release includes major rework to sed, lots of rework on tar, a new tiny implementation of bunzip2, a new devfsd applet, support for 2.6.x kernel modules, updates to the ash shell, sha1sum and md5sum have been merged into a common applet, the dpkg applets has been cleaned up.
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/Manifest4
-rw-r--r--sys-apps/busybox/busybox-1.00_pre4.ebuild159
-rw-r--r--sys-apps/busybox/files/digest-busybox-1.00_pre41
3 files changed, 162 insertions, 2 deletions
diff --git a/sys-apps/busybox/Manifest b/sys-apps/busybox/Manifest
index 1414c751ac97..5d50bb559065 100644
--- a/sys-apps/busybox/Manifest
+++ b/sys-apps/busybox/Manifest
@@ -1,4 +1,4 @@
-MD5 cce972250fb80d0c1d4e19d59dbe8ab0 ChangeLog 3148
+MD5 e6e6de980618700bb801797c6be6e56f ChangeLog 3568
MD5 041f6348b9b2c3051a19d8f3611cd259 busybox-0.50.ebuild 1024
MD5 d2aea6e7d4671cde6cb2da4579fbb6f1 busybox-0.60.2.ebuild 1242
MD5 bfec32dd92d147690a1271b7915a1579 busybox-0.60.3-r1.ebuild 1103
@@ -7,7 +7,7 @@ MD5 cbc0a83fefc19b66aa495c08cf2c2d9b busybox-0.60.5-r1.ebuild 1433
MD5 482b4170d2e88c1218be4f43f124d26d busybox-0.60.5.ebuild 1043
MD5 d62c3f2a74eb8b11a24e53b6ad346d43 busybox-1.00_pre3.ebuild 4392
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 d62c3f2a74eb8b11a24e53b6ad346d43 busybox-1.00_pre4.ebuild 4392
+MD5 2f47f0cc19c18bcea9f4828dcab94aa7 busybox-1.00_pre4.ebuild 4392
MD5 cd67b7e833d718b6fde55506d1cb556d busybox-0.60.5-r2.ebuild 2150
MD5 9ce965b12114a360496fe06e952139a8 files/Config.h 11695
MD5 24ec3839ecb3e429bf29a819398b7753 files/Config.h-0.60.2-cd 13772
diff --git a/sys-apps/busybox/busybox-1.00_pre4.ebuild b/sys-apps/busybox/busybox-1.00_pre4.ebuild
new file mode 100644
index 000000000000..b0bd90b84dfd
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.00_pre4.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.00_pre4.ebuild,v 1.1 2003/12/19 00:00:24 solar Exp $
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Utilities for rescue and embedded systems"
+SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.gz"
+HOMEPAGE="http://www.busybox.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="debug static uclibc"
+
+# Forward anticipation of expected supported arches would include ~x86
+# ~alpha ~mips ~ppc ~sparc
+
+DEPEND="virtual/glibc
+ uclibc? ( dev-libs/uclibc )
+"
+RDEPEND="!static? ${DEPEND}"
+# <pebenito> then eventually turning on selinux would mean
+# adding a dep: selinux? ( sys-libs/libselinux )
+
+busybox_config_option() {
+ [ "$2" = "" ] && return 1
+ case $1 in
+ y) sed -e "s:.*CONFIG_$2.*set:CONFIG_$2=y:g" < \
+ .config > .config~;;
+ n) sed -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" < \
+ .config > .config~;;
+ *) return 1;;
+ esac
+ mv .config{~,}
+ einfo `grep CONFIG_$2 .config`
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # busybox has changed quite a bit from 0.[5-6]* to 1.x so this
+ # config might not be cd ready.
+ make defconfig
+
+ #[ -f .config ] || die "No .config file found for ${PN}"
+
+ # setting the cross compiler from here would be somewhat of a
+ # pain do to as we would need a multiline sed expression which
+ # does not always seem to work so hot for me.
+
+ [ `use static` ] && busybox_config_option y STATIC ||
+ busybox_config_option n STATIC
+
+ # 1.00-pre2 uses the old selinux api which is no longer
+ # maintained. perhaps the next stable release will include
+ # support.
+ #
+
+ #[ `use selinux` ] && busybox_config_option y SELINUX ||
+ # busybox_config_option n SELINUX
+
+ [ `use debug` ] && busybox_config_option y DEBUG ||
+ busybox_config_option n DEBUG
+
+ # Supported architectures:
+
+ # Busybox in general will build on any architecture supported by
+ # gcc. It has a few specialized features added for __sparc__
+ # and __alpha__. insmod functionality is currently limited to
+ # x86, ARM, SH3/4, powerpc, m68k, MIPS, and v850e.
+
+ case ${ARCH} in
+ alpha|sparc*)
+ # non x86 needs to figure out what works for
+ # them the best. sparc64 bobmed while building
+ # ash in my tests
+ busybox_config_option n INSMOD
+ busybox_config_option n MODPROBE
+ busybox_config_option n RMMOD;;
+ *) ;;
+ esac
+
+ # This could almost work but might not be a good idea till we
+ # find a better sed expression for busybox_config_option() or
+ # per package use flags come into play.
+ #
+ #busybox_features=`grep CONFIG_ .config | tr '#' '\n' |
+ # awk '{print $1}' | cut -d = -f 1 | grep -v ^$ | cut -c 8- |
+ # tr [A-Z] [a-z] | awk '{print "busybox_"$1}'`
+ #for f in $busybox_features; do
+ # has $f ${FEATURES} && busybox_config_option y `echo ${f/busybox_/}|tr [a-z] [A-Z]`
+ #done
+}
+
+src_compile() {
+ if [ `use uclibc` ]; then
+ case ${ARCH} in
+ x86*) CROSS="/usr/i386-linux-uclibc/bin/i386-uclibc-";;
+ *) ;;
+ esac
+ fi
+ [ -n "${CROSS}" ] && einfo "Setting cross compiler prefix to ${CROSS}"
+ # MAKEOPTS="-j1" emake CROSS="${CROSS}" include/config.h busybox || die
+ MAKEOPTS="-j1" emake CROSS="${CROSS}" busybox || die
+}
+
+src_install() {
+ into /
+ dobin busybox
+
+ into /usr
+ dodoc AUTHORS Changelog LICENSE README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html
+ dohtml *.sgml
+
+ # no man files?
+ # cd ../man && doman *.1
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab
+ dodoc depmod.pl
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ for f in bootfloppy.txt display.txt mkdevs.sh etc/* etc/init.d/* ; do
+ [ -f ${f} ] && dodoc ${f}
+ done
+
+ cd ../../ || die
+
+ if [ `has buildpkg ${FEATURES}` -a `has keepwork ${FEATURES}` ]; then
+ cd ${S}
+ # this should install to the ./_install/ dir by default.
+ # we make a micro pkg of busybox that can be used for
+ # embedded systems -solar
+ make install && cd ./_install/ &&
+ tar --no-same-owner -jcvf \
+ ${WORKDIR}/${MY_P}-${ARCH}.bz2 . && cd ..
+ fi
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Edit /usr/portage/sys-apps/busybox/files/${MY_P}.config and"
+ einfo "re-emerge if you need to add/remove functionality in "
+ einfo "BusyBox."
+ einfo ""
+ [ `has buildpkg ${FEATURES}` -a `has keepwork ${FEATURES}` ] &&
+ einfo "A ${PN} minipkg can be found at ${WORKDIR}/${MY_P}-${ARCH}.bz2"
+}
diff --git a/sys-apps/busybox/files/digest-busybox-1.00_pre4 b/sys-apps/busybox/files/digest-busybox-1.00_pre4
new file mode 100644
index 000000000000..42451553218c
--- /dev/null
+++ b/sys-apps/busybox/files/digest-busybox-1.00_pre4
@@ -0,0 +1 @@
+MD5 7f17b9f51b48c25f8d9843c20a2fd39b busybox-1.00-pre4.tar.gz 1293296