summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-11-02 08:45:05 +0000
committerDonny Davies <woodchip@gentoo.org>2001-11-02 08:45:05 +0000
commit0184b0d96c6d10a055e8a1b0859af70c18ff6b9f (patch)
tree0ee0af3d5085186ea1709d44a3fcaea0894b546a /sys-apps/file
parentCleanups, DEPEND update (diff)
downloadhistorical-0184b0d96c6d10a055e8a1b0859af70c18ff6b9f.tar.gz
historical-0184b0d96c6d10a055e8a1b0859af70c18ff6b9f.tar.bz2
historical-0184b0d96c6d10a055e8a1b0859af70c18ff6b9f.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/file-3.37.ebuild31
-rw-r--r--sys-apps/file/files/digest-file-3.371
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/file/file-3.37.ebuild b/sys-apps/file/file-3.37.ebuild
new file mode 100644
index 000000000000..fb1e079f486e
--- /dev/null
+++ b/sys-apps/file/file-3.37.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.37.ebuild,v 1.1 2001/11/02 08:45:05 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
+SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
+ ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man \
+ --datadir=/usr/share/misc --host=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ if [ -z "`use build`" ] ; then
+ dodoc LEGAL.NOTICE MAINT README
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
diff --git a/sys-apps/file/files/digest-file-3.37 b/sys-apps/file/files/digest-file-3.37
new file mode 100644
index 000000000000..c76382796f60
--- /dev/null
+++ b/sys-apps/file/files/digest-file-3.37
@@ -0,0 +1 @@
+MD5 5743b2fc24743b6188504762d40c0b4c file-3.37.tar.gz 167936