summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-01-01 19:52:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-01-01 19:52:35 +0000
commitdee745a21b904fea62554255b7f0ecb7ddd246b0 (patch)
tree71e781db0162a72c4b8107146e3fc208e805632c /sys-apps/hal
parentStable on x86; bug #116181 (diff)
downloadhistorical-dee745a21b904fea62554255b7f0ecb7ddd246b0.tar.gz
historical-dee745a21b904fea62554255b7f0ecb7ddd246b0.tar.bz2
historical-dee745a21b904fea62554255b7f0ecb7ddd246b0.zip
sys floppy patch
Package-Manager: portage-2.1_pre3
Diffstat (limited to 'sys-apps/hal')
-rw-r--r--sys-apps/hal/Manifest12
-rw-r--r--sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch12
2 files changed, 21 insertions, 3 deletions
diff --git a/sys-apps/hal/Manifest b/sys-apps/hal/Manifest
index d5c3dd5cf2be..1bc2d810aeab 100644
--- a/sys-apps/hal/Manifest
+++ b/sys-apps/hal/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 2b14d30b114797b4cafe8b049d8d6956 ChangeLog 9700
MD5 f8ec045cb9f929b5bc89e16ce3cbd637 files/0.5-hald.rc 646
MD5 3031a9fe74f43859c313d5f3076e68cd files/digest-hal-0.4.7-r2 62
@@ -7,7 +10,7 @@ MD5 a0ce1c268e0b7d0967ec7b8e0d0d26d2 files/hal-0.4.1-old_storage_policy.patch 12
MD5 b0e12a62ce698e1eb2a32139498330cd files/hal-0.4.5-gentoo_gphoto2_usermap.patch 817
MD5 c1624c9456f164c1b611e3ab22fb105d files/hal-0.4.7-device_info_leak.patch 2203
MD5 64253ef1f2dcf68b2d82429026280085 files/hal-0.4.7-dont_add_device_twice-r1.patch 691
-MD5 58ed07e2de5e898a1e4eeedf595ddb06 files/hal-0.4.7-sys_floppy_detection.patch 568
+MD5 04b0aabf9ea7f7667e54bc6d5b8fe733 files/hal-0.4.7-sys_floppy_detection.patch 784
MD5 a4d2c4884a3dedf2450cf37508d3c122 files/hal-0.4.7-vfat_mount_utf8.patch 670
MD5 e3ecbfe57c0833d32f0ea57a0de58aee files/hal-0.4.8-fix_dvdram.patch 465
MD5 25cb64ec27a48a80126b6de5ff6c3340 files/hal-0.5.1-old_storage_policy.patch 856
@@ -18,3 +21,10 @@ MD5 88fefb2d123c55e564d4b87ff3c7c157 hal-0.4.7-r2.ebuild 3449
MD5 7377ce8d8bb7dec04549c83aa3fbc9d6 hal-0.4.8.ebuild 3416
MD5 5fe5ffac0018125c9a74e1d1fcffa576 hal-0.5.5.1-r3.ebuild 3701
MD5 a60767d83157413d549c69b98fac962c metadata.xml 303
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDuDMtBtvusYtCZMsRAikTAKCEbewVGsNU5Mq7UAGsIMYhOckrQQCeNwNR
+W5r6OGOI0egsQQf5FrhoIbo=
+=NUCP
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch b/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch
index b04168bf01c0..9127f70ad5a7 100644
--- a/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch
+++ b/sys-apps/hal/files/hal-0.4.7-sys_floppy_detection.patch
@@ -1,6 +1,5 @@
-diff -x '*~' -uNr hal-0.4.7/hald/linux/platform_bus_device.c hal-0.4.7.patched/hald/linux/platform_bus_device.c
--- hal-0.4.7/hald/linux/platform_bus_device.c 2004-11-22 22:53:50.000000000 +0100
-+++ hal-0.4.7.patched/hald/linux/platform_bus_device.c 2005-04-17 19:20:37.000000000 +0200
++++ hal-0.4.7-patched/hald/linux/platform_bus_device.c 2005-10-11 13:53:46.000000000 +0200
@@ -66,7 +66,7 @@
if (strncmp (device->bus_id, "floppy", 6) != 0)
return FALSE;
@@ -10,3 +9,12 @@ diff -x '*~' -uNr hal-0.4.7/hald/linux/platform_bus_device.c hal-0.4.7.patched/h
/* get device file */
snprintf (fd_sysfs_path, sizeof (fd_sysfs_path), "%s/block/fd%d",
+@@ -147,7 +147,7 @@
+ char device_file[256];
+ char fd_sysfs_path[256];
+
+- sscanf (device->bus_id, "floppy%d", &number);
++ sscanf (device->bus_id, "%*[flopy.]%d", &number);
+ hal_device_property_set_int (d, "storage.legacy_floppy.number", number);
+
+ hal_device_property_set_string (d, "info.product", "Legacy Floppy Drive");