summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-10 00:57:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-10 00:57:59 +0000
commit5669849acc12c1f8f6cb5ac0841f6426e7f54bf4 (patch)
treeb8f032a07149bdd2d0bd752616a555a79180296b /sys-apps/hprofile
parentversion bump (diff)
downloadhistorical-5669849acc12c1f8f6cb5ac0841f6426e7f54bf4.tar.gz
historical-5669849acc12c1f8f6cb5ac0841f6426e7f54bf4.tar.bz2
historical-5669849acc12c1f8f6cb5ac0841f6426e7f54bf4.zip
initial ebuild #36377
Diffstat (limited to 'sys-apps/hprofile')
-rw-r--r--sys-apps/hprofile/ChangeLog8
-rw-r--r--sys-apps/hprofile/Manifest14
-rw-r--r--sys-apps/hprofile/files/digest-hprofile-2.0_beta21
-rw-r--r--sys-apps/hprofile/hprofile-2.0_beta2.ebuild56
-rw-r--r--sys-apps/hprofile/metadata.xml5
5 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/hprofile/ChangeLog b/sys-apps/hprofile/ChangeLog
new file mode 100644
index 000000000000..1bb9e66573d8
--- /dev/null
+++ b/sys-apps/hprofile/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-apps/hprofile
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hprofile/ChangeLog,v 1.1 2004/10/10 00:57:59 vapier Exp $
+
+*hprofile-2.0_beta2 (09 Oct 2004)
+
+ 09 Oct 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Martin Aspeli #36377.
diff --git a/sys-apps/hprofile/Manifest b/sys-apps/hprofile/Manifest
new file mode 100644
index 000000000000..7dba954cd0ee
--- /dev/null
+++ b/sys-apps/hprofile/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 912ede66946c96032efef1aa4619c4b9 hprofile-2.0_beta2.ebuild 1875
+MD5 98727e8f1f3b99bfebd476f39345c8f5 ChangeLog 355
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 16e617a2b23310082c5b1b051f27f94b files/digest-hprofile-2.0_beta2 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBaIkuHTu7gpaalycRAqnmAJ4kTbkcEZjKKYH0GcLbnOXZUGr9YgCg5tAs
+pp6Ii+8LXImkQLdP7/tlSgU=
+=lke9
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/hprofile/files/digest-hprofile-2.0_beta2 b/sys-apps/hprofile/files/digest-hprofile-2.0_beta2
new file mode 100644
index 000000000000..5e4f3bca4ea3
--- /dev/null
+++ b/sys-apps/hprofile/files/digest-hprofile-2.0_beta2
@@ -0,0 +1 @@
+MD5 e25414d021f3f369a9b1ab2d4efb5a0e hprofile-2.0_beta2.tar.gz 32082
diff --git a/sys-apps/hprofile/hprofile-2.0_beta2.ebuild b/sys-apps/hprofile/hprofile-2.0_beta2.ebuild
new file mode 100644
index 000000000000..00179655f781
--- /dev/null
+++ b/sys-apps/hprofile/hprofile-2.0_beta2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hprofile/hprofile-2.0_beta2.ebuild,v 1.1 2004/10/10 00:57:59 vapier Exp $
+
+DESCRIPTION="Utility to manage hardware, network, power or other profiles"
+HOMEPAGE="http://hprofile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hprofile/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-shells/bash-2.0
+ >=app-admin/sudo-1.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for f in $(grep /usr/local * -rl) ; do
+ sed -i 's:/usr/local:/usr:g' ${f}
+ done
+}
+
+src_install() {
+ dosbin scripts/* || die "dosbin"
+
+ dodir /etc/hprofile
+ cp -r config/hprofile/* ${D}/etc/hprofile/ || die "cp"
+
+ exeinto /etc/init.d
+ doexe extra/rc-scripts/gentoo/*
+
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "Example profiles have been installed into /etc/hprofile/example-profiles"
+ einfo "Initscripts have been been installed to /etc/init.d."
+ einfo
+ einfo "Scripts that should be run from the 'boot' runlevel:"
+ einfo " - hprofile (applies the 'boot' profile)"
+ einfo " - hprunlevel (switches to profile-specific runlevel)"
+ einfo "Scripts that should be run from your default runlevel:"
+ einfo " - net.profile (applies the current 'net' profile)"
+ einfo " - power-profile (applies the current 'power' profile)"
+ einfo
+ einfo "If you get an error message that 'hprunlevel' and 'local' have a"
+ einfo "circular dependency of type 'iafter', this is not a problem, since"
+ einfo "'hprunlevel' and 'local' are not started from the same runlevel"
+ einfo
+ einfo "Also note that the file /etc/runlevels/.critical has been created."
+ einfo "This file contains the 'critical' boot services; since hprofile"
+ einfo "should be started before modules (which is a critical service),"
+ einfo "it must be mentioned in this file."
+}
diff --git a/sys-apps/hprofile/metadata.xml b/sys-apps/hprofile/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/hprofile/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>