summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-17 09:21:14 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-17 09:21:14 +0000
commit3071f1ab27e4420ad44f825d97b2902fa976606e (patch)
tree1e3b136bbc441b47d0429ea17bde2dbde7870ae3 /sys-apps/hwsetup/files
parentEAPI bump. Clean up patch. (diff)
downloadhistorical-3071f1ab27e4420ad44f825d97b2902fa976606e.tar.gz
historical-3071f1ab27e4420ad44f825d97b2902fa976606e.tar.bz2
historical-3071f1ab27e4420ad44f825d97b2902fa976606e.zip
EAPI bump. Clean up patches.
Package-Manager: portage-2.2.13/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'sys-apps/hwsetup/files')
-rw-r--r--sys-apps/hwsetup/files/1.2-3-dyn_blacklist.patch62
-rw-r--r--sys-apps/hwsetup/files/1.2-3-fastprobe.patch5
-rw-r--r--sys-apps/hwsetup/files/1.2-3-gentoo.patch41
-rw-r--r--sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch5
-rw-r--r--sys-apps/hwsetup/files/1.2-7-gentoo.patch5
-rw-r--r--sys-apps/hwsetup/files/1.2-7-openchrome.patch4
-rw-r--r--sys-apps/hwsetup/files/1.2-strip.patch4
7 files changed, 10 insertions, 116 deletions
diff --git a/sys-apps/hwsetup/files/1.2-3-dyn_blacklist.patch b/sys-apps/hwsetup/files/1.2-3-dyn_blacklist.patch
deleted file mode 100644
index 7348993d264b..000000000000
--- a/sys-apps/hwsetup/files/1.2-3-dyn_blacklist.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff -urN hwsetup-1.2.orig/hwsetup.c hwsetup-1.2/hwsetup.c
---- hwsetup-1.2.orig/hwsetup.c 2005-05-28 18:11:51.000000000 -0400
-+++ hwsetup-1.2/hwsetup.c 2005-11-17 14:08:03.000000000 -0500
-@@ -43,12 +43,39 @@
- /* Do not, under any circumstances, load these modules automatically, */
- /* even if in pcitable. (libkudzu may ignore this, and the KNOPPIX */
- /* autoconfig scripts may probe them, too) */
--char *blacklist[] =
-+char blacklist[200][200] =
- { "apm","agpgart","yenta_socket","i82092","i82365","tcic",
- "pcmcia_core","ds","ohci1394","hisax",
- /* Winmodems, unusable, can block sound slot */
- "snd-atiixp-modem", "snd-intel8x0m","snd-via82xx-modem"
- };
-+
-+int blacklistsize = 13;
-+void gen_blacklist(){
-+ int n = 13;
-+ int size = 0;
-+ char *comment;
-+ char module[1024];
-+ FILE *stream;
-+
-+ if((stream = fopen ("/etc/hotplug/blacklist", "r")) != (FILE *)0) {
-+ while((fgets(module, 1023, stream)) != (char *)0 ) {
-+
-+ comment = strchr(module, '#');
-+ if (comment != 0) *comment = '\0';
-+ comment = strchr(module, '\n');
-+ if (comment != 0) *comment = '\0';
-+ size = strlen(module);
-+ if (size < 2) continue;
-+ strcat (module , " \0");
-+ strcpy(blacklist[n] , module);
-+ n++;
-+ if ( n == 200 ) break;
-+ //printf(module);
-+ }
-+ blacklistsize = n;
-+ }
-+}
- #endif
-
- /* If a conflicting module in a row is already loaded, the new module will not be probed anymore */
-@@ -412,7 +438,7 @@
- pid_t mpid;
- if((m==NULL)||(!strcmp("unknown",m))||(!strcmp("ignore",m))) return 0;
- #ifdef BLACKLIST
-- for(i=0;i<(sizeof(blacklist)/sizeof(char*));i++)
-+ for(i=0;i < blacklistsize;i++)
- {
- if(!strcmp(blacklist[i],m))
- {
-@@ -638,5 +664,8 @@
- /* Allow SIGTERM, SIGINT: rmmod depends on this. */
- signal(SIGTERM,SIG_DFL); signal(SIGINT,SIG_DFL);
- signal(SIGALRM,alarm_handler); alarm(MAX_TIME);
-+#ifdef BLACKLIST
-+ gen_blacklist();
-+#endif
- return hw_setup(dc,verbose,probeonly,skip);
- }
diff --git a/sys-apps/hwsetup/files/1.2-3-fastprobe.patch b/sys-apps/hwsetup/files/1.2-3-fastprobe.patch
index 0122a6aee8e7..600b8c4002d6 100644
--- a/sys-apps/hwsetup/files/1.2-3-fastprobe.patch
+++ b/sys-apps/hwsetup/files/1.2-3-fastprobe.patch
@@ -1,6 +1,5 @@
-diff -urN hwsetup-1.2.dyn_blacklist/hwsetup.c hwsetup-1.2/hwsetup.c
---- hwsetup-1.2.dyn_blacklist/hwsetup.c 2005-11-17 14:20:14.000000000 -0500
-+++ hwsetup-1.2/hwsetup.c 2005-11-17 14:24:54.000000000 -0500
+--- a/hwsetup.c
++++ b/hwsetup.c
@@ -140,14 +140,15 @@
int syntax(char *option)
diff --git a/sys-apps/hwsetup/files/1.2-3-gentoo.patch b/sys-apps/hwsetup/files/1.2-3-gentoo.patch
deleted file mode 100644
index 2cd8597a2cc9..000000000000
--- a/sys-apps/hwsetup/files/1.2-3-gentoo.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -urN hwsetup-1.2.orig/hwsetup.c hwsetup-1.2/hwsetup.c
---- hwsetup-1.2.orig/hwsetup.c 2005-12-06 08:42:39.000000000 -0500
-+++ hwsetup-1.2/hwsetup.c 2005-12-06 08:42:18.000000000 -0500
-@@ -23,14 +23,15 @@
- #endif
-
- #define VERSION "HWSETUP 1.2, an automatic hardware configuration tool\n" \
-- "(C) 2006 Klaus Knopper <knoppix@knopper.net>\n\n"
-+ "(C) 2006 Klaus Knopper <knoppix@knopper.net>\n" \
-+ "Modified for Gentoo Linux\n\n"
-
- #define CARDSDB "/usr/share/hwdata/Cards"
--#define XPATH "/usr/X11R6/bin/"
--#define XMODPATH "/usr/X11R6/lib/modules/drivers/"
-+#define XPATH "/usr/bin/"
-+#define XMODPATH "/usr/lib/xorg/modules/drivers/"
-
- #define VERBOSE_PRINT 1
--#define VERBOSE_PROMPT 2
-+#define VERBOSE_PROMPT 0
-
- #define SKIP_AUDIO 1
- #define SKIP_SCSI 2
-@@ -255,7 +256,7 @@
- char xmodule[32];
- char fullpath[128];
- sscanf(&buffer[7],"%31s",xmodule);
-- sprintf(fullpath,XMODPATH"%.31s_drv.o",xmodule);
-+ sprintf(fullpath,XMODPATH"%.31s_drv.so",xmodule);
- if(exists(fullpath))
- {
- strncpy(xi.xmodule,xmodule,sizeof(xi.xmodule));
-@@ -517,7 +518,7 @@
- int writeconfig(char *name,struct device *d,int verbose)
- {
- FILE *f,*k;
-- const char *kconfig="/etc/sysconfig/knoppix";
-+ const char *kconfig="/etc/sysconfig/gentoo";
- char *desc;
- unlink(name);
- if((f=fopen(name,"w"))==NULL)
diff --git a/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch b/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch
index 22092d2a1969..efbe0f6abfed 100644
--- a/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch
+++ b/sys-apps/hwsetup/files/1.2-7-dyn_blacklist.patch
@@ -1,6 +1,5 @@
-diff -urN hwsetup-1.2.orig/hwsetup.c hwsetup-1.2/hwsetup.c
---- hwsetup-1.2.orig/hwsetup.c 2008-04-07 18:32:34.000000000 -0700
-+++ hwsetup-1.2/hwsetup.c 2008-04-07 18:49:20.000000000 -0700
+--- a/hwsetup.c
++++ b/hwsetup.c
@@ -51,13 +51,40 @@
/* Do not, under any circumstances, load these modules automatically, */
/* even if in pcitable. (libkudzu may ignore this, and the KNOPPIX */
diff --git a/sys-apps/hwsetup/files/1.2-7-gentoo.patch b/sys-apps/hwsetup/files/1.2-7-gentoo.patch
index cc78e2705c20..e4fc590393fd 100644
--- a/sys-apps/hwsetup/files/1.2-7-gentoo.patch
+++ b/sys-apps/hwsetup/files/1.2-7-gentoo.patch
@@ -1,6 +1,5 @@
-diff -urN hwsetup-1.2.fastprobe/hwsetup.c hwsetup-1.2/hwsetup.c
---- hwsetup-1.2.fastprobe/hwsetup.c 2008-04-07 19:09:08.000000000 -0700
-+++ hwsetup-1.2/hwsetup.c 2008-04-07 19:07:55.000000000 -0700
+--- a/hwsetup.c
++++ b/hwsetup.c
@@ -388,7 +388,7 @@
sprintf(fullpath,"%.90s%.32s",xpath,server[i]);
if(!exists(fullpath)) continue;
diff --git a/sys-apps/hwsetup/files/1.2-7-openchrome.patch b/sys-apps/hwsetup/files/1.2-7-openchrome.patch
index 641c3447aa49..fb80f9dfcb1a 100644
--- a/sys-apps/hwsetup/files/1.2-7-openchrome.patch
+++ b/sys-apps/hwsetup/files/1.2-7-openchrome.patch
@@ -1,5 +1,5 @@
---- a/hwsetup-1.2/hwsetup.c
-+++ b/hwsetup-1.2/hwsetup.c
+--- a/hwsetup.c
++++ b/hwsetup.c
@@ -456,7 +456,7 @@
else if(strcasestr(xi.xdesc,"Newport")) strcpy(xi.xmodule,"newport");
else if(strcasestr(xi.xdesc,"Siliconmotion")||strcasestr(xi.xdesc,"Silicon Motion")) strcpy(xi.xmodule,"siliconmotion");
diff --git a/sys-apps/hwsetup/files/1.2-strip.patch b/sys-apps/hwsetup/files/1.2-strip.patch
index f1b853760096..17de636a5dc7 100644
--- a/sys-apps/hwsetup/files/1.2-strip.patch
+++ b/sys-apps/hwsetup/files/1.2-strip.patch
@@ -1,5 +1,5 @@
---- hwsetup-1.2/Makefile.orig 2005-05-07 15:20:44.000000000 +0200
-+++ hwsetup-1.2/Makefile 2008-12-22 06:27:41.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -3,7 +3,7 @@
# define BLACKLIST to avoid loading potentially dangerous modules
CFLAGS=-DBLACKLIST -Wall -fPIC