summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-20 22:28:09 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-20 22:28:09 +0000
commitc2fa005b19c9fcaecbd565406a4dd09d7dd10392 (patch)
tree2ed659224204cb9b939003fd9b2a89529273c515 /sys-apps/hwsetup
parentAdd modular X dependencies. Also fix up (R)DEPEND so DEPEND inherits from RDE... (diff)
downloadhistorical-c2fa005b19c9fcaecbd565406a4dd09d7dd10392.tar.gz
historical-c2fa005b19c9fcaecbd565406a4dd09d7dd10392.tar.bz2
historical-c2fa005b19c9fcaecbd565406a4dd09d7dd10392.zip
Fix potential buffer overflow in dynamic blacklist support and closing bug #115669.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog8
-rw-r--r--sys-apps/hwsetup/Manifest6
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.0-dyn_blacklist.patch5
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.1-dyn_blacklist.patch5
4 files changed, 16 insertions, 8 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index e729b3bac255..39e62aedc077 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.29 2005/12/07 04:41:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.30 2005/12/20 22:28:09 wolf31o2 Exp $
+
+ 20 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/hwsetup-1.0-dyn_blacklist.patch,
+ files/hwsetup-1.1-dyn_blacklist.patch:
+ Fix potential buffer overflow in dynamic blacklist support and closing bug
+ #115669.
07 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
files/hwsetup-1.1-gentoo.patch, hwsetup-1.0-r3.ebuild, hwsetup-1.1.ebuild:
diff --git a/sys-apps/hwsetup/Manifest b/sys-apps/hwsetup/Manifest
index 4f681b990b2c..1c9f98d942bf 100644
--- a/sys-apps/hwsetup/Manifest
+++ b/sys-apps/hwsetup/Manifest
@@ -1,11 +1,11 @@
-MD5 006d3a1232e5d68a2bd07c7789055654 ChangeLog 4210
+MD5 559d62b35265fe0406b02cad12b55a7d ChangeLog 4435
MD5 70141575b96009e82605b4f86fbe8758 files/digest-hwsetup-1.0-r3 64
MD5 bc002ab4509c7c318c438f86d6005c71 files/digest-hwsetup-1.1 63
MD5 eff6f85f9378f9f180386a7c34deb4c3 files/hwsetup-1.0-alsa.patch 3831
-MD5 1112a5e573dbca81b1cdc54e7901510a files/hwsetup-1.0-dyn_blacklist.patch 1870
+MD5 e7ecca0700ca86b29277e41635517e7b files/hwsetup-1.0-dyn_blacklist.patch 1895
MD5 7f857bf4e30d36be2ac0f59e316dfa66 files/hwsetup-1.0-fastprobe.patch 3715
MD5 5899ca3d018df09b6e2851f3e8c2e294 files/hwsetup-1.0-gentoo.patch 3599
-MD5 331c5c1b01eaee2c066608e8dd1faf71 files/hwsetup-1.1-dyn_blacklist.patch 1949
+MD5 d374ea118a38b12a7372efa0eb41a3ad files/hwsetup-1.1-dyn_blacklist.patch 1978
MD5 a01ba41c868d97350621a124fece8d25 files/hwsetup-1.1-fastprobe.patch 2802
MD5 ad0bc16bdb6e632f71a2768e270c9372 files/hwsetup-1.1-gentoo.patch 4249
MD5 88a71a2a79c9e7ea1e814a75b5a990a1 hwsetup-1.0-r3.ebuild 987
diff --git a/sys-apps/hwsetup/files/hwsetup-1.0-dyn_blacklist.patch b/sys-apps/hwsetup/files/hwsetup-1.0-dyn_blacklist.patch
index 51558524eb37..99981c9d649d 100644
--- a/sys-apps/hwsetup/files/hwsetup-1.0-dyn_blacklist.patch
+++ b/sys-apps/hwsetup/files/hwsetup-1.0-dyn_blacklist.patch
@@ -1,12 +1,12 @@
diff -Naur hwsetup-1.0/hwsetup.c hwsetup-1.0-patched/hwsetup.c
--- hwsetup-1.0/hwsetup.c 2003-06-02 22:01:28.000000000 +0300
+++ hwsetup-1.0-patched/hwsetup.c 2005-05-28 17:07:09.000000000 +0300
-@@ -42,8 +42,35 @@
+@@ -42,8 +42,36 @@
/* Do not, under any circumstances, load these modules automatically, */
/* even if in pcitable. (libkudzu may ignore this, and the KNOPPIX */
/* autoconfig scripts may probe them, too) */
-const char *blacklist[] = { "apm","agpgart","yenta_socket","i82092","i82365","tcic",
-+char blacklist[200][1024] = { "apm","agpgart","yenta_socket","i82092","i82365","tcic",
++char blacklist[200][200] = { "apm","agpgart","yenta_socket","i82092","i82365","tcic",
"pcmcia_core","ds","ohci1394" };
+int blacklistsize = 9;
+
@@ -29,6 +29,7 @@ diff -Naur hwsetup-1.0/hwsetup.c hwsetup-1.0-patched/hwsetup.c
+ strcat (module , " \0");
+ strcpy(blacklist[n] , module);
+ n++;
++ if ( n == 200 ) break;
+ //printf(module);
+ }
+ blacklistsize = n;
diff --git a/sys-apps/hwsetup/files/hwsetup-1.1-dyn_blacklist.patch b/sys-apps/hwsetup/files/hwsetup-1.1-dyn_blacklist.patch
index e97c091a6e8c..90ada1a6c93e 100644
--- a/sys-apps/hwsetup/files/hwsetup-1.1-dyn_blacklist.patch
+++ b/sys-apps/hwsetup/files/hwsetup-1.1-dyn_blacklist.patch
@@ -1,12 +1,12 @@
diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
--- hwsetup-1.1.orig/hwsetup.c 2005-05-28 18:11:51.000000000 -0400
+++ hwsetup-1.1/hwsetup.c 2005-11-17 14:08:03.000000000 -0500
-@@ -43,12 +43,38 @@
+@@ -43,12 +43,39 @@
/* Do not, under any circumstances, load these modules automatically, */
/* even if in pcitable. (libkudzu may ignore this, and the KNOPPIX */
/* autoconfig scripts may probe them, too) */
-const char *blacklist[] =
-+char blacklist[200][1024] =
++char blacklist[200][200] =
{ "apm","agpgart","yenta_socket","i82092","i82365","tcic",
"pcmcia_core","ds","ohci1394","hisax",
/* Winmodems, unusable, can block sound slot */
@@ -33,6 +33,7 @@ diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
+ strcat (module , " \0");
+ strcpy(blacklist[n] , module);
+ n++;
++ if ( n == 200 ) break;
+ //printf(module);
+ }
+ blacklistsize = n;