summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
commitf808d300ce948c5b81cf5c21de2e3a05abd824e1 (patch)
treec8c9643c98312ebe63cbe13ee800be1c3075828f /sys-apps/iproute2
parentfixums (diff)
downloadhistorical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.tar.gz
historical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.tar.bz2
historical-f808d300ce948c5b81cf5c21de2e3a05abd824e1.zip
fixums
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/iproute2-2.4.7.ebuild95
1 files changed, 40 insertions, 55 deletions
diff --git a/sys-apps/iproute2/iproute2-2.4.7.ebuild b/sys-apps/iproute2/iproute2-2.4.7.ebuild
index cade5336cdce..d35e89da66e8 100644
--- a/sys-apps/iproute2/iproute2-2.4.7.ebuild
+++ b/sys-apps/iproute2/iproute2-2.4.7.ebuild
@@ -1,72 +1,57 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7.ebuild,v 1.2 2001/10/01 22:35:24 drobbins Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7.ebuild,v 1.3 2001/10/06 17:13:29 drobbins Exp $
-A=iproute2-2.4.7-now-ss010824.tar.gz
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
-SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${A}"
-
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/iproute2-2.4.7-now-ss010824.tar.gz"
DEPEND="virtual/glibc"
-# if we include tex, it _could_ lead to X being pulled in during emerge system.
-# tex? ( app-text/tetex )"
src_unpack() {
-
- unpack ${A}
-
- # we now install the kernel headers used for compiling glibc, directly into
- # /usr/include/{asm,linux}; which is a good thing(tm). we need to patch
- # iproute2's Makefile to thusly compile without a /usr/src/linux tree.
- # ~woodchip
- cd ${S}
- patch -p0 < ${FILESDIR}/makefile-kernel-includes.diff || die
-
- # omits this protocol support from being built: "__PF(PUP,pup)"
- # the package builds fine without this patch. is there another concern?
- # ~woodchip
- # cd ${S}/lib
- # cp ll_proto.c ll_proto.c.orig
- # sed -e "36 d" ll_proto.c.orig > ll_proto.c
-
- # why was this commented out? were the programs segfaulting/not working?
- # they seem ok here when i compile with optimisations, so im reenabling
- # this patch. if theres problems, will glady change back. ~woodchip
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
-
- # this next thing is required to enable diffserv (ATM support doesn't compile right now)
- # cp Config Config.orig
- # sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
-
+ unpack ${A}
+ # we now install the kernel headers used for compiling glibc, directly into
+ # /usr/include/{asm,linux}; which is a good thing(tm). we need to patch
+ # iproute2's Makefile to thusly compile without a /usr/src/linux tree.
+ # ~woodchip
+ cd ${S}
+ patch -p0 < ${FILESDIR}/makefile-kernel-includes.diff || die
+
+ # omits this protocol support from being built: "__PF(PUP,pup)"
+ # the package builds fine without this patch. is there another concern?
+ # ~woodchip
+ # cd ${S}/lib
+ # cp ll_proto.c ll_proto.c.orig
+ # sed -e "36 d" ll_proto.c.orig > ll_proto.c
+
+ # why was this commented out? were the programs segfaulting/not working?
+ # they seem ok here when i compile with optimisations, so im reenabling
+ # this patch. if theres problems, will glady change back. ~woodchip
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+
+ # this next thing is required to enable diffserv (ATM support doesn't compile right now)
+ # cp Config Config.orig
+ # sed -e 's/DIFFSERV=n/DIFFSERV=y/g' Config.orig > Config
+
#this fix optionally disables the IEEE1394 definition if it is not in the kernel headers
#This allows this pkg to work with earlier 2.4 kernel headers.
cp ${FILESDIR}/ll_types.c ${S}/lib
}
src_compile() {
-
- make ${MAKEOPTS} || die
- # if [ "`use tex`" ] ; then
- # cd doc
- # make || die
- # fi
+ emake || die
}
src_install() {
-
- cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
- cd ${S}/tc ; dosbin tc
-
- cd ${S} ; dodoc README* RELNOTES
- docinto examples/diffserv ; dodoc examples/diffserv/*
- docinto examples ; dodoc examples/*
-
- dodir /etc/iproute2
- insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
-
- if [ "`use tex`" ] ; then
- docinto ps ; dodoc doc/*.ps
- fi
+ cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc ; dosbin tc
+ cd ${S} ; dodoc README* RELNOTES
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+ if [ "`use tex`" ] ; then
+ docinto ps ; dodoc doc/*.ps
+ fi
}