summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-09-13 18:23:56 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-09-13 18:23:56 +0000
commite465d22907461edfa3e8b77ceed5746c44971840 (patch)
treedc0e0b8df6b658c5eecdc1ce0c12176b48cd730f /sys-apps/ivman
parentadd pmount (diff)
downloadhistorical-e465d22907461edfa3e8b77ceed5746c44971840.tar.gz
historical-e465d22907461edfa3e8b77ceed5746c44971840.tar.bz2
historical-e465d22907461edfa3e8b77ceed5746c44971840.zip
Version bump, closes bug 93080 and 105788
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'sys-apps/ivman')
-rw-r--r--sys-apps/ivman/ChangeLog7
-rw-r--r--sys-apps/ivman/Manifest4
-rw-r--r--sys-apps/ivman/files/digest-ivman-0.6.41
-rw-r--r--sys-apps/ivman/ivman-0.6.4.ebuild71
4 files changed, 81 insertions, 2 deletions
diff --git a/sys-apps/ivman/ChangeLog b/sys-apps/ivman/ChangeLog
index 21ed8cf13e71..5fceb28db328 100644
--- a/sys-apps/ivman/ChangeLog
+++ b/sys-apps/ivman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/ivman
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.15 2005/05/08 18:23:13 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ChangeLog,v 1.16 2005/09/13 18:23:56 genstef Exp $
+
+*ivman-0.6.4 (13 Sep 2005)
+
+ 13 Sep 2005; Stefan Schweizer <genstef@gentoo.org> +ivman-0.6.4.ebuild:
+ Version bump, closes bug 93080 and 105788
08 May 2005; Stefan Schweizer <genstef@gentoo.org> ivman-0.5_pre2.ebuild,
ivman-0.5_pre3.ebuild:
diff --git a/sys-apps/ivman/Manifest b/sys-apps/ivman/Manifest
index 3bc8bdf0d3e3..6039e3e32ee1 100644
--- a/sys-apps/ivman/Manifest
+++ b/sys-apps/ivman/Manifest
@@ -1,7 +1,9 @@
MD5 217682a6813a0a28a1a7be4b3b6adc54 ivman-0.5_pre3.ebuild 1310
-MD5 519041e0216a0ec8b8ffcb2d5b31abe2 ChangeLog 2922
+MD5 0ce9d21a6ace26f61cf8256b4fac27bb ChangeLog 3069
+MD5 e08c18044b92b75b5e6d2f8d14791b7e ivman-0.6.4.ebuild 2582
MD5 2bdc162253b44f623a4ae735767bf0f8 ivman-0.5_pre2.ebuild 1309
MD5 94ae54dc83c1b4b61c9edccab725465b metadata.xml 265
MD5 f1e67af6cdf8b51ac4c5cd5e8e7ec298 files/ivman-0.3.init 524
MD5 7b663d58e12a086e30f6eb8e5cf965d3 files/digest-ivman-0.5_pre2 67
MD5 a561344e43c3fcfab148515b471ecd5a files/digest-ivman-0.5_pre3 67
+MD5 4aac9f5d6f83eeda363d051c89933adf files/digest-ivman-0.6.4 64
diff --git a/sys-apps/ivman/files/digest-ivman-0.6.4 b/sys-apps/ivman/files/digest-ivman-0.6.4
new file mode 100644
index 000000000000..b940bf10a8b6
--- /dev/null
+++ b/sys-apps/ivman/files/digest-ivman-0.6.4
@@ -0,0 +1 @@
+MD5 68195ff903c19ba45fba0eda56ccf4df ivman-0.6.4.tar.bz2 242013
diff --git a/sys-apps/ivman/ivman-0.6.4.ebuild b/sys-apps/ivman/ivman-0.6.4.ebuild
new file mode 100644
index 000000000000..e3427c087292
--- /dev/null
+++ b/sys-apps/ivman/ivman-0.6.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ivman/ivman-0.6.4.ebuild,v 1.1 2005/09/13 18:23:56 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon to mount/unmount devices, based on info from HAL"
+HOMEPAGE="http://ivman.sf.net"
+SRC_URI="mirror://sourceforge/ivman/${P}.tar.bz2"
+LICENSE="QPL"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="debug"
+SLOT="0"
+
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/libxml2
+ >=sys-apps/hal-0.4.0
+ >=sys-apps/pmount-0.8"
+# We now require a minimum of glib 2.6.
+# We should be able to build with either HAL 0.4.x or HAL 0.5.x, but HAL 0.5.x
+# is now what I primarily use ( -> Ivman is now better tested with 0.5.x ).
+# I'm not really certain which version of pmount is required, but it's only
+# been tested with >= 0.8 .
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /etc/init.d/
+ newexe ${FILESDIR}/ivman-0.3.init ivman
+
+ # Ivman can now run as a non-root user :-) Create a dedicated user account,
+ # so users can add rules to /etc/sudoers for programs Ivman wants to
+ # execute...
+ # The group here is intended to be the one needed to use pmount, but Ivman
+ # will still work as long as the group in IvmConfigBase.xml is correct.
+ enewuser ivman -1 /bin/false /dev/null plugdev || die "Problem adding ivman user"
+}
+
+pkg_postinst() {
+
+ if has_version "<sys-apps/hal-0.5.0"; then
+ einfo "Ivman was built against HAL 0.4.x. If you later upgrade to HAL 0.5,"
+ einfo "you must re-merge Ivman."
+ echo
+ else
+ einfo "Ivman was built against HAL 0.5.x. If you later downgrade to HAL 0.4,"
+ einfo "you must re-merge Ivman."
+ echo
+ fi
+
+ einfo "Note that, as of version 0.6.0, the IvmConfigMappings.xml configuration"
+ einfo "file is no longer required to correctly mount fstab entries which"
+ einfo "use symbolic links. You may safely remove this file if desired."
+ einfo "However, HAL typically does not correctly deal with fstab"
+ einfo "entries of this nature, therefore it is strongly recommanded that"
+ einfo "you have real device names (i.e. not symlinks) in /etc/fstab."
+ echo
+
+ einfo "By default, Ivman will mount any removable disks as they are"
+ einfo "attached. If you want Ivman to do more, such as hibernating"
+ einfo "your laptop when the lid is closed or when the battery is low,"
+ einfo "look at the configuration files in /etc/ivman/ ."
+}