summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2003-04-11 06:06:38 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2003-04-11 06:06:38 +0000
commit69ef97693996f5e6d7d4d6670e327f56ba384ab4 (patch)
tree542f54b512ad1c3c6fa93181ea06e70a3124b27c /sys-apps/logwatch
parentMoving back to protector-4 (diff)
downloadhistorical-69ef97693996f5e6d7d4d6670e327f56ba384ab4.tar.gz
historical-69ef97693996f5e6d7d4d6670e327f56ba384ab4.tar.bz2
historical-69ef97693996f5e6d7d4d6670e327f56ba384ab4.zip
Update to 4.3.2 and squashed 4 bugs (13303 16016 16576 17746)
Diffstat (limited to 'sys-apps/logwatch')
-rw-r--r--sys-apps/logwatch/ChangeLog13
-rw-r--r--sys-apps/logwatch/files/digest-logwatch-4.3.21
-rw-r--r--sys-apps/logwatch/logwatch-4.3.2.ebuild74
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-apps/logwatch/ChangeLog b/sys-apps/logwatch/ChangeLog
index 0a8d02b86705..a95860d0beca 100644
--- a/sys-apps/logwatch/ChangeLog
+++ b/sys-apps/logwatch/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-apps/logwatch
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.5 2003/03/31 02:47:50 jhhudso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/ChangeLog,v 1.6 2003/04/11 06:06:38 jhhudso Exp $
+
+*logwatch-4.3.2 (11 Apr 2003)
+
+ 11 Apr 2003; Jared Hudson <jhhudso@gentoo.org> : IMPORTANT NOTICE: I have
+ changed the location of logwatch and its configuration files and scripts.
+ logwatch.pl is now in /usr/sbin/logwatch.pl, the configuration files
+ and scripts are in /etc/log.d This will match the way the author intended
+ logwatch to be enabled while also allowing the configuration files to be
+ monitored for changed and subject to etc-update when logwatch is upgraded.
+ Credit goes to the following people: Alessandro Pisani <alextxm@tin.it>
+ and Georgi Georgiev <chutz@chubaka.net> Bugs fixed: 13303 16016 16576 17746
30 Mar 2003; Jared Hudson <jhhudso@gentoo.org> : Provider archived this
version of the tarball, so I changed our location in the ebuild.
diff --git a/sys-apps/logwatch/files/digest-logwatch-4.3.2 b/sys-apps/logwatch/files/digest-logwatch-4.3.2
new file mode 100644
index 000000000000..f758bd3db0ac
--- /dev/null
+++ b/sys-apps/logwatch/files/digest-logwatch-4.3.2
@@ -0,0 +1 @@
+MD5 fdd2edb48c17f52ace9e2b00a3ac17f9 logwatch-4.3.2.tar.gz 57546
diff --git a/sys-apps/logwatch/logwatch-4.3.2.ebuild b/sys-apps/logwatch/logwatch-4.3.2.ebuild
new file mode 100644
index 000000000000..d5816b09916c
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-4.3.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/logwatch/logwatch-4.3.2.ebuild,v 1.1 2003/04/11 06:06:38 jhhudso Exp $
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org"
+SRC_URI="ftp://ftp.kaybee.org/pub/linux/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ virtual/cron
+ virtual/mta
+ dev-lang/perl
+ net-mail/mailx"
+RDEPEND=""
+
+src_install() {
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/scripts/shared
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ for i in scripts/logfiles/* ; do
+ if [ $(ls $i | wc -l) -ne 0 ] ; then
+ exeinto /etc/log.d/$i
+ doexe $i/*
+ fi
+ done
+
+ exeinto /etc/log.d/scripts/services
+ doexe scripts/services/*
+
+ exeinto /etc/log.d/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /etc/log.d/conf
+ doins conf/logwatch.conf
+
+ insinto /etc/log.d/conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /etc/log.d/conf/services
+ doins conf/services/*
+
+ doman logwatch.8
+ dodoc License project/CHANGES project/TODO README HOWTO-Make-Filter
+}
+
+pkg_postinst() {
+ # this will avoid duplicate entries in the crontab
+ if [ "`grep logwatch.pl ${ROOT}var/spool/cron/crontabs/root`" == "" ];
+ then
+ einfo "adding to cron..."
+ echo "0 0 * * * ${ROOT}usr/sbin/logwatch.pl 2>&1 > /dev/null" \
+ >> ${ROOT}var/spool/cron/crontabs/root
+ fi
+}
+
+pkg_postrm() {
+ # this fixes a bug when logwatch package gets updated
+ if [ "`ls -d ${ROOT}var/db/pkg/sys-apps/logwatch* \
+ | wc -l | tail -c 2`" -lt 2 ];
+ then
+ sed "/^0.*\/usr\/sbin\/logwatch.*null$/d" \
+ ${ROOT}var/spool/cron/crontabs/root \
+ > ${ROOT}var/spool/cron/crontabs/root.new
+ mv --force ${ROOT}var/spool/cron/crontabs/root.new \
+ ${ROOT}var/spool/cron/crontabs/root
+ fi
+}