summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-15 04:55:11 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-15 04:55:11 +0000
commit647dcb4a70970680a36363610162b3c0644283cf (patch)
treed09cacb453d958b9f2f88100d194c9c6acd7df2a /sys-apps/memtest86/files
parentSign Manifest (diff)
downloadhistorical-647dcb4a70970680a36363610162b3c0644283cf.tar.gz
historical-647dcb4a70970680a36363610162b3c0644283cf.tar.bz2
historical-647dcb4a70970680a36363610162b3c0644283cf.zip
Version bump.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux i686
Diffstat (limited to 'sys-apps/memtest86/files')
-rw-r--r--sys-apps/memtest86/files/memtest86-3.5-build.patch5
-rw-r--r--sys-apps/memtest86/files/memtest86-4.0-build.patch41
2 files changed, 43 insertions, 3 deletions
diff --git a/sys-apps/memtest86/files/memtest86-3.5-build.patch b/sys-apps/memtest86/files/memtest86-3.5-build.patch
index 6c47cddb180d..04f45bffa5eb 100644
--- a/sys-apps/memtest86/files/memtest86-3.5-build.patch
+++ b/sys-apps/memtest86/files/memtest86-3.5-build.patch
@@ -1,8 +1,7 @@
make sure all the flags in question force i386 and disable SSP
-diff -Nuar --exclude '*.orig' memtest86-3.5.orig//Makefile memtest86-3.5//Makefile
---- memtest86-3.5.orig//Makefile 2010-03-31 19:43:35.355817421 +0000
-+++ memtest86-3.5//Makefile 2010-03-31 19:47:10.922462467 +0000
+--- a/Makefile
++++ b/Makefile
@@ -8,10 +8,9 @@
#
FDISK=/dev/fd0
diff --git a/sys-apps/memtest86/files/memtest86-4.0-build.patch b/sys-apps/memtest86/files/memtest86-4.0-build.patch
new file mode 100644
index 000000000000..6e2fe6a4d428
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.0-build.patch
@@ -0,0 +1,41 @@
+--- Makefile.org 2011-03-30 16:58:52.000000000 +0200
++++ Makefile 2011-06-15 06:52:44.000000000 +0200
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,7 +48,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
+@@ -72,3 +70,6 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s