summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-28 11:01:23 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-28 11:01:23 +0000
commit70329e85ec9bb60414a92712381e40581f0aee11 (patch)
treef66e7dc315b25db09d2a1bd7a900d07a34ad1bcf /sys-apps/memtest86/files
parentCompile memtest86+ with -O1 instead of -Os (bug #217324). (diff)
downloadhistorical-70329e85ec9bb60414a92712381e40581f0aee11.tar.gz
historical-70329e85ec9bb60414a92712381e40581f0aee11.tar.bz2
historical-70329e85ec9bb60414a92712381e40581f0aee11.zip
Compile memtest86 with -O1 instead of -Os (bug #217324).
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.27-rc6 x86_64
Diffstat (limited to 'sys-apps/memtest86/files')
-rw-r--r--sys-apps/memtest86/files/memtest86-3.4-build.patch13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-apps/memtest86/files/memtest86-3.4-build.patch b/sys-apps/memtest86/files/memtest86-3.4-build.patch
index a530f89016b7..fc94be085fdd 100644
--- a/sys-apps/memtest86/files/memtest86-3.4-build.patch
+++ b/sys-apps/memtest86/files/memtest86-3.4-build.patch
@@ -1,10 +1,13 @@
---- Makefile
-+++ Makefile
-@@ -11,7 +11,10 @@
+diff -Naurp memtest86-3.4-orig/Makefile memtest86-3.4/Makefile
+--- memtest86-3.4-orig/Makefile 2008-09-28 12:56:45.000000000 +0200
++++ memtest86-3.4/Makefile 2008-09-28 12:57:35.000000000 +0200
+@@ -10,8 +10,11 @@ FDISK=/dev/fd0
+
CC=gcc
- CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin \
+-CFLAGS=-Wall -march=i486 -m32 -Os -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC
++CFLAGS=-Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+ -ffreestanding -fPIC -fno-stack-protector
+AS=$(CC) -c
+ASFLAGS=-m32
@@ -12,7 +15,7 @@
OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
config.o linuxbios.o memsize.o pci.o controller.o random.o extra.o \
-@@ -41,8 +42,7 @@
+@@ -41,8 +44,7 @@ reloc.o: reloc.c
$(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
test.o: test.c