summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-07-23 22:13:52 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-07-23 22:13:52 +0000
commitbd59902073f187bacc9c1aaf7b848836f761386f (patch)
tree2cd94d354efd912d526775950ac669d8fb0ea9d5 /sys-apps/mindi
parentMasked net-snmp-5.0.2a for testing. (diff)
downloadhistorical-bd59902073f187bacc9c1aaf7b848836f761386f.tar.gz
historical-bd59902073f187bacc9c1aaf7b848836f761386f.tar.bz2
historical-bd59902073f187bacc9c1aaf7b848836f761386f.zip
new package
Diffstat (limited to 'sys-apps/mindi')
-rw-r--r--sys-apps/mindi/ChangeLog9
-rw-r--r--sys-apps/mindi/files/digest-mindi-0.651
-rw-r--r--sys-apps/mindi/files/mindi-0.65.patch19
-rw-r--r--sys-apps/mindi/mindi-0.65.ebuild36
4 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/mindi/ChangeLog b/sys-apps/mindi/ChangeLog
new file mode 100644
index 000000000000..d87bd469193c
--- /dev/null
+++ b/sys-apps/mindi/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-apps/mindi
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mindi/ChangeLog,v 1.1 2002/07/23 22:09:52 lostlogic Exp $
+
+*mindi-0.65 (23 Jul 2002)
+
+ 23 Jul 2002; Brandon Low <lostlogic@gentoo.org> mindi-0.65.ebuild files/mindi-0.65.patch:
+
+ Thanks to Andreas Kotowicz <koto@mynetix.de> for this initial ebuild.
diff --git a/sys-apps/mindi/files/digest-mindi-0.65 b/sys-apps/mindi/files/digest-mindi-0.65
new file mode 100644
index 000000000000..313b22a1063d
--- /dev/null
+++ b/sys-apps/mindi/files/digest-mindi-0.65
@@ -0,0 +1 @@
+MD5 407b98431fdf86371761e2c1b2f9e3c9 mindi-0.65.tgz 3594781
diff --git a/sys-apps/mindi/files/mindi-0.65.patch b/sys-apps/mindi/files/mindi-0.65.patch
new file mode 100644
index 000000000000..d47f6b8b9df9
--- /dev/null
+++ b/sys-apps/mindi/files/mindi-0.65.patch
@@ -0,0 +1,19 @@
+*** mindi Thu Jul 18 20:16:18 2002
+--- mindi~ Thu Jul 18 20:17:42 2002
+***************
+*** 781,787 ****
+ output="$location $output"
+ copies_found=$(($copies_found+1))
+ if [ -h "$location" ] ; then
+! resolved=`ls -l $location |tr -s ' ' '\t' | cut -f11`
+ if [ "`echo "$resolved" | grep "/"`" = "" ] ; then
+ stub=`echo "$location" | $AWK -F '/' '{ for(i=1;i<NF;i++) {printf("/%s",$i);};};'`
+ output="/$stub/$resolved $output"
+--- 781,787 ----
+ output="$location $output"
+ copies_found=$(($copies_found+1))
+ if [ -h "$location" ] ; then
+! resolved=`ls -l $location |tr -s ' ' '\t' | $AWK '{printf $NF;}'`
+ if [ "`echo "$resolved" | grep "/"`" = "" ] ; then
+ stub=`echo "$location" | $AWK -F '/' '{ for(i=1;i<NF;i++) {printf("/%s",$i);};};'`
+ output="/$stub/$resolved $output"
diff --git a/sys-apps/mindi/mindi-0.65.ebuild b/sys-apps/mindi/mindi-0.65.ebuild
new file mode 100644
index 000000000000..4261cf01c797
--- /dev/null
+++ b/sys-apps/mindi/mindi-0.65.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mindi/mindi-0.65.ebuild,v 1.1 2002/07/23 22:09:52 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Mindi builds boot/root disk images using your existing kernel, modules, tools and libraries"
+HOMEPAGE="http://www.microwerks.net/~hugo/mindi/"
+SRC_URI="http://www.microwerks.net/~hugo/kp/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/bzip2-1.0.1
+ >=app-cdr/cdrtools-1.11
+ >=sys-libs/ncurses-5
+ >=sys-devel/binutils-2
+ >=sys-apps/syslinux-1.7
+ >=sys-apps/lilo-22
+ >=app-admin/dosfstools-2.8"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}.patch || die "patching failed"
+}
+
+src_install() {
+ dodir /usr/share/mindi
+ dodir /usr/sbin
+ cp * --parents -rdf ${D}/usr/share/mindi/
+ dosym /usr/share/mindi/mindi /usr/sbin/
+ dosym /usr/share/mindi/analyze-my-lvm /usr/sbin
+}