summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-03-22 08:33:20 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-03-22 08:33:20 +0000
commit6a8ba0a97197da5c8d5d8c7a6ed7fe10653dbc54 (patch)
tree1069539c00b496a591a796d53df938c03500209c /sys-apps/pcsc-lite
parentManifest fix (diff)
downloadhistorical-6a8ba0a97197da5c8d5d8c7a6ed7fe10653dbc54.tar.gz
historical-6a8ba0a97197da5c8d5d8c7a6ed7fe10653dbc54.tar.bz2
historical-6a8ba0a97197da5c8d5d8c7a6ed7fe10653dbc54.zip
Version bump - 1.2.0. Thanks to Cicero (Robert Thomas) <rwt@cc.gatech.edu> bug #45166 for pointing it out
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog11
-rw-r--r--sys-apps/pcsc-lite/files/digest-pcsc-lite-1.2.01
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild4
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.2.0.ebuild48
4 files changed, 60 insertions, 4 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index 2322ab6c1711..d2dc3be6c74d 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pcsc-lite
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.5 2003/08/03 04:38:59 iggy Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.6 2004/03/22 08:33:20 dragonheart Exp $
+
+*pcsc-lite-1.2.0 (22 Mar 2004)
+
+ 22 Mar 2004; Daniel Black <dragonheart@gentoo.org> pcsc-lite-1.1.1.ebuild,
+ pcsc-lite-1.2.0.ebuild:
+ Version bump - 1.2.0. Thanks to Cicero (Robert Thomas) <rwt@cc.gatech.edu> bug
+ #45166 for pointing it out
02 Aug 2003; <iggy@gentoo.org> pcsc-lite-1.1.1.ebuild, files/pcscd-init:
Gentoo style init script fixes bug # 15524 thanks to Alberto Ornaghi <alor@antifork.org>
diff --git a/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.2.0 b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.2.0
new file mode 100644
index 000000000000..8d01138d9f1b
--- /dev/null
+++ b/sys-apps/pcsc-lite/files/digest-pcsc-lite-1.2.0
@@ -0,0 +1 @@
+MD5 98456d274b2f4bfe74c5ab59070f8d50 pcsc-lite-1.2.0.tar.gz 790384
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild
index ee6f31c737b9..9d2056beba2a 100644
--- a/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild,v 1.6 2003/09/07 03:00:30 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.1.1.ebuild,v 1.7 2004/03/22 08:33:20 dragonheart Exp $
inherit eutils
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.2.0.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.2.0.ebuild
new file mode 100644
index 000000000000..c9bca31b8da7
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.2.0.ebuild,v 1.1 2004/03/22 08:33:20 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="https://alioth.debian.org/download.php/419/pcsc-lite-${PV}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="static"
+
+RDEPEND="!static? ( virtual/glibc )
+ !static? ( dev-libs/libusb )"
+
+DEPEND="sys-devel/make
+ sys-devel/libtool
+ sys-apps/sed
+ sys-devel/flex
+ sys-apps/gawk
+ dev-libs/libusb
+ dev-util/pkgconfig
+ sys-devel/gcc
+ ${RDEPEND}"
+
+src_compile() {
+ econf \
+ --enable-usbdropdir=/usr/share/pcsc/drivers \
+ --enable-muscledropdir=/usr/share/pcsc/services \
+ `use_enable static` || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+ docinto sample
+ dodoc src/utils/README src/utils/sample.*
+ rm -rf ${D}/usr/doc
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcscd-init pcscd
+}