summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:36:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:36:50 +0000
commit8a14644021a2dbca117f48256d02be176d1062a7 (patch)
treed862820840f3c760fce28ac34a21bb462ef2dd88 /sys-apps/supervise-scripts
parentrepoman (diff)
downloadhistorical-8a14644021a2dbca117f48256d02be176d1062a7.tar.gz
historical-8a14644021a2dbca117f48256d02be176d1062a7.tar.bz2
historical-8a14644021a2dbca117f48256d02be176d1062a7.zip
repoman
Diffstat (limited to 'sys-apps/supervise-scripts')
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild21
-rw-r--r--sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild22
2 files changed, 22 insertions, 21 deletions
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
index 877f163a8b7d..901998e68873 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.10 2003/06/21 21:19:41 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.4.ebuild,v 1.11 2003/09/10 05:36:49 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Starting and stopping daemontools managed services."
-SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
-KEYWORDS="x86 amd64 ppc sparc "
-SLOT="0"
+SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
+
LICENSE="GPL-2"
-RDEPENDS=">=sys-apps/daemontools-0.70"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc sparc"
+
+RDEPEND=">=sys-apps/daemontools-0.70"
src_compile() {
emake || die
}
src_install() {
- exeinto /usr/bin
- doexe svc-add svc-isdown svc-isup svc-remove \
- svc-start svc-status svc-stop \
- svc-waitdown svc-waitup svscan-add-to-inittab
+ dobin \
+ svc-add svc-isdown svc-isup svc-remove \
+ svc-start svc-status svc-stop \
+ svc-waitdown svc-waitup svscan-add-to-inittab
}
diff --git a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
index 720e02e3d30b..2db022ac2585 100644
--- a/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
+++ b/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.1 2003/08/28 20:12:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/supervise-scripts/supervise-scripts-3.5.ebuild,v 1.2 2003/09/10 05:36:50 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Starting and stopping daemontools managed services."
-SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
HOMEPAGE="http://untroubled.org/supervise-scripts/"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~hppa ~alpha ~mips "
-SLOT="0"
+SRC_URI="http://untroubled.org/supervise-scripts/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~arm ~hppa ~alpha ~mips "
+
RDEPEND=">=sys-apps/daemontools-0.70"
DEPEND=">=sys-apps/daemontools-0.70
dev-libs/bglibs
@@ -23,12 +24,11 @@ src_compile() {
}
src_install() {
- into /usr
- exeinto /usr/bin
- doexe svc-add svc-isdown svc-isup svc-remove \
- svc-start svc-status svc-stop svc-restart \
- svc-waitdown svc-waitup svscan-add-to-inittab \
- svscan-add-to-inittab svscan-start svscan-stopall
+ dobin \
+ svc-add svc-isdown svc-isup svc-remove \
+ svc-start svc-status svc-stop svc-restart \
+ svc-waitdown svc-waitup svscan-add-to-inittab \
+ svscan-add-to-inittab svscan-start svscan-stopall
dodoc ANNOUNCEMENT COPYING ChangeLog NEWS README TODO VERSION
doman *.[0-9]
}