summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-03-03 22:19:37 +0000
committerMike Gilbert <floppym@gentoo.org>2014-03-03 22:19:37 +0000
commit6cf2e8aab7100fb718d4a19673e4dc2b440861f1 (patch)
treec6e7e6c7724b90adcfa22ebf5f82be7e0b1727c6 /sys-apps/systemd/systemd-9999.ebuild
parentStable for AMD64 x86 too. (diff)
downloadhistorical-6cf2e8aab7100fb718d4a19673e4dc2b440861f1.tar.gz
historical-6cf2e8aab7100fb718d4a19673e4dc2b440861f1.tar.bz2
historical-6cf2e8aab7100fb718d4a19673e4dc2b440861f1.zip
Pass --with-rootprefix if the ROOTPREFIX envvar is set. This should be considered experimental and is a convenience for developers only.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'sys-apps/systemd/systemd-9999.ebuild')
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 73529c356f09..b84df853aa66 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.99 2014/03/02 16:51:29 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.100 2014/03/03 22:19:31 floppym Exp $
EAPI=5
@@ -221,6 +221,14 @@ multilib_src_configure() {
)
fi
+ # Added for testing; this is UNSUPPORTED by the Gentoo systemd team!
+ if [[ -n ${ROOTPREFIX+set} ]]; then
+ myeconfargs+=(
+ --with-rootprefix="${ROOTPREFIX}"
+ --with-rootlibdir="${ROOTPREFIX}/$(get_libdir)"
+ )
+ fi
+
if ! multilib_is_native_abi; then
myeconfargs+=(
ac_cv_search_cap_init=