summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNate Underwood <natey@gentoo.org>2003-04-30 18:37:42 +0000
committerNate Underwood <natey@gentoo.org>2003-04-30 18:37:42 +0000
commit6370c208f8bd421f5cf31ee8d98e18df2288fe44 (patch)
tree52d6074e219239c7d1ea8eb16f610ec9529c3142 /sys-apps/systrace/systrace-1.0-r2.ebuild
parentManifest update (diff)
downloadhistorical-6370c208f8bd421f5cf31ee8d98e18df2288fe44.tar.gz
historical-6370c208f8bd421f5cf31ee8d98e18df2288fe44.tar.bz2
historical-6370c208f8bd421f5cf31ee8d98e18df2288fe44.zip
Bump for new systrace userland sources
Diffstat (limited to 'sys-apps/systrace/systrace-1.0-r2.ebuild')
-rw-r--r--sys-apps/systrace/systrace-1.0-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/systrace/systrace-1.0-r2.ebuild b/sys-apps/systrace/systrace-1.0-r2.ebuild
new file mode 100644
index 000000000000..f75ddd223aa3
--- /dev/null
+++ b/sys-apps/systrace/systrace-1.0-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+
+DESCRIPTION="Systrace userland binary"
+HOMEPAGE="http://www.systrace.org"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-04-27.tar.gz
+ http://natey.com/gentoo/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
+SLOT="0"
+LICENSE="GPL-2"
+PATCH1="systrace.c-no_x11-1.0.patch"
+INCLUDE0="/usr/src/linux/include/linux/systrace.h"
+INCLUDE1="/usr/include/linux/systrace.h"
+S="${WORKDIR}/${P}"
+
+KEYWORDS="~x86"
+IUSE="gtk"
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
+
+pkg_setup() {
+ if ! [ -f ${INCLUDE0} ] || ! [ -f ${INCLUDE1} ] ;
+ then
+ einfo
+ einfo "ERROR: It does not look like you have a systrace capable kernel. If"
+ einfo "this is incorrect, please copy /usr/src/linux/include/linux/systrace.h"
+ einfo "to /usr/include/linux/ and restart the build."
+ einfo
+ einfo "The latest systrace Linux kernel patches can be found at:"
+ einfo
+ einfo "http://www.citi.umich.edu/u/provos/systrace/linux.html"
+ einfo
+ exit 1
+ fi
+}
+
+src_compile() {
+ if [ "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace with gtk support; this version will not"
+ einfo "function without the sys-apps/gtk-systrace package installed. Please"
+ einfo "set the USE=\"-gtk\" to build the non-gui capable version of systrace."
+ einfo
+ sleep 7
+ ./configure --host=${CHOST} || die
+ elif [ -z "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace without gtk support; please set USE=\"gtk\""
+ einfo "to build the gui capable version of systrace."
+ einfo
+ sleep 7
+ cd ${S}
+ epatch ../${PATCH1} || die
+ ./configure --host=${CHOST} || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ dobin systrace
+ exeinto /usr/bin
+
+ doman systrace.1
+}