summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-09 18:57:56 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-09 18:57:56 +0000
commit294aa172cd8cc38e7abbad594281d40c237003ad (patch)
treeb7fb64d1858c64615b117bc48c578851e599f90a /sys-apps/sysvinit
parentBump to -r3 to fix building of sulogin in catalyst stages (diff)
downloadhistorical-294aa172cd8cc38e7abbad594281d40c237003ad.tar.gz
historical-294aa172cd8cc38e7abbad594281d40c237003ad.tar.bz2
historical-294aa172cd8cc38e7abbad594281d40c237003ad.zip
Build sulogin in any case, since it's always possible to link against /lib/libcrypt.so even when the static lib is unavailable
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/ChangeLog8
-rw-r--r--sys-apps/sysvinit/files/digest-sysvinit-2.85-r11
-rw-r--r--sys-apps/sysvinit/sysvinit-2.85-r1.ebuild71
3 files changed, 79 insertions, 1 deletions
diff --git a/sys-apps/sysvinit/ChangeLog b/sys-apps/sysvinit/ChangeLog
index b6ff7dbbdfe0..d16e20672bf9 100644
--- a/sys-apps/sysvinit/ChangeLog
+++ b/sys-apps/sysvinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sysvinit
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.11 2004/07/02 19:54:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.12 2004/07/09 18:57:56 agriffis Exp $
+
+*sysvinit-2.85-r1 (09 Jul 2004)
+
+ 09 Jul 2004; Aron Griffis <agriffis@gentoo.org> +sysvinit-2.85-r1.ebuild:
+ Build sulogin in any case, since it's always possible to link against
+ /lib/libcrypt.so even when the static lib is unavailable
02 Jul 2004; Aron Griffis <agriffis@gentoo.org> sysvinit-2.84.ebuild,
sysvinit-2.85.ebuild:
diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.85-r1 b/sys-apps/sysvinit/files/digest-sysvinit-2.85-r1
new file mode 100644
index 000000000000..e60573a3c576
--- /dev/null
+++ b/sys-apps/sysvinit/files/digest-sysvinit-2.85-r1
@@ -0,0 +1 @@
+MD5 8a2d8f1ed5a2909da04132fefa44905e sysvinit-2.85.tar.gz 92758
diff --git a/sys-apps/sysvinit/sysvinit-2.85-r1.ebuild b/sys-apps/sysvinit/sysvinit-2.85-r1.ebuild
new file mode 100644
index 000000000000..eed1803e9072
--- /dev/null
+++ b/sys-apps/sysvinit/sysvinit-2.85-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.85-r1.ebuild,v 1.1 2004/07/09 18:57:56 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="/sbin/init - parent of all processes"
+HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
+SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
+ ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="selinux build"
+
+DEPEND="virtual/os-headers
+ selinux? ( >=sys-libs/libselinux-1.14 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src || die
+
+ # SELinux patch
+ use selinux && epatch ${FILESDIR}/sysvinit-${PV}-selinux.patch
+}
+
+src_compile() {
+ # Note: The LCRYPT define below overrides the test in
+ # sysvinit's Makefile. This is because sulogin must be linked
+ # to libcrypt in any case, but when building stage2 in
+ # catalyst, /usr/lib/libcrypt.a isn't available. In truth
+ # this doesn't change how sulogin is built since ld would use
+ # the shared obj by default anyway! The other option is to
+ # refrain from building sulogin, but that isn't a good option.
+ # (09 Jul 2004 agriffis)
+ emake -C ${S}/src CC="${CC:-gcc}" LD="${CC:-gcc}" \
+ LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} -D_GNU_SOURCE" \
+ LCRYPT="-lcrypt" || die
+}
+
+src_install() {
+ cd ${S}/src
+ into /
+ dosbin init halt killall5 runlevel shutdown sulogin
+ dosym init /sbin/telinit
+ dobin last mesg utmpdump wall
+ dosym killall5 /sbin/pidof
+ dosym halt /sbin/reboot
+ dosym halt /sbin/poweroff
+ dosym last /bin/lastb
+ insinto /usr/include
+ doins initreq.h
+
+ # sysvinit docs
+ cd ${S}
+ doman man/*.[1-9]
+ dodoc COPYRIGHT README doc/*
+
+ # install our inittab
+ insinto /etc
+ doins ${FILESDIR}/inittab || die
+
+ # Add serial console for arches that typically have it
+ case ${ARCH} in
+ sparc|mips|hppa|alpha|ia64)
+ sed -i -e \
+ 's"# TERMINALS"# SERIAL CONSOLE\nc0:12345:respawn:/sbin/agetty 9600 ttyS0 vt100\n\n&"' \
+ ${D}/etc/inittab || die
+ ;;
+ esac
+}