summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-01-02 06:04:29 +0000
committerMatthew Turk <satai@gentoo.org>2003-01-02 06:04:29 +0000
commit54503e73454e8e2cba4897830131d1869bc232d1 (patch)
tree5f9e2497c227ed9fc4da3dcdf983eca356c0ae88 /sys-apps/texinfo
parentCloses 12312. Version bump, fixed opts. (diff)
downloadhistorical-54503e73454e8e2cba4897830131d1869bc232d1.tar.gz
historical-54503e73454e8e2cba4897830131d1869bc232d1.tar.bz2
historical-54503e73454e8e2cba4897830131d1869bc232d1.zip
Closes 11047, a huge problem with generating info files. Thanks to Ingo
Krabbe.
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog12
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.3-r11
-rw-r--r--sys-apps/texinfo/texinfo-4.3-r1.ebuild73
3 files changed, 79 insertions, 7 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index 8951b4a35741..5ddaeda8aeeb 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,14 +1,12 @@
# ChangeLog for sys-apps/texinfo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.14 2002/12/09 22:30:05 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.15 2003/01/02 06:04:29 satai Exp $
- 10 Dec 2002; Martin Schlemmer <azarah@gentoo.org> texinfo-4.3.ebuild :
+*texinfo-4.3-r1 (21 Nov 2002)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
- Changed sparc ~sparc keywords
-
- 27 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
- Update SRC_URI to fix bug #11297.
+ 20 Nov 2002; Ingo Krabbe <ikrabbe@dokom.net> :
+ apply localization bugfix for install-info.
+ committed by satai@gentoo.org.
*texinfo-4.3 (18 Nov 2002)
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.3-r1 b/sys-apps/texinfo/files/digest-texinfo-4.3-r1
new file mode 100644
index 000000000000..85de720f7c72
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.3-r1
@@ -0,0 +1 @@
+MD5 9a8f8ef8b7f8323bb985ab12fcdb2f0b texinfo-4.3.tar.gz 1808898
diff --git a/sys-apps/texinfo/texinfo-4.3-r1.ebuild b/sys-apps/texinfo/texinfo-4.3-r1.ebuild
new file mode 100644
index 000000000000..17fcc7b92544
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.3-r1.ebuild,v 1.1 2003/01/02 06:04:29 satai Exp $
+
+IUSE="nls build"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU info program and utilities"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/texinfo/${P}.tar.gz
+ ftp://alpha.gnu.org/pub/gnu/texinfo/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+RDEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/doc
+ # Get the texinfo info page to have a proper name of texinfo.info
+ cp texinfo.txi texinfo.txi.orig
+ sed -e 's:setfilename texinfo:setfilename texinfo.info:' \
+ texinfo.txi.orig > texinfo.txi
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:INFO_DEPS = texinfo:INFO_DEPS = texinfo.info:' \
+ -e 's:texinfo\::texinfo.info\::' \
+ Makefile.in.orig > Makefile.in
+ cd ${S}/util
+ patch -p0 < ${FILESDIR}/install-info.patch
+}
+
+src_compile() {
+ local myconf=""
+ if [ -z "`use nls`" ] || [ -n "`use build`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ export WANT_AUTOMAKE_1_6=1
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ if [ "`use build`" ] ; then
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ make DESTDIR=${D} \
+ infodir=/usr/share/info \
+ install || die
+
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ if [ ! -f ${D}/usr/share/info/texinfo.info ] ; then
+ die "Could not install texinfo.info!!!"
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}
+