summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-16 18:03:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-16 18:03:51 +0000
commit0a2fda922e17ff09f3bfde0a45e73781dfdbaea7 (patch)
treef814c5d07f10d9400cd7f18968fe3a97d3a42aa7 /sys-apps/util-linux
parentadd apache2 desc (diff)
downloadhistorical-0a2fda922e17ff09f3bfde0a45e73781dfdbaea7.tar.gz
historical-0a2fda922e17ff09f3bfde0a45e73781dfdbaea7.tar.bz2
historical-0a2fda922e17ff09f3bfde0a45e73781dfdbaea7.zip
fix rare failures with parallel makes
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog5
-rw-r--r--sys-apps/util-linux/files/util-linux-2.11y-parallel-make.patch11
-rw-r--r--sys-apps/util-linux/util-linux-2.11y.ebuild13
3 files changed, 24 insertions, 5 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index aa7304903036..9edac1b4e3e3 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/util-linux
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.18 2002/12/13 17:24:58 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.19 2002/12/16 18:03:51 azarah Exp $
+
+ 16 Dec 2002; Martin Schlemmer <azarah@gentoo.org> util-linux-2.11y.ebuild :
+ Fix rare failures with parallel makes. Update to use epatch.
10 Dec 2002; Martin Schlemmer <azarah@gentoo.org> util-linux-2.11y.ebuild :
Mark stable.
diff --git a/sys-apps/util-linux/files/util-linux-2.11y-parallel-make.patch b/sys-apps/util-linux/files/util-linux-2.11y-parallel-make.patch
new file mode 100644
index 000000000000..65c5166ebee2
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.11y-parallel-make.patch
@@ -0,0 +1,11 @@
+--- util-linux-2.11y/mount/Makefile.orig 2002-12-16 17:46:29.000000000 +0000
++++ util-linux-2.11y/mount/Makefile 2002-12-16 17:46:59.000000000 +0000
+@@ -78,7 +78,7 @@
+
+ sundries.o nfsmount.o nfsmount_xdr.o nfsmount_clnt.o: nfsmount.h
+
+-umount.o: mount_constants.h
++umount.o: mount_constants.h nfsmount.h
+
+ mount.o mount_by_label.o mount_guess_fstype.o: linux_fs.h
+
diff --git a/sys-apps/util-linux/util-linux-2.11y.ebuild b/sys-apps/util-linux/util-linux-2.11y.ebuild
index 3e0fff4e1c99..0884dfd16b3c 100644
--- a/sys-apps/util-linux/util-linux-2.11y.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11y.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11y.ebuild,v 1.4 2002/12/13 17:24:58 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11y.ebuild,v 1.5 2002/12/16 18:03:51 azarah Exp $
IUSE="crypt nls"
+inherit eutils
+
CRYPT_PATCH_P="${P}-crypt-gentoo"
S="${WORKDIR}/${P}"
DESCRIPTION="Various useful Linux utilities"
@@ -11,9 +13,10 @@ SRC_URI="http://www.kernel.org/pub/linux/utils/${PN}/${P}.tar.bz2
crypt? ( http://gentoo.twobit.net/misc/${CRYPT_PATCH_P}.patch.gz )"
# Patched for 2.11y -- NJ <carpaski@gentoo.org)
# crypt? ( http://www.kernel.org/pub/linux/kernel/people/hvr/util-linux-patch-int/${CRYPT_PATCH_P}.patch.gz )"
-
HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
+
KEYWORDS="x86 ppc sparc alpha"
+SLOT="0"
LICENSE="GPL-2"
DEPEND="virtual/glibc
@@ -23,7 +26,6 @@ DEPEND="virtual/glibc
RDEPEND="${DEPEND} sys-devel/perl
nls? ( sys-devel/gettext )"
-SLOT="0"
src_unpack() {
unpack ${A}
@@ -32,9 +34,12 @@ src_unpack() {
if [ ! -z "`use crypt`" ]
then
- gunzip -c ${DISTDIR}/${CRYPT_PATCH_P}.patch.gz | patch -p1 || die "crypto patch"
+ epatch ${DISTDIR}/${CRYPT_PATCH_P}.patch.gz
fi
+ # Fix rare failures with -j4 or higher
+ epatch ${FILESDIR}/${P}-parallel-make.patch
+
cp MCONFIG MCONFIG.orig
sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
-e "s:CPU=.*:CPU=${CHOST%%-*}:" \