summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-26 11:53:13 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-26 11:53:13 +0000
commit89ffb63eeab7e410f215f5be0995eec244f39563 (patch)
tree06c5ba87695ae33a9d5cadf5b57f762bc076e0b7 /sys-apps/which
parentAnother touchup... Getting a bit rediculous... Don't you think? (diff)
downloadhistorical-89ffb63eeab7e410f215f5be0995eec244f39563.tar.gz
historical-89ffb63eeab7e410f215f5be0995eec244f39563.tar.bz2
historical-89ffb63eeab7e410f215f5be0995eec244f39563.zip
cleanup
Diffstat (limited to 'sys-apps/which')
-rw-r--r--sys-apps/which/files/which-gentoo.patch14
-rw-r--r--sys-apps/which/which-2.12-r2.ebuild21
-rw-r--r--sys-apps/which/which-2.13.ebuild20
3 files changed, 36 insertions, 19 deletions
diff --git a/sys-apps/which/files/which-gentoo.patch b/sys-apps/which/files/which-gentoo.patch
new file mode 100644
index 000000000000..3422b5042b35
--- /dev/null
+++ b/sys-apps/which/files/which-gentoo.patch
@@ -0,0 +1,14 @@
+diff -r -C2 which-2.12.orig/which.texinfo which-2.12/which.texinfo
+*** which-2.13.orig/which.texinfo Thu Jul 6 07:26:39 2000
+--- which-2.13/which.texinfo Fri Aug 3 17:23:52 2001
+***************
+*** 9,12 ****
+--- 9,16 ----
+
+ @ifinfo
++ @direntry
++ * which: (which). show full path of commands.
++ @end direntry
++
+ @format
+
diff --git a/sys-apps/which/which-2.12-r2.ebuild b/sys-apps/which/which-2.12-r2.ebuild
index 76672c3415e1..e6343b692017 100644
--- a/sys-apps/which/which-2.12-r2.ebuild
+++ b/sys-apps/which/which-2.12-r2.ebuild
@@ -1,22 +1,24 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.12-r2.ebuild,v 1.5 2002/07/14 19:20:20 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.12-r2.ebuild,v 1.6 2002/07/26 11:53:13 blizzy Exp $
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
DESCRIPTION="Prints out location of specified executables that are in your path"
-SRC_URI="ftp://prep.ai.mit.edu/gnu/which/${A}"
HOMEPAGE="http://www.xs4all.nl/~carlo17/which/"
-KEYWORDS="x86"
-SLOT="0"
+SRC_URI="http://www.xs4all.nl/~carlo17/which/${P}.tar.gz"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="virtual/glibc
+ sys-apps/texinfo"
+DEPEND="${RDEPEND}"
-DEPEND="virtual/glibc sys-apps/texinfo"
+S="${WORKDIR}/${P}"
src_unpack() {
unpack ${A}
- cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}
+ patch -p1 -i ${FILESDIR}/which-gentoo.patch || die
}
src_compile() {
@@ -30,4 +32,3 @@ src_install() {
doinfo which.info
dodoc AUTHORS COPYING EXAMPLES NEWS README*
}
-
diff --git a/sys-apps/which/which-2.13.ebuild b/sys-apps/which/which-2.13.ebuild
index bb57d037424c..ff3d4c9ee68a 100644
--- a/sys-apps/which/which-2.13.ebuild
+++ b/sys-apps/which/which-2.13.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.13.ebuild,v 1.4 2002/07/16 05:51:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.13.ebuild,v 1.5 2002/07/26 11:53:13 blizzy Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Prints out location of specified executables that are in your path"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/which/${P}.tar.gz"
HOMEPAGE="http://www.xs4all.nl/~carlo17/which/"
-KEYWORDS="x86 ppc"
-SLOT="0"
+SRC_URI="http://www.xs4all.nl/~carlo17/which/${P}.tar.gz"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
-DEPEND="virtual/glibc sys-apps/texinfo"
+RDEPEND="virtual/glibc
+ sys-apps/texinfo"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
src_unpack() {
unpack ${A}
- cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+ cd ${S}
+ patch -p1 -i ${FILESDIR}/which-gentoo.patch || die
}
src_compile() {
@@ -29,4 +32,3 @@ src_install() {
doinfo which.info
dodoc AUTHORS COPYING EXAMPLES NEWS README*
}
-