summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-20 17:22:23 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-20 17:22:23 +0000
commitd85cdfe5684006ef87b5f07a62570704b9f5ad3e (patch)
treedc9cef89936058217f65b8c1d02001eef026dc05 /sys-apps/xinetd
parentmasking xinetd-2.3.5 for testing - please test (diff)
downloadhistorical-d85cdfe5684006ef87b5f07a62570704b9f5ad3e.tar.gz
historical-d85cdfe5684006ef87b5f07a62570704b9f5ad3e.tar.bz2
historical-d85cdfe5684006ef87b5f07a62570704b9f5ad3e.zip
version bump - no other changes - please test
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/ChangeLog8
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.51
-rw-r--r--sys-apps/xinetd/xinetd-2.3.5.ebuild50
3 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/xinetd/ChangeLog b/sys-apps/xinetd/ChangeLog
index d67074a2204e..7f70dfa930c7 100644
--- a/sys-apps/xinetd/ChangeLog
+++ b/sys-apps/xinetd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/xinetd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.2 2002/03/30 15:30:48 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/ChangeLog,v 1.3 2002/06/20 17:22:23 bangert Exp $
+
+*xinetd-2.3.5 (20 Jun 2002)
+
+ 20 Jun 2002; Seemant Kulleen <seemant@gentoo.org> xinetd-2.3.5.ebuild :
+
+ Version bump -- copied the 2.3.4 ebuild over.
*xinetd-2.3.4 (30 Mar 2002)
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.5 b/sys-apps/xinetd/files/digest-xinetd-2.3.5
new file mode 100644
index 000000000000..9716e5342558
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.5
@@ -0,0 +1 @@
+MD5 a8a9b429ff491e88fb65a7d7822fd261 xinetd-2.3.5.tar.gz 269473
diff --git a/sys-apps/xinetd/xinetd-2.3.5.ebuild b/sys-apps/xinetd/xinetd-2.3.5.ebuild
new file mode 100644
index 000000000000..31d8bebbbf4f
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.5.ebuild,v 1.1 2002/06/20 17:22:23 bangert Exp $
+
+# NB: This ebuild introduces the /etc/xinetd.d includedir with a default
+# /etc/xinetd.conf file. Check your config files if you're upgrading
+# from an older ebuild version. You should browse /etc/xinetd.conf
+# and the files in /etc/xinetd.d. Everything is off by default with
+# access restricted to localhost.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Xinetd is a powerful replacement for inetd, with advanced features"
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+DEPEND="virtual/glibc tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+RDEPEND="virtual/glibc sys-devel/perl"
+
+src_compile() {
+
+ local myconf
+ use tcpd && myconf="--with-libwrap"
+
+ ./configure --with-loadavg --host=${CHOST} ${myconf} || die
+
+ # Parallel make does not work
+ make || die
+}
+
+src_install() {
+
+ into /usr ; dosbin xinetd/xinetd xinetd/itox
+ exeinto /usr/sbin ; doexe ${FILESDIR}/xconv.pl
+
+ newman xinetd/xinetd.conf.man xinetd.conf.5
+ newman xinetd/xinetd.log.man xinetd.log.8
+ newman xinetd/xinetd.man xinetd.8
+ doman xinetd/itox.8
+
+ newdoc xinetd/sample.conf xinetd.conf.dist.sample
+ newdoc ${FILESDIR}/xinetd.conf xinetd.conf.default
+ dodoc AUDIT CHANGELOG README COPYRIGHT
+
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/etc.xinetd.d/*
+ exeinto /etc/init.d ; newexe ${FILESDIR}/xinetd.rc6 xinetd
+ insinto /etc/conf.d ; newins ${FILESDIR}/xinetd.confd xinetd
+ insinto /etc ; doins ${FILESDIR}/xinetd.conf
+}